summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorPhilippe Schenker <philippe.schenker@toradex.com>2020-12-02 10:00:12 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2020-12-08 15:02:17 +0100
commit2143d5c3299d00abd3b86a3a6b7a9465a7e0c49f (patch)
tree21fa1a79be19f00f279b927b5d86ca51eef33bf0 /recipes-graphics
parentc6326b7a6f3dc060c9083c2b8cba95179d024233 (diff)
tdx-reference-multimedia-images: choose different qt demos
For low-end modules without GPU only show the QT analogclock. For TK1 also choose a different QT-demo. Related-to: ELB-3153 Signed-off-by: Philippe Schenker <philippe.schenker@toradex.com> (cherry picked from commit c79cc904871adae96d1c0d0743c5a2605cb25e20)
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb9
-rw-r--r--recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb9
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb9
3 files changed, 27 insertions, 0 deletions
diff --git a/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb
new file mode 100644
index 0000000..d11611e
--- /dev/null
+++ b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be launched right after weston started
+
+INITIAL_APP_PKGS ?= "qtbase-examples qtwayland"
+INITIAL_PATH ?= ""
+APPLICATION_ENVIRONMENT ?= '\"QT_QPA_PLATFORM=wayland-egl\"'
+WAYLAND_APPLICATION ?= "/usr/share/examples/gui/analogclock/analogclock"
+
+require wayland-app-launch.inc
diff --git a/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb
new file mode 100644
index 0000000..b85fdf0
--- /dev/null
+++ b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be launched right after weston started
+
+INITIAL_APP_PKGS ?= "qtsmarthome qtwayland"
+INITIAL_PATH ?= "/usr/share/qtsmarthome-1.0/"
+APPLICATION_ENVIRONMENT ?= '\"QT_QPA_PLATFORM=wayland-egl\"'
+WAYLAND_APPLICATION ?= "${INITIAL_PATH}/smarthome"
+
+require wayland-app-launch.inc
diff --git a/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb
new file mode 100644
index 0000000..c9bfd7a
--- /dev/null
+++ b/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be started
+
+INITIAL_APP_PKGS ?= "qtbase-examples"
+INITIAL_PATH ?= ""
+X_APPLICATION ?= "/usr/share/examples/gui/analogclock/analogclock"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/x-window-simple-app:"
+require recipes-graphics/x-window-simple-app/x-window-simple-app.inc