summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-01-05 14:15:08 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2014-04-01 10:11:34 +0200
commit91962fabf7d312efb6fd7ab970b55ad5923f2f5c (patch)
tree813b0895bf9f563d835f0118c280dade7f4dfb8a /recipes-kernel
parent5e1244928fffe8ba82218595a70fb6eda7999373 (diff)
colibri-vf: use meta-fsl* layer for BSP files
remove the files copied from meta-fsl* for Colibri-VF V2.1 move the colibri-vf u-boot and kernel stuff to meta-fsl-arm-extra
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex-vf_git.bb52
1 files changed, 0 insertions, 52 deletions
diff --git a/recipes-kernel/linux/linux-toradex-vf_git.bb b/recipes-kernel/linux/linux-toradex-vf_git.bb
deleted file mode 100644
index b5e8bb8..0000000
--- a/recipes-kernel/linux/linux-toradex-vf_git.bb
+++ /dev/null
@@ -1,52 +0,0 @@
-inherit kernel
-require recipes-kernel/linux/linux.inc
-
-LINUX_VERSION ?= "3.0.15"
-
-SRCREV_colibri-vf = "72249651843f93d50c302833546fb2880052a80f"
-PR_colibri-vf = "V2.1b3"
-
-PV = "${LINUX_VERSION}+gitr${SRCREV}"
-S = "${WORKDIR}/git"
-SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=colibri_vf"
-# a Patch
-# SRC_URI += "file://a.patch "
-
-COMPATIBLE_MACHINE_colibri-vf = "colibri-vf"
-
-# Place changes to the defconfig here
-config_script () {
-# #example change to the .config
-# #sets CONFIG_TEGRA_CAMERA unconditionally to 'y'
-# sed -i -e /CONFIG_TEGRA_CAMERA/d ${S}/.config
-# echo "CONFIG_TEGRA_CAMERA=y" >> ${S}/.config
- echo "dummy" > /dev/null
-}
-
-do_configure_prepend () {
- #use the defconfig provided in the kernel source tree
- #assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
- DEFCONFIG="`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`"
-
- oe_runmake $DEFCONFIG
-
- #maybe change some configuration
- config_script
-}
-
-kernel_do_compile() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
- oe_runmake ${KERNEL_IMAGETYPE_FOR_MAKE} ${KERNEL_ALT_IMAGETYPE} LD="${KERNEL_LD}"
- if test "${KERNEL_IMAGETYPE_FOR_MAKE}.gz" = "${KERNEL_IMAGETYPE}"; then
- gzip -9c < "${KERNEL_IMAGETYPE_FOR_MAKE}" > "${KERNEL_OUTPUT}"
- fi
-}
-
-do_compile_kernelmodules() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
- if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
- oe_runmake ${PARALLEL_MAKE} modules LD="${KERNEL_LD}"
- else
- bbnote "no modules to compile"
- fi
-}