summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-10-10 19:10:02 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-10-10 19:10:02 +0200
commitf498512a668290f1ea84988d6fa8bd83906c222b (patch)
treeebda04e37fe52178c1f336b9a369158f36d4f408 /recipes-kernel
parent0e1426d82c5bf39c7b43cdc475f1efedcc67e71c (diff)
colibri-vf50: add the machine, kernel and u-boot
- also add the relevant configuration files
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex-vf_git.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex-vf_git.bb b/recipes-kernel/linux/linux-toradex-vf_git.bb
new file mode 100644
index 0000000..185f90f
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-vf_git.bb
@@ -0,0 +1,57 @@
+inherit kernel
+require recipes-kernel/linux/linux.inc
+
+LINUX_VERSION ?= "3.0.15"
+
+SRCREV_colibri-vf50 = "5746e7e3d1376c80ae7f512d110adbcbad3e7000"
+PR_colibri-vf50 = "V2.1a1"
+
+PV = "${LINUX_VERSION}+gitr${SRCREV}"
+S = "${WORKDIR}/git"
+SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=colibri_vf"
+# a Patch
+# SRC_URI += "file://a.patch "
+
+
+COMPATIBLE_MACHINE_colibri-vf50 = "colibri-vf50"
+
+# Place changes to the defconfig here
+config_script () {
+# #example change to the .config
+# #sets CONFIG_TEGRA_CAMERA unconditionally to 'y'
+# sed -i -e /CONFIG_TEGRA_CAMERA/d ${S}/.config
+# echo "CONFIG_TEGRA_CAMERA=y" >> ${S}/.config
+ sed -i -e /CONFIG_VFPv3/d ${S}/.config
+ echo "CONFIG_VFPv3=y" >> ${S}/.config
+ sed -i -e /CONFIG_NEON/d ${S}/.config
+ echo "CONFIG_NEON=y" >> ${S}/.config
+ echo "dummy" > /dev/null
+}
+
+do_configure_prepend () {
+ #use the defconfig provided in the kernel source tree
+ #assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
+ DEFCONFIG=`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`
+
+ oe_runmake $DEFCONFIG
+
+ #maybe change some configuration
+ config_script
+}
+
+kernel_do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
+ oe_runmake ${KERNEL_IMAGETYPE_FOR_MAKE} ${KERNEL_ALT_IMAGETYPE} LD="${KERNEL_LD}"
+ if test "${KERNEL_IMAGETYPE_FOR_MAKE}.gz" = "${KERNEL_IMAGETYPE}"; then
+ gzip -9c < "${KERNEL_IMAGETYPE_FOR_MAKE}" > "${KERNEL_OUTPUT}"
+ fi
+}
+
+do_compile_kernelmodules() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
+ if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
+ oe_runmake ${PARALLEL_MAKE} modules LD="${KERNEL_LD}"
+ else
+ bbnote "no modules to compile"
+ fi
+}