summaryrefslogtreecommitdiff
path: root/recipes-qt/qt4/qt4-x11-free-systemd.bb
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2014-11-27 13:48:05 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-12-08 02:20:43 +0100
commit61f49e7c40c9151a44b1750633dda6eb7b882603 (patch)
treee50fed97cf6a7df19b6a7f9945f3161f356949e0 /recipes-qt/qt4/qt4-x11-free-systemd.bb
parent109e1b90ec072be6e625b8afb68c6cf5a245d130 (diff)
qt4-x11-free-systemd.bb: move init script to /usr/bin
Due to the move to systemd, all init scripts located under /etc/init.d get deleted by the inherited systemd recipes (systemd.inc). Since we don't use the script as a system V init script, we can move the script to /usr/bin.
Diffstat (limited to 'recipes-qt/qt4/qt4-x11-free-systemd.bb')
-rw-r--r--recipes-qt/qt4/qt4-x11-free-systemd.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-qt/qt4/qt4-x11-free-systemd.bb b/recipes-qt/qt4/qt4-x11-free-systemd.bb
index 681a14d..cb5fce2 100644
--- a/recipes-qt/qt4/qt4-x11-free-systemd.bb
+++ b/recipes-qt/qt4/qt4-x11-free-systemd.bb
@@ -13,10 +13,9 @@ inherit allarch systemd
SRC_URI = "file://qtdemo.service \
file://qtdemo-init "
-FILES_${PN} += " ${sysconfdir}/init.d "
do_install () {
- install -d ${D}/${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/qtdemo-init ${D}/${sysconfdir}/init.d/
+ install -d ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/qtdemo-init ${D}/${bindir}
install -d ${D}${systemd_unitdir}/system/
install -m 0644 ${WORKDIR}/qtdemo.service ${D}${systemd_unitdir}/system