summaryrefslogtreecommitdiff
path: root/recipes-qt/qt4/qt4-x11-free-systemd.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2015-10-21 15:13:45 +0200
committerMax Krummenacher <max.oss.09@gmail.com>2015-10-28 09:36:02 +0100
commit9195c842d31f53ac73f5e2ab507638a26676a7a5 (patch)
treec07bcc0efcee2b5ff4816380be0cdb326d0f73ac /recipes-qt/qt4/qt4-x11-free-systemd.bb
parent8a6d1bb3afe9e76156d7999e720527a4f1b3a871 (diff)
qt4-x11-free-systemd: change filenames for systemd service
qtdemo-init exists in another recipe for qte. When both recipes are built we get an error during sysroot deployment.
Diffstat (limited to 'recipes-qt/qt4/qt4-x11-free-systemd.bb')
-rw-r--r--recipes-qt/qt4/qt4-x11-free-systemd.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-qt/qt4/qt4-x11-free-systemd.bb b/recipes-qt/qt4/qt4-x11-free-systemd.bb
index 45ea962..426f632 100644
--- a/recipes-qt/qt4/qt4-x11-free-systemd.bb
+++ b/recipes-qt/qt4/qt4-x11-free-systemd.bb
@@ -10,17 +10,17 @@ PR = "r1"
inherit allarch systemd
-SRC_URI = "file://qtdemo.service \
- file://qtdemo-init "
+SRC_URI = "file://qt4-x11-demo.service \
+ file://qt4-x11-demo-init "
do_install () {
install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/qtdemo-init ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/qt4-x11-demo-init ${D}/${bindir}
install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/qtdemo.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/qt4-x11-demo.service ${D}${systemd_unitdir}/system
}
NATIVE_SYSTEMD_SUPPORT = "1"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "qtdemo.service"
+SYSTEMD_SERVICE_${PN} = "qt4-x11-demo.service"