summaryrefslogtreecommitdiff
path: root/recipes-qt/qt4
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-07-26 20:24:02 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-09-22 11:09:16 +0200
commit5aea1a72f85f7f61c5f928091302b8d78c150c91 (patch)
tree209e99ee3e47a8d354f4c065ac1390b00da67cd0 /recipes-qt/qt4
parent6ba56ffacf174340a60d91eedcda1c1e8aaf37a9 (diff)
systemd: adapt to new systemd handling
with the move from meta-openembedded to oe-core some things have changed, e.g. the config files have to explicitly installed
Diffstat (limited to 'recipes-qt/qt4')
-rw-r--r--recipes-qt/qt4/qt4-x11-free-systemd.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/qt4/qt4-x11-free-systemd.bb b/recipes-qt/qt4/qt4-x11-free-systemd.bb
index 2c8227c..3e426f9 100644
--- a/recipes-qt/qt4/qt4-x11-free-systemd.bb
+++ b/recipes-qt/qt4/qt4-x11-free-systemd.bb
@@ -17,6 +17,9 @@ FILES_${PN} += " ${sysconfdir}/init.d "
do_install () {
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/qtdemo-init ${D}/${sysconfdir}/init.d/
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/qtdemo.service ${D}${systemd_unitdir}/system
}
NATIVE_SYSTEMD_SUPPORT = "1"