summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2016-05-24 13:19:07 -0700
committerMax Krummenacher <max.krummenacher@toradex.com>2016-06-30 13:28:27 +0200
commit703c0c0ebdfc938360f16538607c5ea0d3df5535 (patch)
treeef0be5d39924a1a9aeba8ebea2fdf8a8123c6868 /recipes-support
parent1292f8746a6ab27c6f8c9c3053d500d83bf6fb29 (diff)
florence: move to latest GTK2 version 0.5.4
The latest GTK2 version is 0.5.4, which contains several bug fixes. Noteable, it fixes an issue where the SVG keys have not been displayed with recent versions of its dependencies. Note: This adds GStreamer 0.10 dependency... Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/florence/files/fix-no-atspi-compile.patch30
-rw-r--r--recipes-support/florence/florence_0.5.1.bbappend6
-rw-r--r--recipes-support/florence/florence_0.5.4.bb21
3 files changed, 51 insertions, 6 deletions
diff --git a/recipes-support/florence/files/fix-no-atspi-compile.patch b/recipes-support/florence/files/fix-no-atspi-compile.patch
new file mode 100644
index 0000000..0bb5dee
--- /dev/null
+++ b/recipes-support/florence/files/fix-no-atspi-compile.patch
@@ -0,0 +1,30 @@
+diff --git a/src/florence.c b/src/florence.c
+index b27c31b..feadefe 100644
+--- a/src/florence.c
++++ b/src/florence.c
+@@ -44,12 +44,6 @@
+ /* exit signal */
+ static int flo_exit=FALSE;
+
+-#ifdef ENABLE_AT_SPI2
+-void flo_check_show (struct florence *florence, AtspiAccessible *obj);
+-#else
+-void flo_check_show (struct florence *florence, Accessible *obj);
+-#endif
+-
+ /* Called on destroy event (systray quit or close window) */
+ void flo_destroy (void)
+ {
+@@ -61,6 +55,12 @@ void flo_destroy (void)
+ }
+
+ #ifdef AT_SPI
++#ifdef ENABLE_AT_SPI2
++void flo_check_show (struct florence *florence, AtspiAccessible *obj);
++#else
++void flo_check_show (struct florence *florence, Accessible *obj);
++#endif
++
+ /* Called to destroy the icon */
+ void flo_icon_destroy (GtkWidget *widget, gpointer user_data)
+ {
diff --git a/recipes-support/florence/florence_0.5.1.bbappend b/recipes-support/florence/florence_0.5.1.bbappend
deleted file mode 100644
index d15d369..0000000
--- a/recipes-support/florence/florence_0.5.1.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-RDEPENDS_${PN} += "librsvg-gtk"
-SRC_URI += " \
- file://fix_garbled_titlebar.patch \
-"
diff --git a/recipes-support/florence/florence_0.5.4.bb b/recipes-support/florence/florence_0.5.4.bb
new file mode 100644
index 0000000..7321a9c
--- /dev/null
+++ b/recipes-support/florence/florence_0.5.4.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Florence is a virtual keyboard (also called on-screen-keyboard), which allows the user to input text through a touchscreen."
+HOMEPAGE = "http://florence.sourceforge.net/english.html"
+
+#NOTICE: If florence can't find its gconf settings, you need to start florence with --config for one time and save the configuration once.
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+
+PR = "r1"
+
+DEPENDS = "gtk+ libxml2 libglade librsvg libxtst gconf cairo intltool-native gnome-doc-utils libnotify gstreamer"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/florence/florence/${PV}-gtk2/florence-${PV}.tar.bz2 \
+ file://fix-no-atspi-compile.patch \
+ file://fix_garbled_titlebar.patch"
+SRC_URI[md5sum] = "8d5c2367a28485bfcf577650b0badab7"
+SRC_URI[sha256sum] = "26d33aa20d5fbf34ceeded4c41cb922d2988b6082e33d9acc46dd7bfe56d31a1"
+
+inherit gettext autotools gconf pkgconfig
+
+EXTRA_OECONF = "--disable-scrollkeeper --without-docs --without-at-spi --without-panelapplet --without-xrecord"