summaryrefslogtreecommitdiff
path: root/recipes/gpioconfig
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-06-19 09:09:54 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2012-06-19 09:09:54 +0200
commit362c0d8250ae1b8d7b2afce5bc4b27075fe82c68 (patch)
treef9fd52c57fb7f7592ff358eed1fe59ec9b3d113c /recipes/gpioconfig
parentb3f0841ade3dc1cbd1b7dd825439cb03a02629d2 (diff)
Update to new NV binary packages L4T R15
Removed nvrm_deamon and corresponding init.d script Kernel from git.toradex.int
Diffstat (limited to 'recipes/gpioconfig')
-rwxr-xr-xrecipes/gpioconfig/files/GPIOConfig.desktop~11
-rwxr-xr-xrecipes/gpioconfig/files/Makefile31
-rw-r--r--recipes/gpioconfig/gpioconfig.bb~44
3 files changed, 0 insertions, 86 deletions
diff --git a/recipes/gpioconfig/files/GPIOConfig.desktop~ b/recipes/gpioconfig/files/GPIOConfig.desktop~
deleted file mode 100755
index 4a0e9ac..0000000
--- a/recipes/gpioconfig/files/GPIOConfig.desktop~
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/usr/bin/env xdg-open
-
-[Desktop Entry]
-Version=1.0
-Type=Application
-Terminal=false
-Icon[C]=gnome-panel-launcher
-Exec=/usr/bin/GPIOConfig
-Name[C]=GPIOConfig
-Name=GPIOConfig
-Icon=/usr/share/pixmaps/GPIOConfig.png
diff --git a/recipes/gpioconfig/files/Makefile b/recipes/gpioconfig/files/Makefile
deleted file mode 100755
index 2b0143d..0000000
--- a/recipes/gpioconfig/files/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-CROSS_COMPILE ?= /vibrante/toolchains/tegra2-4.4.1-nv/bin/arm-none-linux-gnueabi-
-CC ?= $(CROSS_COMPILE)gcc
-STRIP ?= $(CROSS_COMPILE)strip
-
-SYSROOT_DIR=/srv/nfs/rootfs-include-lib-gtk
-prefix = ""
-bindir = $(prefix)/usr/bin
-
-CFLAGS ?= -Wall -g -O2 `pkg-config --cflags gtk+-2.0`
-
-#DRV = gpio_usr_drv
-
-PROG = GPIOConfig
-
-OBJS = gpio_gtk.o custom-list.o gpio_usr_drv.o
-
-all: $(OBJS)
-# $(CC) -o $(DRV) $(DRV).c
- $(CC) -o $(PROG) $(OBJS) $(LDFLAGS) `pkg-config --cflags gtk+-2.0` `pkg-config --libs gtk+-2.0` -L $(SYSROOT_DIR)/usr/lib -Wl,--allow-shlib-undefined
- $(STRIP) $(PROG)
-
-%o: %c
- $(CC) $(CFLAGS) $(CPPFLAGS) `pkg-config --cflags gtk+-2.0` -c $<
-
-clean:
- rm -f $(DRV) $(PROG) $(OBJS) *.o~ *.h~ 2>/dev/null
-
-install:
- install -d $(bindir)
- install $(PROG) $(bindir)
-
diff --git a/recipes/gpioconfig/gpioconfig.bb~ b/recipes/gpioconfig/gpioconfig.bb~
deleted file mode 100644
index e5e6435..0000000
--- a/recipes/gpioconfig/gpioconfig.bb~
+++ /dev/null
@@ -1,44 +0,0 @@
-DESCRIPTION = "GPIOConfig tool for Colibri T20"
-SECTION = "base"
-LICENSE = "propriatry"
-PR = "r3"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-DEPENDS = "gtk+"
-RDEPENDS = "gtk+"
-
-S = "${WORKDIR}/target-utils/GPIOConfig"
-
-SVN_REV = "230"
-SRC_URI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=target-utils/GPIOConfig;rev=${SVN_REV};proto=http"
-#SRC_URI += "file://Makefile"
-SRC_URI += "file://GPIOConfig.desktop"
-SRC_URI += "file://GPIOConfig.png"
-
-PACKAGES = "${PN}"
-
-# just don't do any configuring
-do_configure() {
-}
-
-do_install() {
- install -d ${D}/${bindir}
- install -d ${D}/${datadir}/applications
- install -d ${D}/${datadir}/pixmaps
- install ${S}/GPIOConfig ${D}/${bindir}
- install ${WORKDIR}/GPIOConfig.desktop ${D}/${datadir}/applications
- install ${WORKDIR}/GPIOConfig.png ${D}/${datadir}/pixmaps/GPIOConfig.png
-}
-
-pkg_postinst_${PN}() {
- mkdir -p ${base_prefix}/home/root/Desktop
- cp ${datadir}/applications/GPIOConfig.desktop ${base_prefix}/home/root/Desktop/
-}
-
-pkg_postremove_${PN}() {
- rm -f ${base_prefix}/home/Desktop/GPIOConfig.desktop
-}
-
-
-