summaryrefslogtreecommitdiff
path: root/recipes/images
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-02-05 15:04:33 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-02-05 15:04:33 +0100
commitc4088c386f571554d81c4e1b9424e2d64883c43d (patch)
tree9c9f1454572a9fadb38e183aef06ff891dd0a651 /recipes/images
parent41549b8995d30d8e99f4168123e2d9362d77928b (diff)
image: image name now defined in the image.bb files
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/angstrom-lxde-image.bb6
-rw-r--r--recipes/images/console-trdx-image.bb2
-rw-r--r--recipes/images/trdx-image-fstype.inc5
3 files changed, 8 insertions, 5 deletions
diff --git a/recipes/images/angstrom-lxde-image.bb b/recipes/images/angstrom-lxde-image.bb
index 5fad57a..baf5492 100644
--- a/recipes/images/angstrom-lxde-image.bb
+++ b/recipes/images/angstrom-lxde-image.bb
@@ -7,6 +7,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
PV = "V2.0"
PR = "r3"
+#start of the resulting deployable tarball
+IMAGE_NAME_colibri-t20 = "T20_LinuxImage"
+IMAGE_NAME_colibri-t30 = "T30_LinuxImage"
+IMAGE_NAME_apalis-t30 = "ApalisT30_LinuxImage"
+IMAGE_NAME_colibri-pxa = "PXA_LinuxImage"
+
#create the deployment directory-tree
require trdx-image-fstype.inc
diff --git a/recipes/images/console-trdx-image.bb b/recipes/images/console-trdx-image.bb
index 7416d75..b996723 100644
--- a/recipes/images/console-trdx-image.bb
+++ b/recipes/images/console-trdx-image.bb
@@ -1,6 +1,8 @@
#Angstrom image
DESCRIPTION = "Image booting to a console"
+IMAGE_NAME = "${MACHINE}-console-trdx-image"
+
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
diff --git a/recipes/images/trdx-image-fstype.inc b/recipes/images/trdx-image-fstype.inc
index 39f8ff9..4610da5 100644
--- a/recipes/images/trdx-image-fstype.inc
+++ b/recipes/images/trdx-image-fstype.inc
@@ -4,11 +4,6 @@ BURNFLASH := "${THISDIR}/files/${MACHINE}/burnflash.tar.bz2"
S = "${WORKDIR}/burnflash"
-IMAGE_NAME_colibri-t20 = "T20_LinuxImage"
-IMAGE_NAME_colibri-t30 = "T30_LinuxImage"
-IMAGE_NAME_apalis-t30 = "ApalisT30_LinuxImage"
-IMAGE_NAME_colibri-pxa = "PXA_LinuxImage"
-
IMAGE_ROOTFS = "${WORKDIR}/${IMAGE_NAME}${PV}/rootfs"
do_rootfs_prepend() {