summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-01-11 15:48:34 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-03-14 14:26:28 +0100
commit35ac446955c5899725f6cd742224b818d48f9ca0 (patch)
tree962ad404f199cc7fe0276440a8d66f7032fd5541 /recipes
parentf631512ae60b53390cace7d9963f48cb98bad915 (diff)
angstrom-lxde-image: use gstreamer 1.0 for the non tegra machines
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/images/angstrom-lxde-image.bb71
-rw-r--r--recipes/images/angstrom-qt-x11-image.bb1
2 files changed, 62 insertions, 10 deletions
diff --git a/recipes/images/angstrom-lxde-image.bb b/recipes/images/angstrom-lxde-image.bb
index 07cc980..b902bcf 100644
--- a/recipes/images/angstrom-lxde-image.bb
+++ b/recipes/images/angstrom-lxde-image.bb
@@ -43,7 +43,9 @@ ROOTFS_PKGMANAGE_PKGS ?= '${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none
CONMANPKGS ?= "connman connman-client connman-gnome"
CONMANPKGS_libc-uclibc = ""
-DEPENDS += "gst-plugins-good gst-plugins-bad gst-plugins-ugly"
+DEPENDS_tegra += "gst-plugins-good gst-plugins-bad gst-plugins-ugly"
+#do not build plugins-ugly because it would require to whitelist LICENCES without deploying them
+DEPENDS += "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad"
#deploy the OpenGL ES headers to the sysroot
DEPENDS_append_tegra = " nvsamples"
@@ -60,11 +62,66 @@ BAD_RECOMMENDATIONS = "gnome-icon-theme"
BAD_RECOMMENDATIONS_append_colibri-vf = " udev-hwdb cpufrequtils"
# this would pull in a large amount of gst-plugins, we only add a selected few
-# gst-plugins-base-meta
-# gst-plugins-good-meta
-# gst-plugins-bad-meta
+# gstreamer1.0-plugins-base-meta
+# gstreamer1.0-plugins-good-meta
+# gstreamer1.0-plugins-bad-meta
# gst-ffmpeg
GSTREAMER = " \
+ gstreamer1.0 \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-plugins-base-alsa \
+ gstreamer1.0-plugins-base-audioconvert \
+ gstreamer1.0-plugins-base-audioresample \
+ gstreamer1.0-plugins-base-audiotestsrc \
+ gstreamer1.0-plugins-base-typefindfunctions \
+ gstreamer1.0-plugins-base-ivorbisdec \
+ gstreamer1.0-plugins-base-ogg \
+ gstreamer1.0-plugins-base-theora \
+ gstreamer1.0-plugins-base-videotestsrc \
+ gstreamer1.0-plugins-base-vorbis \
+ gstreamer1.0-plugins-good-audioparsers \
+ gstreamer1.0-plugins-good-autodetect \
+ gstreamer1.0-plugins-good-avi \
+ gstreamer1.0-plugins-good-deinterlace \
+ gstreamer1.0-plugins-good-id3demux \
+ gstreamer1.0-plugins-good-isomp4 \
+ gstreamer1.0-plugins-good-matroska \
+ gstreamer1.0-plugins-good-rtp \
+ gstreamer1.0-plugins-good-rtpmanager \
+ gstreamer1.0-plugins-good-udp \
+ gstreamer1.0-plugins-good-video4linux2 \
+ gstreamer1.0-plugins-good-wavenc \
+ gstreamer1.0-plugins-good-wavparse \
+"
+# No longer available
+# gst-plugins-base-decodebin \
+# gst-plugins-base-decodebin2 \
+# gst-plugins-base-playbin \
+# gst-plugins-ugly-asf \
+#"
+
+GSTREAMER_append_mx6 = " \
+ gstreamer1.0-plugins-base-ximagesink \
+ gstreamer1.0-plugins-base-xvimagesink \
+ gstreamer1.0-plugins-imx \
+ gst1.0-fsl-plugin \
+ gst1.0-fsl-plugin-gplay \
+ gst1.0-fsl-plugin-grecorder \
+"
+GSTREAMER_append_mx7 = " \
+ gstreamer1.0-plugins-base-ximagesink \
+ gstreamer1.0-plugins-base-xvimagesink \
+ gst1.0-fsl-plugin \
+ gst1.0-fsl-plugin-gplay \
+ gst1.0-fsl-plugin-grecorder \
+"
+# No longer available
+# gst-plugins-gl \
+# gst-fsl-plugin \
+#
+
+# use gstreamer-0.10 for tegra
+GSTREAMER_tegra = " \
gstreamer \
gst-plugins-base \
gst-plugins-base-alsa \
@@ -98,12 +155,6 @@ GSTREAMER = " \
GSTREAMER_append_tegra3 = " \
gst-plugins-good-jpeg \
"
-GSTREAMER_append_mx6 = " \
- gst-plugins-base-ximagesink \
- gst-plugins-base-xvimagesink \
- gst-plugins-gl \
- gst-fsl-plugin \
-"
GSTREAMER_colibri-vf = ""
IMAGE_INSTALL_append_tegra = " \
diff --git a/recipes/images/angstrom-qt-x11-image.bb b/recipes/images/angstrom-qt-x11-image.bb
index a6f9412..c365762 100644
--- a/recipes/images/angstrom-qt-x11-image.bb
+++ b/recipes/images/angstrom-qt-x11-image.bb
@@ -95,6 +95,7 @@ GSTREAMER_append_mx6 = " \
gst-plugins-base-xvimagesink \
gst-plugins-gl \
gst-fsl-plugin \
+ gpu-viv-bin-mx6q-libraries \
"
GSTREAMER_colibri-vf = ""