summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-10-10 19:10:02 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-10-10 19:10:02 +0200
commitf498512a668290f1ea84988d6fa8bd83906c222b (patch)
treeebda04e37fe52178c1f336b9a369158f36d4f408 /recipes
parent0e1426d82c5bf39c7b43cdc475f1efedcc67e71c (diff)
colibri-vf50: add the machine, kernel and u-boot
- also add the relevant configuration files
Diffstat (limited to 'recipes')
-rw-r--r--recipes/base-files/base-files/colibri-vf50/fstab14
-rw-r--r--recipes/base-files/base-files/colibri-vf50/profile35
-rw-r--r--recipes/base-files/base-files_3.0.14.bbappend2
3 files changed, 50 insertions, 1 deletions
diff --git a/recipes/base-files/base-files/colibri-vf50/fstab b/recipes/base-files/base-files/colibri-vf50/fstab
new file mode 100644
index 0000000..fea4501
--- /dev/null
+++ b/recipes/base-files/base-files/colibri-vf50/fstab
@@ -0,0 +1,14 @@
+# stock fstab - you probably want to override this with a machine specific one
+
+rootfs / auto defaults 1 1
+proc /proc proc defaults 0 0
+debugfs /sys/kernel/debug debugfs defaults 0 0
+devpts /dev/pts devpts mode=0620,gid=5 0 0
+usbfs /proc/bus/usb usbfs defaults 0 0
+tmpfs /var/volatile tmpfs defaults 0 0
+tmpfs /dev/shm tmpfs mode=0777 0 0
+tmpfs /media/ram tmpfs defaults 0 0
+
+# uncomment this if your device has a SD/MMC/Transflash slot
+#/dev/mmcblk0p1 /media/card auto defaults,sync,noauto 0 0
+
diff --git a/recipes/base-files/base-files/colibri-vf50/profile b/recipes/base-files/base-files/colibri-vf50/profile
new file mode 100644
index 0000000..c1ee240
--- /dev/null
+++ b/recipes/base-files/base-files/colibri-vf50/profile
@@ -0,0 +1,35 @@
+# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
+# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
+
+PATH="/usr/local/bin:/usr/bin:/bin"
+EDITOR="/bin/vi" # needed for packages like cron
+test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
+
+if [ ! -e /etc/localtime ]; then
+ TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
+ # for an explanation of how to set this to your local timezone.
+ export TZ
+fi
+
+if [ "$HOME" = "/home/root" ]; then
+ PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin
+fi
+if [ "$PS1" ]; then
+# works for bash and ash (no other shells known to be in use here)
+ PS1='\u@\h:\w\$ '
+fi
+
+if [ -d /etc/profile.d ]; then
+ for i in /etc/profile.d/* ; do
+ . $i
+ done
+ unset i
+fi
+
+test -z "$DISPLAY" && DISPLAY=":0.0" # have the X display defined, unless it is already set, e.g. by a ssh connection
+export DISPLAY
+
+export PATH PS1 OPIEDIR QPEDIR QTDIR EDITOR TERM
+
+umask 022
+
diff --git a/recipes/base-files/base-files_3.0.14.bbappend b/recipes/base-files/base-files_3.0.14.bbappend
index 0211321..d9ecab1 100644
--- a/recipes/base-files/base-files_3.0.14.bbappend
+++ b/recipes/base-files/base-files_3.0.14.bbappend
@@ -1,4 +1,4 @@
-PRINC = "4"
+PRINC = "5"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"