summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-benchmark/fio/fio_3.29.bb49
-rw-r--r--recipes-benchmark/memtester/files/Makefile.patch28
-rw-r--r--recipes-benchmark/memtester/memtester_4.5.1.bb25
-rw-r--r--recipes-connectivity/bluez-alsa/bluez-alsa_git.bb79
-rw-r--r--recipes-connectivity/bluez-alsa/files/0001-Fix-linkage-mark-external-variable-as-extern.patch65
-rw-r--r--recipes-connectivity/bluez-alsa/files/bluez-alsa.service11
-rw-r--r--recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch41
-rw-r--r--recipes-connectivity/connman/connman/0001-connman-clock-ntp-client-should-not-update-time-time.patch (renamed from recipes-connectivity/connman/connman/0003-connman-clock-ntp-client-should-not-update-time-time.patch)0
-rw-r--r--recipes-connectivity/connman/connman/0001-connman.service.in-don-t-start-if-nfs-boot.patch33
-rw-r--r--recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch28
-rw-r--r--recipes-connectivity/connman/connman_%.bbappend7
-rw-r--r--recipes-connectivity/wpa-supplicant/wpa-supplicant_%.bbappend4
-rw-r--r--recipes-core/base-files/base-files/fstab2
-rw-r--r--recipes-devtools/run-postinsts/run-postinsts/run-postinsts.service16
-rw-r--r--recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend1
-rw-r--r--recipes-devtools/socketcan/can-utils_git.bbappend1
-rw-r--r--recipes-images/images/packagegroup-tdx-cli.bb9
-rw-r--r--recipes-images/images/packagegroup-tdx-graphical.bb2
-rw-r--r--recipes-images/images/packagegroup-tdx-qt5.bb4
-rw-r--r--recipes-images/images/tdx-reference-minimal-image.bb5
-rw-r--r--recipes-images/images/tdx-reference-multimedia-image.bb8
-rw-r--r--recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch19
-rw-r--r--recipes-support/mcc-pingpong/mcc-pingpong/update-mcc_free_buffer-call.patch19
-rw-r--r--recipes-support/tdx-oak-sensors/tdx-oak-sensors_0082.bb2
24 files changed, 220 insertions, 238 deletions
diff --git a/recipes-benchmark/fio/fio_3.29.bb b/recipes-benchmark/fio/fio_3.29.bb
new file mode 100644
index 0000000..40f2b2a
--- /dev/null
+++ b/recipes-benchmark/fio/fio_3.29.bb
@@ -0,0 +1,49 @@
+SUMMARY = "Filesystem and hardware benchmark and stress tool"
+DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
+stress/hardware verification. It has support for a number of I/O engines, \
+I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
+and much more. It can work on block devices as well as files. fio accepts \
+job descriptions in a simple-to-understand text format. Several example job \
+files are included. fio displays all sorts of I/O performance information."
+HOMEPAGE = "http://freecode.com/projects/fio"
+SECTION = "console/tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "libaio zlib coreutils-native"
+DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}"
+RDEPENDS_${PN} = "python3-core bash"
+
+PACKAGECONFIG_NUMA = "numa"
+# ARM does not currently support NUMA
+PACKAGECONFIG_NUMA_arm = ""
+PACKAGECONFIG_NUMA_armeb = ""
+
+PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
+PACKAGECONFIG[numa] = ",--disable-numa,numactl"
+
+SRCREV = "9b46661c289d01dbfe5182189a7abea9ce2f9e04"
+SRC_URI = "git://git.kernel.dk/fio.git;branch=master \
+"
+
+S = "${WORKDIR}/git"
+
+# avoids build breaks when using no-static-libs.inc
+DISABLE_STATIC = ""
+
+EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
+EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}"
+
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
+ install -d ${D}/${docdir}/${PN}
+ cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
+
+}
+
+
diff --git a/recipes-benchmark/memtester/files/Makefile.patch b/recipes-benchmark/memtester/files/Makefile.patch
new file mode 100644
index 0000000..971e52a
--- /dev/null
+++ b/recipes-benchmark/memtester/files/Makefile.patch
@@ -0,0 +1,28 @@
+From 9a950b14b9f7767d83e5faac2e1e8203c500e2c2 Mon Sep 17 00:00:00 2001
+From: Rod Whitby <rod@whitby.id.au>
+Date: Tue, 25 Oct 2011 18:43:50 -0500
+Subject: [PATCH] memtester: Added patch to Makefile to change no-longer-supported 'head -1' syntax to 'head -n 1'.
+
+Signed-off-by: Joel A Fernandes <joelagnel@ti.com>
+---
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index a271bf5..6bccff3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -32,8 +32,8 @@ install: all
+ auto-ccld.sh: \
+ conf-cc conf-ld warn-auto.sh
+ ( cat warn-auto.sh; \
+- echo CC=\'`head -1 conf-cc`\'; \
+- echo LD=\'`head -1 conf-ld`\' \
++ echo CC=\'`head -n 1 conf-cc`\'; \
++ echo LD=\'`head -n 1 conf-ld`\' \
+ ) > auto-ccld.sh
+
+ compile: \
+--
+1.7.0.4
+
diff --git a/recipes-benchmark/memtester/memtester_4.5.1.bb b/recipes-benchmark/memtester/memtester_4.5.1.bb
new file mode 100644
index 0000000..1628a05
--- /dev/null
+++ b/recipes-benchmark/memtester/memtester_4.5.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Utility to test for faulty memory subsystem"
+HOMEPAGE = "http://pyropus.ca/software/memtester/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+SRC_URI = "http://pyropus.ca/software/memtester/old-versions/${BP}.tar.gz \
+ file://Makefile.patch \
+ "
+SRC_URI[md5sum] = "1bc22c01e987d6a67fac39dc5656a4d3"
+SRC_URI[sha256sum] = "1c5fc2382576c084b314cfd334d127a66c20bd63892cac9f445bc1d8b4ca5a47"
+
+do_compile () {
+ echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
+ echo '${CC} ${LDFLAGS}' > conf-ld
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man8
+ install -m 0755 memtester ${D}${bindir}/
+ install -m 0755 memtester.8 ${D}${mandir}/man8/
+}
diff --git a/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb b/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
index 085792d..dd04c2c 100644
--- a/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
+++ b/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
@@ -3,45 +3,64 @@ HOMEPAGE = "https://github.com/Arkq/bluez-alsa"
SECTION = "libs"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=bb3e99e80c5d718213f35ae1def4c106"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8449a4f133a93f6254b496d4fb476e83"
-SRC_URI = " \
- git://github.com/Arkq/bluez-alsa.git;protocol=https;branch=master \
- file://0001-Fix-linkage-mark-external-variable-as-extern.patch \
-"
-
-SRCREV = "9045edb436ea755f395a2e09e4525b5defad286a"
+SRC_URI = "git://github.com/Arkq/bluez-alsa.git;protocol=https;branch=master"
-SRC_URI += "file://bluez-alsa.service"
+SRCREV = "dd05a1baa261b94da9ba977b5e3392c8b4dc7a5e"
+PV = "4.0.0+git${SRCPV}"
S = "${WORKDIR}/git"
-DEPENDS += "alsa-lib bluez5 systemd glib-2.0 sbc"
+DEPENDS += "alsa-lib bluez5 dbus glib-2.0 sbc"
-PACKAGECONFIG[aac] = "--enable-aac, --disable-aac, "
-PACKAGECONFIG[aptx] = "--enable-aptx,--disable-aptx,"
-PACKAGECONFIG[hcitop] = "--enable-hcitop, --disable-hcitop, libbsd ncurses"
+PACKAGECONFIG ??= "aplay cli hcitop ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[a2dpconf] = "--enable-a2dpconf,--disable-a2dpconf"
+PACKAGECONFIG[aac] = "--enable-aac,--disable-aac,fdk-aac"
+PACKAGECONFIG[aplay] = "--enable-aplay,--disable-aplay"
+PACKAGECONFIG[cli] = "--enable-cli,--disable-cli"
+PACKAGECONFIG[coverage] = "--with-coverage,--without-coverage,lcov-native"
+PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
+PACKAGECONFIG[debug-time] = "--enable-debug-time,--disable-debug-time"
+PACKAGECONFIG[faststream] = "--enable-faststream,--disable-faststream"
+PACKAGECONFIG[hcitop] = "--enable-hcitop,--disable-hcitop,libbsd ncurses"
+PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
+PACKAGECONFIG[mp3lame] = "--enable-mp3lame,--disable-mp3lame,lame"
+PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123,mpg123"
+PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono,ofono"
+PACKAGECONFIG[payloadcheck] = "--enable-payloadcheck,--disable-payloadcheck"
+PACKAGECONFIG[rfcomm] = "--enable-rfcomm,--disable-rfcomm"
+PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_system_unitdir} \
+ --with-systemdbluealsaargs='${SYSTEMD_BLUEALSA_ARGS}' --with-systemdbluealsaaplayargs='${SYSTEMD_BLUEALSA_APLAY_ARGS}',--disable-systemd,systemd"
+PACKAGECONFIG[test] = "--enable-test,--disable-test,libcheck libsndfile1"
+PACKAGECONFIG[upower] = "--enable-upower,--disable-upower,,upower"
-inherit autotools pkgconfig
-inherit systemd
+inherit autotools pkgconfig systemd
-SYSTEMD_AUTO_ENABLE = "enable"
-SYSTEMD_SERVICE_${PN} = "bluez-alsa.service"
+EXTRA_OECONF = " \
+ --disable-aptx \
+ --disable-lc3plus \
+ --disable-ldac \
+ --disable-manpages \
+"
-PACKAGECONFIG += "hcitop"
+PACKAGE_BEFORE_PN = "${PN}-aplay"
+RRECOMMENDS_${PN} = "${PN}-aplay"
-do_install_append () {
- install -d ${D}${base_libdir}/systemd/system
- install -m 0644 ${WORKDIR}/bluez-alsa.service ${D}${base_libdir}/systemd/system
-}
+FILES_${PN}-aplay = "${bindir}/bluealsa-aplay"
+FILES_${PN} += "${libdir}/alsa-lib/*"
-FILES_${PN} += "\
- ${datadir}/alsa/alsa.conf.d/20-bluealsa.conf\
- ${libdir}/alsa-lib/libasound_module_ctl_bluealsa.so\
- ${libdir}/alsa-lib/libasound_module_pcm_bluealsa.so\
-"
+SYSTEMD_PACKAGES += "${PN}-aplay"
+SYSTEMD_SERVICE_${PN} = "bluealsa.service"
+SYSTEMD_SERVICE_${PN}-aplay = "bluealsa-aplay.service"
-FILES_${PN}-staticdev += "\
- ${libdir}/alsa-lib/libasound_module_ctl_bluealsa.a\
- ${libdir}/alsa-lib/libasound_module_pcm_bluealsa.a\
-"
+SYSTEMD_AUTO_ENABLE_${PN}-aplay = "disable"
+
+# Choose bluez-alsa arguments to be used in bluealsa systemd service
+# Usually could choose profiles with it: a2dp-source a2dp-sink hfp-hf hfp-ag hsp-hs hsp-ag hfp-ofono
+# Enable bluez-alsa arguments by default:
+SYSTEMD_BLUEALSA_ARGS ?= "-p a2dp-source -p a2dp-sink"
+
+# Choose bluealsa-aplay arguments to be used in bluealsa-aplay systemd service
+# Defaults to be empty:
+SYSTEMD_BLUEALSA_APLAY_ARGS ?= ""
diff --git a/recipes-connectivity/bluez-alsa/files/0001-Fix-linkage-mark-external-variable-as-extern.patch b/recipes-connectivity/bluez-alsa/files/0001-Fix-linkage-mark-external-variable-as-extern.patch
deleted file mode 100644
index d366e18..0000000
--- a/recipes-connectivity/bluez-alsa/files/0001-Fix-linkage-mark-external-variable-as-extern.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-From 3b7b70fbb70131adf0c0451c95b9a5313ddc8e53 Mon Sep 17 00:00:00 2001
-From: Arkadiusz Bokowy <arkadiusz.bokowy@gmail.com>
-Date: Sun, 9 Feb 2020 22:26:16 +0100
-Subject: [PATCH] Fix linkage - mark external variable as extern
-
-(cherry picked from commit 30a23dd7ce9b00c702fa48545f6b03038f9e17c6)
-
-Conflicts:
- src/bluealsa-iface.h
- src/bluez-a2dp.h
- src/bluez-iface.h
- src/ofono-iface.h
- test/server-mock.c
- test/test-ba.c
- test/test-io.c
- test/test-rfcomm.c
-
-Upstream-Status: Backport [master after tag v2.1.0]
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- src/bluez-a2dp.h | 8 ++++----
- src/bluez-iface.h | 4 ++--
- 2 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/src/bluez-a2dp.h b/src/bluez-a2dp.h
-index 4826a6f..715fd89 100644
---- a/src/bluez-a2dp.h
-+++ b/src/bluez-a2dp.h
-@@ -17,15 +17,15 @@
-
- #include "a2dp-codecs.h"
-
--const a2dp_sbc_t bluez_a2dp_sbc;
-+extern const a2dp_sbc_t bluez_a2dp_sbc;
- #if ENABLE_MP3
--const a2dp_mpeg_t bluez_a2dp_mpeg;
-+extern const a2dp_mpeg_t bluez_a2dp_mpeg;
- #endif
- #if ENABLE_AAC
--const a2dp_aac_t bluez_a2dp_aac;
-+extern const a2dp_aac_t bluez_a2dp_aac;
- #endif
- #if ENABLE_APTX
--const a2dp_aptx_t bluez_a2dp_aptx;
-+extern const a2dp_aptx_t bluez_a2dp_aptx;
- #endif
-
- #endif
-diff --git a/src/bluez-iface.h b/src/bluez-iface.h
-index 7d61638..a86a1bd 100644
---- a/src/bluez-iface.h
-+++ b/src/bluez-iface.h
-@@ -13,7 +13,7 @@
-
- #include <gio/gio.h>
-
--const GDBusInterfaceInfo bluez_iface_endpoint;
--const GDBusInterfaceInfo bluez_iface_profile;
-+extern const GDBusInterfaceInfo bluez_iface_endpoint;
-+extern const GDBusInterfaceInfo bluez_iface_profile;
-
- #endif
---
-2.20.1
-
diff --git a/recipes-connectivity/bluez-alsa/files/bluez-alsa.service b/recipes-connectivity/bluez-alsa/files/bluez-alsa.service
deleted file mode 100644
index 671815e..0000000
--- a/recipes-connectivity/bluez-alsa/files/bluez-alsa.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Bluetooth Audio ALSA Backend
-After=bluetooth.service
-Requires=bluetooth.service
-
-[Service]
-Type=simple
-ExecStart=/usr/bin/bluealsa
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch b/recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch
new file mode 100644
index 0000000..91949a2
--- /dev/null
+++ b/recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch
@@ -0,0 +1,41 @@
+From 0d23846576b53b6a2a8391a29d44e82bf3aed588 Mon Sep 17 00:00:00 2001
+From: Ming Liu <ming.liu@toradex.com>
+Date: Tue, 28 Dec 2021 13:50:13 +0100
+Subject: [PATCH] Adjust main configuration
+
+- Blacklist rndis nic's, we want them handled by systemd's networkd.
+- Disable background scan, to avoid significant increase in bandwidth.
+
+Upstream-Status: Inappropriate [Toradex specific]
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+Signed-off-by: Ming Liu <ming.liu@toradex.com>
+---
+ src/main.conf | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/main.conf b/src/main.conf
+index 14965e1..24a17bf 100644
+--- a/src/main.conf
++++ b/src/main.conf
+@@ -23,7 +23,7 @@
+ # When BackgroundScanning is false, ConnMan will not perform any scan
+ # regardless of wifi is connected or not, unless it is requested by
+ # the user through a D-Bus call.
+-# BackgroundScanning = true
++BackgroundScanning = false
+
+ # Assume that service gateways also function as timeservers.
+ # UseGatewaysAsTimeservers = false
+@@ -67,7 +67,7 @@
+ # not be handled by ConnMan, if their first characters
+ # match any of the list entries. Default value is
+ # vmnet,vboxnet,virbr,ifb,ve-,vb-.
+-# NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-
++NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-,usb,rndis
+
+ # Allow ConnMan to change the system hostname. This can
+ # happen for example if we receive DHCP hostname option.
+--
+2.25.1
+
diff --git a/recipes-connectivity/connman/connman/0003-connman-clock-ntp-client-should-not-update-time-time.patch b/recipes-connectivity/connman/connman/0001-connman-clock-ntp-client-should-not-update-time-time.patch
index c570812..c570812 100644
--- a/recipes-connectivity/connman/connman/0003-connman-clock-ntp-client-should-not-update-time-time.patch
+++ b/recipes-connectivity/connman/connman/0001-connman-clock-ntp-client-should-not-update-time-time.patch
diff --git a/recipes-connectivity/connman/connman/0001-connman.service.in-don-t-start-if-nfs-boot.patch b/recipes-connectivity/connman/connman/0001-connman.service.in-don-t-start-if-nfs-boot.patch
deleted file mode 100644
index 65da8ff..0000000
--- a/recipes-connectivity/connman/connman/0001-connman.service.in-don-t-start-if-nfs-boot.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 390493e5aab8a6c859a9d14020b6b9cd09bf6f57 Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Fri, 30 Dec 2016 13:43:52 +0100
-Subject: [PATCH] connman.service.in: don't start if nfs boot
-
-connman reconnects its NIC's. If doing a NFS boot the rootfs
-connection drops and the boot will fail.
-As a simple workaround do not manage the network with connman
-at all.
-Alternatively one could black list the network interface used
-for NFS in /etc/connman/main.conf.
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- src/connman.service.in | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/connman.service.in b/src/connman.service.in
-index dab48bc..72c0c91 100644
---- a/src/connman.service.in
-+++ b/src/connman.service.in
-@@ -7,6 +7,8 @@ After=dbus.service network-pre.target systemd-sysusers.service
- Before=network.target multi-user.target shutdown.target
- Wants=network.target
- Conflicts=systemd-resolved.service
-+# only if not NFS mount, connman will disconnect your rootfs otherwise!
-+ConditionKernelCommandLine=!root=/dev/nfs
-
- [Service]
- Type=dbus
---
-2.12.0
-
diff --git a/recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch b/recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch
deleted file mode 100644
index dd6bafa..0000000
--- a/recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 38a7afa59f0edc1e4c6a49e778e6456f6cd30446 Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Fri, 30 Dec 2016 13:41:47 +0100
-Subject: [PATCH 2/2] main.conf: blacklist rndis nic's
-
-We want them handled by systemd's networkd.
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- src/main.conf | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/main.conf b/src/main.conf
-index 14965e1..d7b2951 100644
---- a/src/main.conf
-+++ b/src/main.conf
-@@ -67,7 +67,7 @@
- # not be handled by ConnMan, if their first characters
- # match any of the list entries. Default value is
- # vmnet,vboxnet,virbr,ifb,ve-,vb-.
--# NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-
-+NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-,usb,rndis
-
- # Allow ConnMan to change the system hostname. This can
- # happen for example if we receive DHCP hostname option.
---
-2.13.6
-
diff --git a/recipes-connectivity/connman/connman_%.bbappend b/recipes-connectivity/connman/connman_%.bbappend
index 330f66e..3400da3 100644
--- a/recipes-connectivity/connman/connman_%.bbappend
+++ b/recipes-connectivity/connman/connman_%.bbappend
@@ -1,9 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/connman:"
-SRC_URI += " \
- file://0001-connman.service.in-don-t-start-if-nfs-boot.patch \
- file://0002-main.conf-blacklist-rndis-nic-s.patch \
- file://0003-connman-clock-ntp-client-should-not-update-time-time.patch \
+SRC_URI_append = " \
+ file://0001-Adjust-main-configuration.patch \
+ file://0001-connman-clock-ntp-client-should-not-update-time-time.patch \
"
do_install_append() {
diff --git a/recipes-connectivity/wpa-supplicant/wpa-supplicant_%.bbappend b/recipes-connectivity/wpa-supplicant/wpa-supplicant_%.bbappend
new file mode 100644
index 0000000..5f01cac
--- /dev/null
+++ b/recipes-connectivity/wpa-supplicant/wpa-supplicant_%.bbappend
@@ -0,0 +1,4 @@
+do_install_append () {
+ # Disable background scan to avoid significant increase in bandwidth
+ sed -i '/update_config/abgscan=""' ${D}${sysconfdir}/wpa_supplicant.conf
+}
diff --git a/recipes-core/base-files/base-files/fstab b/recipes-core/base-files/base-files/fstab
index 6ccd038..d9ded1e 100644
--- a/recipes-core/base-files/base-files/fstab
+++ b/recipes-core/base-files/base-files/fstab
@@ -1,6 +1,6 @@
# stock fstab - you probably want to override this with a machine specific one
-/dev/root / auto noatime 1 1
+/dev/root / auto defaults,noatime 1 1
/dev/boot-part /boot auto noatime,noauto 0 0
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0620,ptmxmode=0666,gid=5 0 0
diff --git a/recipes-devtools/run-postinsts/run-postinsts/run-postinsts.service b/recipes-devtools/run-postinsts/run-postinsts/run-postinsts.service
deleted file mode 100644
index 1b71a1f..0000000
--- a/recipes-devtools/run-postinsts/run-postinsts/run-postinsts.service
+++ /dev/null
@@ -1,16 +0,0 @@
-[Unit]
-Description=Run pending postinsts
-DefaultDependencies=no
-After=systemd-remount-fs.service systemd-tmpfiles-setup.service tmp.mount
-Before=sysinit.target
-ConditionPathExistsGlob=#SYSCONFDIR#/*-postinsts
-
-[Service]
-Type=oneshot
-ExecStart=#SBINDIR#/run-postinsts
-ExecStartPost=#BASE_BINDIR#/systemctl --no-reload disable run-postinsts.service
-RemainAfterExit=No
-TimeoutSec=0
-
-[Install]
-WantedBy=sysinit.target
diff --git a/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend b/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend
deleted file mode 100644
index ef0f837..0000000
--- a/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/run-postinsts:"
diff --git a/recipes-devtools/socketcan/can-utils_git.bbappend b/recipes-devtools/socketcan/can-utils_git.bbappend
new file mode 100644
index 0000000..96a9805
--- /dev/null
+++ b/recipes-devtools/socketcan/can-utils_git.bbappend
@@ -0,0 +1 @@
+SRCREV="901c9e519d8002701eed5fc6823e0239656e38fe"
diff --git a/recipes-images/images/packagegroup-tdx-cli.bb b/recipes-images/images/packagegroup-tdx-cli.bb
index f329401..21709c2 100644
--- a/recipes-images/images/packagegroup-tdx-cli.bb
+++ b/recipes-images/images/packagegroup-tdx-cli.bb
@@ -65,6 +65,7 @@ RRECOMMENDS_packagegroup-devel-tdx-cli = "\
bonnie++ \
devmem2 \
evtest \
+ fio \
gdbserver \
i2c-tools \
ldd \
@@ -94,9 +95,16 @@ RRECOMMENDS_packagegroup-machine-tdx-cli_colibri-imx6ull = "\
mtd-utils-ubifs \
mwifiexap \
"
+RRECOMMENDS_packagegroup-machine-tdx-cli_colibri-imx6ull-emmc = "\
+ bmode-usb \
+"
RRECOMMENDS_packagegroup-machine-tdx-cli_colibri-imx7 = "\
mtd-utils-ubifs \
"
+RRECOMMENDS_packagegroup-machine-tdx-cli_verdin-imx8mp = "\
+ btuart \
+ mwifiexap \
+"
RRECOMMENDS_packagegroup-machine-tdx-cli_mx8 = "\
mwifiexap \
"
@@ -179,6 +187,7 @@ RRECOMMENDS_packagegroup-wifi-tdx-cli = "\
SUMMARY_packagegroup-wifi-fw-tdx-cli = "Wi-Fi firmware"
RRECOMMENDS_packagegroup-wifi-fw-tdx-cli = "\
linux-firmware-ath10k \
+ linux-firmware-nxp89xx \
linux-firmware-sd8686 \
linux-firmware-sd8688 \
linux-firmware-sd8787 \
diff --git a/recipes-images/images/packagegroup-tdx-graphical.bb b/recipes-images/images/packagegroup-tdx-graphical.bb
index 4088c44..de9e381 100644
--- a/recipes-images/images/packagegroup-tdx-graphical.bb
+++ b/recipes-images/images/packagegroup-tdx-graphical.bb
@@ -51,6 +51,7 @@ GSTREAMER_MX6QDL = " \
RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_append_mx6dl = " ${GSTREAMER_MX6QDL}"
RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_append_mx6q = " ${GSTREAMER_MX6QDL}"
RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_colibri-imx6ull = ""
+RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_colibri-imx6ull-emmc = ""
RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_append_mx7 = " imx-gst1.0-plugin"
RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_append_mx8 = " \
imx-gst1.0-plugin \
@@ -79,6 +80,7 @@ RRECOMMENDS_packagegroup-gpu-tdx-graphical_append_mx6q = " \
${IMAGE_INSTALL_OPENCL_IMX} \
"
RRECOMMENDS_packagegroup-gpu-tdx-graphical_colibri-imx6ull = ""
+RRECOMMENDS_packagegroup-gpu-tdx-graphical_colibri-imx6ull-emmc = ""
RRECOMMENDS_packagegroup-gpu-tdx-graphical_append_mx8 = " \
tinycompress \
libvdk-imx \
diff --git a/recipes-images/images/packagegroup-tdx-qt5.bb b/recipes-images/images/packagegroup-tdx-qt5.bb
index ea14bc9..f3828ba 100644
--- a/recipes-images/images/packagegroup-tdx-qt5.bb
+++ b/recipes-images/images/packagegroup-tdx-qt5.bb
@@ -22,6 +22,10 @@ RRECOMMENDS_${PN}_colibri-imx6ull = " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland', '', d)} \
qtbase-examples \
"
+RRECOMMENDS_${PN}_colibri-imx6ull-emmc = " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland', '', d)} \
+ qtbase-examples \
+"
RRECOMMENDS_${PN}_colibri-imx7 = " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland', '', d)} \
qtbase-examples \
diff --git a/recipes-images/images/tdx-reference-minimal-image.bb b/recipes-images/images/tdx-reference-minimal-image.bb
index ae2e0dc..1be5909 100644
--- a/recipes-images/images/tdx-reference-minimal-image.bb
+++ b/recipes-images/images/tdx-reference-minimal-image.bb
@@ -14,11 +14,6 @@ IMAGE_NAME = "${MACHINE_NAME}_${IMAGE_BASENAME}"
COPY_LIC_MANIFEST ?= "1"
COPY_LIC_DIRS ?= "1"
-# Show Tezi EULA license
-TEZI_SHOW_EULA_LICENSE ?= "1"
-TEZI_SHOW_EULA_LICENSE_apalis-tk1 ?= "0"
-TEZI_SHOW_EULA_LICENSE_use-mainline-bsp ?= "0"
-
add_rootfs_version () {
printf "${DISTRO_NAME} ${DISTRO_VERSION} (${DISTRO_CODENAME}) \\\n \\\l\n" > ${IMAGE_ROOTFS}/etc/issue
printf "${DISTRO_NAME} ${DISTRO_VERSION} (${DISTRO_CODENAME}) %%h\n" > ${IMAGE_ROOTFS}/etc/issue.net
diff --git a/recipes-images/images/tdx-reference-multimedia-image.bb b/recipes-images/images/tdx-reference-multimedia-image.bb
index 8365909..252f7fc 100644
--- a/recipes-images/images/tdx-reference-multimedia-image.bb
+++ b/recipes-images/images/tdx-reference-multimedia-image.bb
@@ -8,11 +8,6 @@ inherit populate_sdk_qt5
#Prefix to the resulting deployable tarball name
export IMAGE_BASENAME = "Reference-Multimedia-Image"
-# Show Tezi EULA license
-TEZI_SHOW_EULA_LICENSE ?= "1"
-TEZI_SHOW_EULA_LICENSE_apalis-tk1 ?= "0"
-TEZI_SHOW_EULA_LICENSE_use-mainline-bsp ?= "0"
-
SYSTEMD_DEFAULT_TARGET = "graphical.target"
IMAGE_FEATURES += " \
@@ -23,12 +18,14 @@ IMAGE_FEATURES += " \
APP_LAUNCH_WAYLAND ?= "wayland-qtdemo-launch-cinematicexperience"
APP_LAUNCH_WAYLAND_colibri-imx6ull ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND_colibri-imx6ull-emmc ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_WAYLAND_colibri-imx7 ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_WAYLAND_colibri-imx7-emmc ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_WAYLAND_apalis-tk1 ?= "wayland-qtdemo-launch-qtsmarthome"
APP_LAUNCH_X11 ?= "x-window-qtcinematicexperience"
APP_LAUNCH_X11_colibri-imx6ull ?= "x-window-analogclock"
+APP_LAUNCH_X11_colibri-imx6ull-emmc ?= "x-window-analogclock"
APP_LAUNCH_X11_colibri-imx7 ?= "x-window-analogclock"
APP_LAUNCH_X11_colibri-imx7-emmc ?= "x-window-analogclock"
APP_LAUNCH_X11_apalis-tk1 ?= "x-window-qtsmarthome"
@@ -50,6 +47,7 @@ IMAGE_INSTALL += " \
less \
makedevs \
mime-support \
+ net-tools \
util-linux \
v4l-utils \
\
diff --git a/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch b/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch
deleted file mode 100644
index 4e6b921..0000000
--- a/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 7a1fc14..a0f8f4a 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,12 +1,12 @@
- INSTALL_PATH=$(DESTDIR)/usr/bin
-
--LDFLAGS+=-lmcc
-+LDLIBS+=-lmcc
-
- all: build/mcc-pingpong
-
- build/mcc-pingpong: src/pingpong.c
- mkdir -p build/
-- $(CC) $< -o $@ $(CFLAGS) $(LDFLAGS)
-+ $(CC) $< -o $@ $(CFLAGS) $(LDLIBS) $(LDFLAGS)
-
- install:
- mkdir -p $(INSTALL_PATH)
diff --git a/recipes-support/mcc-pingpong/mcc-pingpong/update-mcc_free_buffer-call.patch b/recipes-support/mcc-pingpong/mcc-pingpong/update-mcc_free_buffer-call.patch
deleted file mode 100644
index bdd00b5..0000000
--- a/recipes-support/mcc-pingpong/mcc-pingpong/update-mcc_free_buffer-call.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit c7db59e08ff1dfb30ae4aba8d6274b0cc8a0f228
-Author: Anthony Felice <tony.felice@timesys.com>
-Date: Mon Apr 15 19:24:06 2013 -0400
-
- Update call to mcc_free_buffer to comply with API change.
-
-diff --git a/src/pingpong.c b/src/pingpong.c
-index 3d49fc8..5850059 100644
---- a/src/pingpong.c
-+++ b/src/pingpong.c
-@@ -121,7 +121,7 @@ int main(int argc, char** argv)
- return 1;
- }
-
-- mcc_free_buffer(null, data);
-+ mcc_free_buffer(data);
- }
-
- mcc_destroy(node_num);
diff --git a/recipes-support/tdx-oak-sensors/tdx-oak-sensors_0082.bb b/recipes-support/tdx-oak-sensors/tdx-oak-sensors_0082.bb
index fc13b98..6eaada7 100644
--- a/recipes-support/tdx-oak-sensors/tdx-oak-sensors_0082.bb
+++ b/recipes-support/tdx-oak-sensors/tdx-oak-sensors_0082.bb
@@ -3,7 +3,7 @@ LICENSE = "PD"
S = "${WORKDIR}/OakLinux_${PV}"
-SRC_URI = "http://files.toradex.com/Oak/Linux/OakLinux_${PV}.tar.bz2"
+SRC_URI = "https://files.toradex.com/Oak/Linux/OakLinux_${PV}.tar.bz2"
SRC_URI[md5sum] = "cedc87c056f961c15751ee899fb719d5"
SRC_URI[sha256sum] = "69836dfa746422a64f6518cc9e785a7a64ca67d82f5fae0421515a59f4394929"