summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/toradex-mirrors.bbclass14
-rw-r--r--conf/layer.conf2
-rw-r--r--qt5-layer/recipes-qt/examples/cinematicexperience/fix-fullscreen-mode.patch4
-rw-r--r--recipes-connectivity/wireless-regdb/wireless-regdb_2018.05.31.bb44
-rw-r--r--recipes-graphics/gpicview/gpicview/0001-gpicview-allow-to-build-for-gtk-wayland.patch276
-rw-r--r--recipes-graphics/gpicview/gpicview/remove-gdk-x11.patch136
-rw-r--r--recipes-graphics/gpicview/gpicview_0.2.5.bb2
-rw-r--r--recipes-images/images/packagegroup-tdx-cli.bb25
-rw-r--r--recipes-images/images/packagegroup-tdx-graphical.bb3
-rw-r--r--recipes-images/images/tdx-reference-multimedia-image.bb3
10 files changed, 302 insertions, 207 deletions
diff --git a/classes/toradex-mirrors.bbclass b/classes/toradex-mirrors.bbclass
deleted file mode 100644
index 8f13e52..0000000
--- a/classes/toradex-mirrors.bbclass
+++ /dev/null
@@ -1,14 +0,0 @@
-TORADEX_MIRROR_URL="https://artifacts.toradex.com/artifactory/tdxref-torizoncore-sources-frankfurt/${TDX_MAJOR}"
-
-PREMIRRORS:append = " \
-cvs://.*/.* ${TORADEX_MIRROR_URL} \
-svn://.*/.* ${TORADEX_MIRROR_URL} \
-git://.*/.* ${TORADEX_MIRROR_URL} \
-gitsm://.*/.* ${TORADEX_MIRROR_URL} \
-hg://.*/.* ${TORADEX_MIRROR_URL} \
-bzr://.*/.* ${TORADEX_MIRROR_URL} \
-p4://.*/.* ${TORADEX_MIRROR_URL} \
-osc://.*/.* ${TORADEX_MIRROR_URL} \
-https?$://.*/.* ${TORADEX_MIRROR_URL} \
-ftp://.*/.* ${TORADEX_MIRROR_URL} \
-"
diff --git a/conf/layer.conf b/conf/layer.conf
index 421ae75..d4b083c 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -20,7 +20,5 @@ LAYERDEPENDS_toradex-demos = " \
core \
yocto \
openembedded-layer gnome-layer multimedia-layer networking-layer \
- freescale-layer \
- freescale-distro \
"
LAYERSERIES_COMPAT_toradex-demos = "hardknott honister kirkstone"
diff --git a/qt5-layer/recipes-qt/examples/cinematicexperience/fix-fullscreen-mode.patch b/qt5-layer/recipes-qt/examples/cinematicexperience/fix-fullscreen-mode.patch
index a7a6846..a82dc40 100644
--- a/qt5-layer/recipes-qt/examples/cinematicexperience/fix-fullscreen-mode.patch
+++ b/qt5-layer/recipes-qt/examples/cinematicexperience/fix-fullscreen-mode.patch
@@ -1,5 +1,5 @@
---- main.cpp.orig 2022-11-16 15:25:11.221100107 +0100
-+++ main.cpp 2022-11-18 09:30:01.084064039 +0100
+--- a/main.cpp 2022-11-16 15:25:11.221100107 +0100
++++ b/main.cpp 2022-11-18 09:30:01.084064039 +0100
@@ -1,5 +1,22 @@
#include <QGuiApplication>
#include <QQuickView>
diff --git a/recipes-connectivity/wireless-regdb/wireless-regdb_2018.05.31.bb b/recipes-connectivity/wireless-regdb/wireless-regdb_2018.05.31.bb
deleted file mode 100644
index 874fd5f..0000000
--- a/recipes-connectivity/wireless-regdb/wireless-regdb_2018.05.31.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-SUMMARY = "Wireless Central Regulatory Domain Database"
-HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA"
-SECTION = "net"
-LICENSE = "ISC"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c"
-
-SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz"
-SRC_URI[md5sum] = "0cbbdc21186c76cf58aba01b03f3dc5b"
-SRC_URI[sha256sum] = "e1dfbc3b97771373077f430c3c05082fae883145b37db5b2cfd12c56676fbe7b"
-
-inherit bin_package allarch
-
-do_install() {
- install -d -m0755 ${D}${nonarch_libdir}/crda
- install -d -m0755 ${D}${sysconfdir}/wireless-regdb/pubkeys
- install -m 0644 regulatory.bin ${D}${nonarch_libdir}/crda/regulatory.bin
- install -m 0644 sforshee.key.pub.pem ${D}${sysconfdir}/wireless-regdb/pubkeys/sforshee.key.pub.pem
-
- install -m 0644 -D regulatory.db ${D}${nonarch_base_libdir}/firmware/regulatory.db
- install -m 0644 regulatory.db.p7s ${D}${nonarch_base_libdir}/firmware/regulatory.db.p7s
-}
-
-# Install static regulatory DB in /lib/firmware for kernel to load.
-# This requires Linux kernel >= v4.15.
-# For kernel <= v4.14, inherit the kernel_wireless_regdb.bbclass in kernel's recipe.
-PACKAGES =+ "${PN}-static"
-RCONFLICTS:${PN} = "${PN}-static"
-RDEPENDS:${PN}-dev = ""
-
-FILES:${PN}-static = " \
- ${nonarch_base_libdir}/firmware/regulatory.db \
- ${nonarch_base_libdir}/firmware/regulatory.db.p7s \
-"
-
-# Native users might want to use the source of regulatory DB.
-# This is for example used by Linux kernel <= v4.14 and kernel_wireless_regdb.bbclass.
-do_install:append:class-native() {
- install -m 0644 -D db.txt ${D}${libdir}/crda/db.txt
-}
-
-RSUGGESTS:${PN} = "crda"
-
-BBCLASSEXTEND = "native"
-
diff --git a/recipes-graphics/gpicview/gpicview/0001-gpicview-allow-to-build-for-gtk-wayland.patch b/recipes-graphics/gpicview/gpicview/0001-gpicview-allow-to-build-for-gtk-wayland.patch
new file mode 100644
index 0000000..8cf74c1
--- /dev/null
+++ b/recipes-graphics/gpicview/gpicview/0001-gpicview-allow-to-build-for-gtk-wayland.patch
@@ -0,0 +1,276 @@
+From aa2f81a3e78e7da505bdab465eacce9b37b035e6 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Mon, 6 Nov 2023 10:43:46 +0000
+Subject: [PATCH] gpicview: allow to build for gtk/wayland
+
+For wayland gdk/gdkx.h does not work, even with xwayland.
+Remove the more elaborate gf_display_get_workarea function and use the
+existing fallback.
+With the removal of gdk from the code also remove the dependency
+check on x11 from configure.
+
+Upstream-Status: Inappropriate [Toradex specific]
+Upstream targets X11. Removing the use of gdk would remove
+functionaliy.
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ Makefile.in | 2 -
+ configure.ac | 4 --
+ data/Makefile.in | 2 -
+ src/Makefile.am | 5 +-
+ src/Makefile.in | 7 +--
+ src/working-area.c | 123 ++-------------------------------------------
+ 6 files changed, 6 insertions(+), 137 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 6ecf74a..cad90b7 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -317,8 +317,6 @@ SHELL = @SHELL@
+ STRIP = @STRIP@
+ USE_NLS = @USE_NLS@
+ VERSION = @VERSION@
+-X11_CFLAGS = @X11_CFLAGS@
+-X11_LIBS = @X11_LIBS@
+ XGETTEXT = @XGETTEXT@
+ abs_builddir = @abs_builddir@
+ abs_srcdir = @abs_srcdir@
+diff --git a/configure.ac b/configure.ac
+index 2fb2469..1591584 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -56,15 +56,11 @@ AC_SUBST(GTK_LIBS)
+
+ pkg_modules="x11"
+
+-PKG_CHECK_MODULES(X11, [$pkg_modules])
+ AC_CHECK_LIB(jpeg, jpeg_start_decompress, [],
+ [AC_MSG_ERROR([libjpeg not found])], -lm)
+ AC_CHECK_HEADER(jpeglib.h, , [AC_MSG_ERROR([libjpeg not found])])
+ LIBJPEG='-ljpeg'
+
+-AC_SUBST(X11_CFLAGS)
+-AC_SUBST(X11_LIBS)
+-
+ # Generate po/LINGUAS on the fly rather than relying on translators
+ # to maintain it manually. This also overcome the problem that Transifex
+ # cannot add a language to po/LINGUAS if a new po file is submitted.
+diff --git a/data/Makefile.in b/data/Makefile.in
+index c8c142b..ea2e4ff 100644
+--- a/data/Makefile.in
++++ b/data/Makefile.in
+@@ -234,8 +234,6 @@ SHELL = @SHELL@
+ STRIP = @STRIP@
+ USE_NLS = @USE_NLS@
+ VERSION = @VERSION@
+-X11_CFLAGS = @X11_CFLAGS@
+-X11_LIBS = @X11_LIBS@
+ XGETTEXT = @XGETTEXT@
+ abs_builddir = @abs_builddir@
+ abs_srcdir = @abs_srcdir@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 44ecb19..6c7a683 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -2,7 +2,6 @@
+
+ # set the include path found by configure
+ gpicview_CPPFLAGS = $(all_includes) \
+- $(X11_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(ADDITIONAL_FLAGS) \
+ -I$(top_srcdir) \
+@@ -27,7 +26,7 @@ gpicview_SOURCES = \
+
+ # the library search path.
+ # use -nodefaultlibs to prevent linking libstdc++
+-gpicview_LDADD = $(X11_LIBS) $(GTK_LIBS) -lm
++gpicview_LDADD = $(GTK_LIBS) -lm
+
+ noinst_HEADERS = \
+ glib-mem.h \
+@@ -44,6 +43,4 @@ noinst_HEADERS = \
+
+ noinst_PROGRAMS=xml-purge
+ xml_purge_SOURCES=xml-purge.c
+-xml_purge_CFLAGS=@X11_CFLAGS@
+-xml_purge_LDADD=@X11_LIBS@
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 24cfe1f..65fea48 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -271,8 +271,6 @@ SHELL = @SHELL@
+ STRIP = @STRIP@
+ USE_NLS = @USE_NLS@
+ VERSION = @VERSION@
+-X11_CFLAGS = @X11_CFLAGS@
+-X11_LIBS = @X11_LIBS@
+ XGETTEXT = @XGETTEXT@
+ abs_builddir = @abs_builddir@
+ abs_srcdir = @abs_srcdir@
+@@ -331,7 +329,6 @@ top_srcdir = @top_srcdir@
+
+ # set the include path found by configure
+ gpicview_CPPFLAGS = $(all_includes) \
+- $(X11_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(ADDITIONAL_FLAGS) \
+ -I$(top_srcdir) \
+@@ -356,7 +353,7 @@ gpicview_SOURCES = \
+
+ # the library search path.
+ # use -nodefaultlibs to prevent linking libstdc++
+-gpicview_LDADD = $(X11_LIBS) $(GTK_LIBS) -lm
++gpicview_LDADD = $(GTK_LIBS) -lm
+ noinst_HEADERS = \
+ glib-mem.h \
+ image-list.h \
+@@ -371,8 +368,6 @@ noinst_HEADERS = \
+ jhead.h
+
+ xml_purge_SOURCES = xml-purge.c
+-xml_purge_CFLAGS = @X11_CFLAGS@
+-xml_purge_LDADD = @X11_LIBS@
+ all: all-am
+
+ .SUFFIXES:
+diff --git a/src/working-area.c b/src/working-area.c
+index 86a1fa5..2fa9474 100644
+--- a/src/working-area.c
++++ b/src/working-area.c
+@@ -23,126 +23,11 @@
+ */
+
+ # include <gdk/gdk.h>
+-# include <gdk/gdkx.h>
+-# include <X11/Xlib.h>
+-# include <X11/Xutil.h>
+-# include <X11/Xatom.h>
+-
+-void get_working_area(GdkScreen* screen, GdkRectangle *rect);
+-
+-static gboolean gf_display_get_workarea(GdkScreen* g_screen, GdkRectangle *rect) {
+- Atom xa_desktops, xa_current, xa_workarea, xa_type;
+- Display *x_display;
+- Window x_root;
+- guint32 desktops = 0, current = 0;
+- gulong *workareas, len, fill;
+- guchar *data;
+- gint format;
+-
+- GdkDisplay *g_display;
+- Screen *x_screen;
+-
+- /* get the gdk display */
+- g_display = gdk_display_get_default();
+- if(!g_display)
+- return FALSE;
+-
+- /* get the x display from the gdk display */
+- x_display = gdk_x11_display_get_xdisplay(g_display);
+- if(!x_display)
+- return FALSE;
+-
+- /* get the x screen from the gdk screen */
+- x_screen = gdk_x11_screen_get_xscreen(g_screen);
+- if(!x_screen)
+- return FALSE;
+-
+- /* get the root window from the screen */
+- x_root = XRootWindowOfScreen(x_screen);
+-
+- /* find the _NET_NUMBER_OF_DESKTOPS atom */
+- xa_desktops = XInternAtom(x_display, "_NET_NUMBER_OF_DESKTOPS", True);
+- if(xa_desktops == None)
+- return FALSE;
+-
+- /* get the number of desktops */
+- if(XGetWindowProperty(x_display, x_root, xa_desktops, 0, 1, False,
+- XA_CARDINAL, &xa_type, &format, &len, &fill,
+- &data) != Success)
+- {
+- return FALSE;
+- }
+-
+- if(!data)
+- return FALSE;
+-
+- desktops = *(guint32 *)data;
+- XFree(data);
+-
+- /* find the _NET_CURRENT_DESKTOP atom */
+- xa_current = XInternAtom(x_display, "_NET_CURRENT_DESKTOP", True);
+- if(xa_current == None)
+- return FALSE;
+-
+- /* get the current desktop */
+- if(XGetWindowProperty(x_display, x_root, xa_current, 0, 1, False,
+- XA_CARDINAL, &xa_type, &format, &len, &fill,
+- &data) != Success)
+- {
+- return FALSE;
+- }
+-
+- if(!data)
+- return FALSE;
+-
+- current = *(guint32 *)data;
+- XFree(data);
+-
+- /* find the _NET_WORKAREA atom */
+- xa_workarea = XInternAtom(x_display, "_NET_WORKAREA", True);
+- if(xa_workarea == None)
+- return FALSE;
+-
+- if(XGetWindowProperty(x_display, x_root, xa_workarea, 0, (glong)(4 * 32),
+- False, AnyPropertyType, &xa_type, &format, &len,
+- &fill, &data) != Success)
+- {
+- return FALSE;
+- }
+-
+- /* make sure the type and format are good */
+- if(xa_type == None || format == 0)
+- return FALSE;
+-
+- /* make sure we don't have any leftovers */
+- if(fill)
+- return FALSE;
+-
+- /* make sure len divides evenly by 4 */
+- if(len % 4)
+- return FALSE;
+-
+- /* it's good, lets use it */
+- workareas = (gulong *)(guint32 *)data;
+-
+- rect->x = (guint32)workareas[current * 4];
+- rect->y = (guint32)workareas[current * 4 + 1];
+- rect->width = (guint32)workareas[current * 4 + 2];
+- rect->height = (guint32)workareas[current * 4 + 3];
+-
+- /* clean up our memory */
+- XFree(data);
+-
+- return TRUE;
+-}
+
+ void get_working_area(GdkScreen* screen, GdkRectangle *rect)
+ {
+- if( !gf_display_get_workarea(screen, rect) )
+- {
+- rect->x = 0;
+- rect->y = 0;
+- rect->width = gdk_screen_width();
+- rect->height = gdk_screen_height();
+- }
++ rect->x = 0;
++ rect->y = 0;
++ rect->width = gdk_screen_width();
++ rect->height = gdk_screen_height();
+ }
+--
+2.35.3
+
diff --git a/recipes-graphics/gpicview/gpicview/remove-gdk-x11.patch b/recipes-graphics/gpicview/gpicview/remove-gdk-x11.patch
deleted file mode 100644
index a1f97b3..0000000
--- a/recipes-graphics/gpicview/gpicview/remove-gdk-x11.patch
+++ /dev/null
@@ -1,136 +0,0 @@
-For xwayland gdk/gdkx.h does not work.
-Remove the more elaborate gf_display_get_workarea function and use only
-the fallback.
---- ./src/working-area.c.orig 2016-02-20 22:38:31.000000000 +0000
-+++ ./src/working-area.c 2020-01-07 13:37:47.023817524 +0000
-@@ -23,126 +23,11 @@
- */
-
- # include <gdk/gdk.h>
--# include <gdk/gdkx.h>
--# include <X11/Xlib.h>
--# include <X11/Xutil.h>
--# include <X11/Xatom.h>
--
--void get_working_area(GdkScreen* screen, GdkRectangle *rect);
--
--static gboolean gf_display_get_workarea(GdkScreen* g_screen, GdkRectangle *rect) {
-- Atom xa_desktops, xa_current, xa_workarea, xa_type;
-- Display *x_display;
-- Window x_root;
-- guint32 desktops = 0, current = 0;
-- gulong *workareas, len, fill;
-- guchar *data;
-- gint format;
--
-- GdkDisplay *g_display;
-- Screen *x_screen;
--
-- /* get the gdk display */
-- g_display = gdk_display_get_default();
-- if(!g_display)
-- return FALSE;
--
-- /* get the x display from the gdk display */
-- x_display = gdk_x11_display_get_xdisplay(g_display);
-- if(!x_display)
-- return FALSE;
--
-- /* get the x screen from the gdk screen */
-- x_screen = gdk_x11_screen_get_xscreen(g_screen);
-- if(!x_screen)
-- return FALSE;
--
-- /* get the root window from the screen */
-- x_root = XRootWindowOfScreen(x_screen);
--
-- /* find the _NET_NUMBER_OF_DESKTOPS atom */
-- xa_desktops = XInternAtom(x_display, "_NET_NUMBER_OF_DESKTOPS", True);
-- if(xa_desktops == None)
-- return FALSE;
--
-- /* get the number of desktops */
-- if(XGetWindowProperty(x_display, x_root, xa_desktops, 0, 1, False,
-- XA_CARDINAL, &xa_type, &format, &len, &fill,
-- &data) != Success)
-- {
-- return FALSE;
-- }
--
-- if(!data)
-- return FALSE;
--
-- desktops = *(guint32 *)data;
-- XFree(data);
--
-- /* find the _NET_CURRENT_DESKTOP atom */
-- xa_current = XInternAtom(x_display, "_NET_CURRENT_DESKTOP", True);
-- if(xa_current == None)
-- return FALSE;
--
-- /* get the current desktop */
-- if(XGetWindowProperty(x_display, x_root, xa_current, 0, 1, False,
-- XA_CARDINAL, &xa_type, &format, &len, &fill,
-- &data) != Success)
-- {
-- return FALSE;
-- }
--
-- if(!data)
-- return FALSE;
--
-- current = *(guint32 *)data;
-- XFree(data);
--
-- /* find the _NET_WORKAREA atom */
-- xa_workarea = XInternAtom(x_display, "_NET_WORKAREA", True);
-- if(xa_workarea == None)
-- return FALSE;
--
-- if(XGetWindowProperty(x_display, x_root, xa_workarea, 0, (glong)(4 * 32),
-- False, AnyPropertyType, &xa_type, &format, &len,
-- &fill, &data) != Success)
-- {
-- return FALSE;
-- }
--
-- /* make sure the type and format are good */
-- if(xa_type == None || format == 0)
-- return FALSE;
--
-- /* make sure we don't have any leftovers */
-- if(fill)
-- return FALSE;
--
-- /* make sure len divides evenly by 4 */
-- if(len % 4)
-- return FALSE;
--
-- /* it's good, lets use it */
-- workareas = (gulong *)(guint32 *)data;
--
-- rect->x = (guint32)workareas[current * 4];
-- rect->y = (guint32)workareas[current * 4 + 1];
-- rect->width = (guint32)workareas[current * 4 + 2];
-- rect->height = (guint32)workareas[current * 4 + 3];
--
-- /* clean up our memory */
-- XFree(data);
--
-- return TRUE;
--}
-
- void get_working_area(GdkScreen* screen, GdkRectangle *rect)
- {
-- if( !gf_display_get_workarea(screen, rect) )
-- {
-- rect->x = 0;
-- rect->y = 0;
-- rect->width = gdk_screen_width();
-- rect->height = gdk_screen_height();
-- }
-+ rect->x = 0;
-+ rect->y = 0;
-+ rect->width = gdk_screen_width();
-+ rect->height = gdk_screen_height();
- }
diff --git a/recipes-graphics/gpicview/gpicview_0.2.5.bb b/recipes-graphics/gpicview/gpicview_0.2.5.bb
index 6e1020b..170db77 100644
--- a/recipes-graphics/gpicview/gpicview_0.2.5.bb
+++ b/recipes-graphics/gpicview/gpicview_0.2.5.bb
@@ -10,7 +10,7 @@ RDEPENDS:${PN} = "adwaita-icon-theme"
SRC_URI = " \
${SOURCEFORGE_MIRROR}/lxde/${P}.tar.xz \
- file://remove-gdk-x11.patch \
+ file://0001-gpicview-allow-to-build-for-gtk-wayland.patch \
"
SRC_URI[md5sum] = "26be9b0c5a234f1afe7d83d02a4a33f4"
SRC_URI[sha256sum] = "38466058e53702450e5899193c4b264339959b563dd5cd81f6f690de32d82942"
diff --git a/recipes-images/images/packagegroup-tdx-cli.bb b/recipes-images/images/packagegroup-tdx-cli.bb
index 7326b9a..ef5d0e7 100644
--- a/recipes-images/images/packagegroup-tdx-cli.bb
+++ b/recipes-images/images/packagegroup-tdx-cli.bb
@@ -13,6 +13,7 @@ PACKAGES += " \
packagegroup-networking-tdx-cli \
packagegroup-utils-tdx-cli \
packagegroup-utils-large-tdx-cli \
+ packagegroup-tpm2-tdx-cli \
packagegroup-wifi-tdx-cli \
packagegroup-wifi-fw-tdx-cli \
packagegroup-wifi-fw-large-tdx-cli \
@@ -42,6 +43,7 @@ RRECOMMENDS:packagegroup-base-tdx-cli = "\
can-utils-cantest \
dosfstools \
e2fsprogs-mke2fs \
+ exfat-utils \
iproute2 \
libgomp \
libgpiod-tools \
@@ -75,6 +77,7 @@ RRECOMMENDS:packagegroup-devel-tdx-cli = "\
fio \
gdbserver \
i2c-tools \
+ jq \
ldd \
less \
perf \
@@ -84,6 +87,9 @@ RRECOMMENDS:packagegroup-devel-tdx-cli = "\
spidev-test \
strace \
"
+RRECOMMENDS:packagegroup-devel-tdx-cli:append:k3 = "\
+ k3conf \
+"
SUMMARY:packagegroup-machine-tdx-cli = "Machine specific tools"
RRECOMMENDS:packagegroup-machine-tdx-cli = "\
@@ -97,7 +103,6 @@ RRECOMMENDS:packagegroup-machine-tdx-cli:colibri-imx6 = "\
RRECOMMENDS:packagegroup-machine-tdx-cli:colibri-imx6ull = "\
bmode-usb \
mtd-utils-ubifs \
- mwifiexap \
"
RRECOMMENDS:packagegroup-machine-tdx-cli:colibri-imx6ull-emmc = "\
bmode-usb \
@@ -105,13 +110,6 @@ RRECOMMENDS:packagegroup-machine-tdx-cli:colibri-imx6ull-emmc = "\
RRECOMMENDS:packagegroup-machine-tdx-cli:colibri-imx7 = "\
mtd-utils-ubifs \
"
-RRECOMMENDS:packagegroup-machine-tdx-cli:verdin-imx8mp = "\
- btuart \
- mwifiexap \
-"
-RRECOMMENDS:packagegroup-machine-tdx-cli:mx8-generic-bsp = "\
- mwifiexap \
-"
SUMMARY:packagegroup-networking-tdx-cli = "Networking specific tools"
RRECOMMENDS:packagegroup-networking-tdx-cli = "\
@@ -132,6 +130,7 @@ RRECOMMENDS:packagegroup-utils-tdx-cli = "\
alsa-utils \
alsa-utils-aplay \
alsa-utils-amixer \
+ alsa-ucm-conf-tdx \
bluealsa \
bzip2 \
e2fsprogs \
@@ -152,6 +151,9 @@ RRECOMMENDS:packagegroup-utils-tdx-cli = "\
tdx-oak-sensors \
util-linux \
"
+RRECOMMENDS:packagegroup-utils-tdx-cli:append:k3 = " \
+ cpuburn-a53 \
+"
RRECOMMENDS:packagegroup-utils-tdx-cli:append:mx8-generic-bsp = " \
cpuburn-a53 \
"
@@ -164,6 +166,12 @@ RRECOMMENDS:packagegroup-utils-large-tdx-cli = "\
packagegroup-dotnet-deps \
"
+SUMMARY:packagegroup-tpm2-tdx-cli = "Basic tools to work with TPM 2.0"
+RRECOMMENDS:packagegroup-tpm2-tdx-cli = " \
+ tpm2-tools \
+ libtss2-tcti-device \
+"
+
SUMMARY:packagegroup-wifi-tdx-cli = "Useful Wi-Fi utilities and firmware"
BACKPORTS = ""
RRECOMMENDS:packagegroup-wifi-tdx-cli = "\
@@ -176,6 +184,7 @@ RRECOMMENDS:packagegroup-wifi-tdx-cli = "\
SUMMARY:packagegroup-wifi-fw-tdx-cli = "Wi-Fi firmware"
RRECOMMENDS:packagegroup-wifi-fw-tdx-cli = "\
linux-firmware-ath10k \
+ linux-firmware-iw416 \
linux-firmware-nxp89xx \
linux-firmware-sd8686 \
linux-firmware-sd8688 \
diff --git a/recipes-images/images/packagegroup-tdx-graphical.bb b/recipes-images/images/packagegroup-tdx-graphical.bb
index 9968ab7..f1e0114 100644
--- a/recipes-images/images/packagegroup-tdx-graphical.bb
+++ b/recipes-images/images/packagegroup-tdx-graphical.bb
@@ -22,6 +22,9 @@ RRECOMMENDS:packagegroup-tdx-graphical = " \
packagegroup-x11-utils-tdx-graphical', \
'', d), d)} \
"
+RRECOMMENDS:packagegroup-tdx-graphical:append:k3 = " \
+ packagegroup-drm-utils-tdx-graphical \
+"
RRECOMMENDS:packagegroup-tdx-graphical:append:mx8-nxp-bsp = " \
packagegroup-drm-utils-tdx-graphical \
"
diff --git a/recipes-images/images/tdx-reference-multimedia-image.bb b/recipes-images/images/tdx-reference-multimedia-image.bb
index f9f285b..4299e81 100644
--- a/recipes-images/images/tdx-reference-multimedia-image.bb
+++ b/recipes-images/images/tdx-reference-multimedia-image.bb
@@ -18,12 +18,14 @@ APP_LAUNCH_WAYLAND:colibri-imx6ull ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_WAYLAND:colibri-imx6ull-emmc ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_WAYLAND:colibri-imx7 ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_WAYLAND:colibri-imx7-emmc ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND:verdin-am62 ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_X11 ?= "x-window-qtcinematicexperience"
APP_LAUNCH_X11:colibri-imx6ull ?= "x-window-analogclock"
APP_LAUNCH_X11:colibri-imx6ull-emmc ?= "x-window-analogclock"
APP_LAUNCH_X11:colibri-imx7 ?= "x-window-analogclock"
APP_LAUNCH_X11:colibri-imx7-emmc ?= "x-window-analogclock"
+APP_LAUNCH_X11:verdin-am62 ?= "x-window-analogclock"
IMAGE_INSTALL += " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
@@ -31,6 +33,7 @@ IMAGE_INSTALL += " \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
'weston-xwayland xterm', \
bb.utils.contains('DISTRO_FEATURES', 'x11', '${APP_LAUNCH_X11}', '', d), d)} \
+ ${@bb.utils.contains("MACHINE_FEATURES", "tpm2", "packagegroup-tpm2-tdx-cli", "",d)} \
\
packagegroup-tdx-cli \
packagegroup-tdx-graphical \