summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.06.bbappend24
-rw-r--r--recipes-kernel/linux/linux-colibri-t20_git.bb27
-rw-r--r--recipes-lxde/lxdm/lxdm_0.4.1.bbappend5
3 files changed, 16 insertions, 40 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2011.06.bbappend b/recipes-bsp/u-boot/u-boot_2011.06.bbappend
index 27c3c61..fac7c1f 100644
--- a/recipes-bsp/u-boot/u-boot_2011.06.bbappend
+++ b/recipes-bsp/u-boot/u-boot_2011.06.bbappend
@@ -1,14 +1,10 @@
# Extends the core u-boot recipe
# to take the u-boot sources including the colibri stuff from our git repository
-PR ="r1"
+PR ="r2"
DEPENDS += "dtc-native"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-# Also overwries the license checksum to suit the updated text file in our U-Boot snapshot.
-#LIC_FILES_CHKSUM_colibri-t20 = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
-#LIC_FILES_CHKSUM_colibri-t30 = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
-
COMPATIBLE_MACHINE_colibri-t20 = "colibri-t20"
COMPATIBLE_MACHINE_colibri-t30 = "colibri-t30"
@@ -29,18 +25,18 @@ UBOOT_MACHINE_colibri-t30 = "colibri_t30_config"
#SRCREV_COLIBRI = "63c37d9e1d3ea97391576384d237728c44b5e33b"
#####################################################################################################################
+# toradex git ###################################################################################################
+FILESPATHPKG =. "git:"
+S="${WORKDIR}/git"
+SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
+SRCREV_COLIBRI = "2a1325206da5381292c2b268e248702c523cc927"
+#####################################################################################################################
+
PV_colibri-t20 = "${PR}+gitr${SRCREV}"
PV_colibri-t30 = "${PR}+gitr${SRCREV}"
-# internal SVN #####################################################################################################################
-S = "${WORKDIR}/bootloader/u-boot"
-SRCREV_COLIBRI = "321"
-SRC_URI_COLIBRI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=bootloader/u-boot;rev=${SRCREV_COLIBRI};protocol=http \
-"
-#####################################################################################################################
-
-SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI} "
-SRC_URI_colibri-t30 = "${SRC_URI_COLIBRI} "
+SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI}"
+SRC_URI_colibri-t30 = "${SRC_URI_COLIBRI}"
SRCREV_colibri-t20 = "${SRCREV_COLIBRI}"
SRCREV_colibri-t30 = "${SRCREV_COLIBRI}"
PV_colibri-t20 = "${PR}+gitr${SRCREV}"
diff --git a/recipes-kernel/linux/linux-colibri-t20_git.bb b/recipes-kernel/linux/linux-colibri-t20_git.bb
index a461544..9b99a53 100644
--- a/recipes-kernel/linux/linux-colibri-t20_git.bb
+++ b/recipes-kernel/linux/linux-colibri-t20_git.bb
@@ -3,31 +3,15 @@ require recipes-kernel/linux/linux.inc
LINUX_VERSION ?= "3.1.10"
-#SRCREV = "37440f3ed07a6f588b05b8f98d0b3025c1949371"
-#L4T R15 first run
-#SRCREV = "4f48c4961b86b4df1bcb4b1b535bc1c3d158b5af"
-#L4T R15, optimized config, bcm4329 warnings removed
-#SRCREV = "b562b12b12ba303d5ceca17b347d8c506e18f7f4"
-#Nand timings for 1.1, asix driver update, asix driver patch autodetach
SRCREV = "4dec0ae6f55768ba0acef97ff2c67f7d5d4663fe"
-
PV = "${LINUX_VERSION}+gitr${SRCREV}"
PR = "V2.0b1"
S = "${WORKDIR}/git"
#SRC_URI = "\
# git://gitorious.org/colibri-t20-embedded-linux-bsp/colibri_t20-linux-kernel.git;protocol=git;branch=master \
# file://bcm4329_warning.patch "
-SRC_URI = "git://git.toradex.com/linux-colibri.git;protocol=git;branch=colibri"
-# file://bcm4329_warning.patch \
-# file://remove_modules.patch "
-
-#SVN_REV = 190
-#PV = "2.6.36.2"
-#PR = "${SVN_REV}"
-#S = "${WORKDIR}/kernel"
-#SRC_URI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=kernel;rev=${SVN_REV};proto=http \
-# file://bcm4329_warning.patch "
+SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=colibri"
COMPATIBLE_MACHINE = "colibri-t20"
@@ -37,17 +21,8 @@ do_configure_prepend_colibri-t20() {
#use the defconfig provided in the kernel source tree
install -m 0644 ${S}/arch/arm/configs/colibri_t20_defconfig ${WORKDIR}/defconfig
- #compile with -O2, 4.5. compiler seems to fail with -Os
-# sed -i -e /CONFIG_CC_OPTIMIZE_FOR_SIZE/d ${WORKDIR}/defconfig
-# echo "CONFIG_CC_OPTIMIZE_FOR_SIZE=n" >> ${WORKDIR}/defconfig
-
#compile with -mno-unaligned-access, with 4.7 compiler the kernel fails
echo "KBUILD_CFLAGS += -mno-unaligned-access" >> ${S}/Makefile
}
-#do_compile_kernelmodules_colibri-t20() {
-# :
-#}
-
-#require recipes-kernel/linux/linux-tools.inc
diff --git a/recipes-lxde/lxdm/lxdm_0.4.1.bbappend b/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
index 57589d9..a31c9ed 100644
--- a/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
+++ b/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
@@ -7,6 +7,11 @@ SRC_URI += " \
file://configfiles.patch \
file://fix_event_check_bug_caused_cpu_100.patch \
"
+
+#issues during V2.0alpha development, might be removed later
+INITSCRIPT_PARAMS_colibri-t20 = "start 98 5 2 . stop 20 0 1 6 ."
+
+
pkg_postinst_${PN}() {
# Register up as default dm
mkdir -p ${sysconfdir}/X11/