summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot_git.bbappend.orig
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot_git.bbappend.orig')
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bbappend.orig23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_git.bbappend.orig b/recipes-bsp/u-boot/u-boot_git.bbappend.orig
new file mode 100644
index 0000000..9a1acc8
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_git.bbappend.orig
@@ -0,0 +1,23 @@
+# Extends the core U-Boot GIT recipe
+# to take the u-boot sources including the colibri stuff from our git repository
+
+# Also overwries the license checksum to suit the updated text file in our U-Boot snapshot.
+#LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
+
+COMPATIBLE_MACHINE = "omap3-pandora"
+DEFAULT_PREFERENCE_omap3-pandora = "1"
+
+# Latest SRCREV.
+SRCREV_pn-${PN}_omap3-pandora = "55d0d2dd5d07fbfd57309997c38da5281b9824b5"
+
+PR ="r3"
+PV_omap3-pandora = "omap3-pandora+${PR}+gitr${SRCREV}"
+
+SRC_URI_omap3-pandora = "git://git.openpandora.org/pandora-u-boot.git;branch=pandora-2011.12;protocol=git \
+"
+
+UBOOT_MACHINE_omap3-pandora = "omap3_pandora_config"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"