summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend b/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
index 05ed04d..c524db7 100644
--- a/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
+++ b/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
@@ -1,7 +1,12 @@
PRINC = "1"
-# workaround, other packages provide this already
+# workaround, meta-openembedded tries to install an unneeded but unavailable .service file
+# so provide one during install and later on delete it again
+do_install_prepend () {
+ install -d ${S}/systemd/
+ ln -s /dev/null ${S}/systemd/dummy.service
+}
+
do_install_append () {
- # NOP
- :
-} \ No newline at end of file
+ rm -f ${D}${systemd_unitdir}/system/dummy.service
+}