summaryrefslogtreecommitdiff
path: root/recipes-core/systemd/systemd_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/systemd/systemd_%.bbappend')
-rw-r--r--recipes-core/systemd/systemd_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index b24e14c..df69043 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -2,6 +2,17 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/systemd:"
SRC_URI += " \
file://networkd_dont_stop_the_dhcp_server.patch \
+ file://rndis.network \
"
PACKAGECONFIG_append = " networkd"
+
+do_install_append() {
+ # The network files need to be in /usr/lib/systemd, not ${systemd_unitdir}...
+ install -d ${D}${prefix}/lib/systemd/network/
+ install -m 0644 ${WORKDIR}/rndis.network ${D}${prefix}/lib/systemd/network/
+}
+
+FILES_${PN} += " \
+ ${nonarch_base_libdir}/systemd/network \
+"