summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/base-files/base-files/disable_systemd_coloroutput.sh3
-rw-r--r--recipes-core/base-files/base-files/profile45
-rw-r--r--recipes-core/base-files/base-files/x11-display-var.sh1
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend11
4 files changed, 15 insertions, 45 deletions
diff --git a/recipes-core/base-files/base-files/disable_systemd_coloroutput.sh b/recipes-core/base-files/base-files/disable_systemd_coloroutput.sh
new file mode 100644
index 0000000..904ad2b
--- /dev/null
+++ b/recipes-core/base-files/base-files/disable_systemd_coloroutput.sh
@@ -0,0 +1,3 @@
+# disable the colorization of systemd component output
+SYSTEMD_COLORS=0
+export DISPLAY SYSTEMD_COLORS
diff --git a/recipes-core/base-files/base-files/profile b/recipes-core/base-files/base-files/profile
deleted file mode 100644
index 22308ad..0000000
--- a/recipes-core/base-files/base-files/profile
+++ /dev/null
@@ -1,45 +0,0 @@
-# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
-# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
-
-PATH="/usr/local/bin:/usr/bin:/bin"
-EDITOR="/bin/vi" # needed for packages like cron
-test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
-
-if [ ! -e /etc/localtime ]; then
- TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
- # for an explanation of how to set this to your local timezone.
- export TZ
-fi
-
-if [ "$HOME" = "/home/root" ]; then
- PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin
-fi
-if [ "$PS1" ]; then
-# works for bash and ash (no other shells known to be in use here)
- PS1='\u@\h:\w\$ '
-fi
-
-if [ -d /etc/profile.d ]; then
- for i in /etc/profile.d/* ; do
- . $i
- done
- unset i
-fi
-
-test -z "$DISPLAY" && DISPLAY=":0.0" # have the X display defined, unless it is already set, e.g. by a ssh connection
-
-SYSTEMD_COLORS=0
-
-export PATH PS1 OPIEDIR QPEDIR QTDIR EDITOR TERM DISPLAY SYSTEMD_COLORS
-
-# Serial consoles are not able to autoresize. Set size once upon login.
-if [ -x /usr/bin/resize ] && termpath="`tty`"; then
- # Make sure we are on a serial console (i.e. the device used starts with /dev/tty),
- # otherwise we confuse e.g. the eclipse launcher which tries do use ssh
- case "$termpath" in
- /dev/tty*) resize >/dev/null
- esac
-fi
-
-umask 022
-
diff --git a/recipes-core/base-files/base-files/x11-display-var.sh b/recipes-core/base-files/base-files/x11-display-var.sh
new file mode 100644
index 0000000..ee0eeeb
--- /dev/null
+++ b/recipes-core/base-files/base-files/x11-display-var.sh
@@ -0,0 +1 @@
+test -z "$DISPLAY" && DISPLAY=":0.0" # have the X display defined, unless it is already set, e.g. by a ssh connection
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
index 613f9c6..a038011 100644
--- a/recipes-core/base-files/base-files_3.0.14.bbappend
+++ b/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -1 +1,12 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/base-files:"
+
+SRC_URI += " \
+ file://disable_systemd_coloroutput.sh \
+ file://x11-display-var.sh \
+"
+
+do_install_append () {
+ install -m 0755 -d ${D}${sysconfdir}/profile.d
+ install -m 0644 ${WORKDIR}/disable_systemd_coloroutput.sh ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${WORKDIR}/x11-display-var.sh ${D}${sysconfdir}/profile.d/
+}