summaryrefslogtreecommitdiff
path: root/recipes-devtools/python/python_2.7.9.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python_2.7.9.bbappend')
-rw-r--r--recipes-devtools/python/python_2.7.9.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/python/python_2.7.9.bbappend b/recipes-devtools/python/python_2.7.9.bbappend
new file mode 100644
index 0000000..ff0071f
--- /dev/null
+++ b/recipes-devtools/python/python_2.7.9.bbappend
@@ -0,0 +1,19 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/python:"
+
+SRC_URI_remove = "file://avoid_warning_about_tkinter.patch"
+
+PACKAGECONFIG ?= ""
+
+PACKAGECONFIG[tkinter] = ",,tk"
+PACKAGECONFIG_remove_class-native = "tkinter"
+PACKAGECONFIG_remove_class-nativesdk = "tkinter"
+RDEPENDS_${PN}-tkinter_append += "${@base_contains('PACKAGECONFIG', 'tkinter', 'tcl tk', '', d)}"
+SRC_URI += " \
+ ${@base_contains('PACKAGECONFIG', 'tkinter', '', 'file://dont_build_tkinter.patch', d)} \
+"
+python __anonymous() {
+ if not 'openembedded-layer' in d.getVar('BBFILE_COLLECTIONS'):
+ if 'tkinter' in d.getVar('PACKAGECONFIG'):
+ bb.error('Python PACKAGECONFIG tkinter requires tk provided by' \
+ 'meta-oe layer but the layer is not available.')
+}