summaryrefslogtreecommitdiff
path: root/recipes-devtools/python/python_2.7.9.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python_2.7.9.bbappend')
-rw-r--r--recipes-devtools/python/python_2.7.9.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-devtools/python/python_2.7.9.bbappend b/recipes-devtools/python/python_2.7.9.bbappend
index 64d3787..28e5d9e 100644
--- a/recipes-devtools/python/python_2.7.9.bbappend
+++ b/recipes-devtools/python/python_2.7.9.bbappend
@@ -12,8 +12,8 @@ SRC_URI += " \
${@bb.utils.contains('PACKAGECONFIG', 'tkinter', '', 'file://dont_build_tkinter.patch', d)} \
"
python __anonymous() {
- if not 'openembedded-layer' in d.getVar('BBFILE_COLLECTIONS'):
- if 'tkinter' in d.getVar('PACKAGECONFIG'):
+ if not 'openembedded-layer' in d.getVar('BBFILE_COLLECTIONS', True):
+ if 'tkinter' in d.getVar('PACKAGECONFIG', True):
bb.error('Python PACKAGECONFIG tkinter requires tk provided by' \
'meta-oe layer but the layer is not available.')
}