summaryrefslogtreecommitdiff
path: root/recipes-graphics/x-window-simple-app
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/x-window-simple-app')
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb2
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-simple-app.inc2
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb2
3 files changed, 4 insertions, 2 deletions
diff --git a/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb
index 2e44da9..968c98e 100644
--- a/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb
+++ b/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb
@@ -1,7 +1,7 @@
# set the following variable to your one and only application which should
# be started
-RDEPENDS ?= "qtsmarthome"
+INITIAL_APP_PKGS ?= "qtsmarthome"
INITIAL_PATH ?= "/usr/share/qtsmarthome-1.0"
X_APPLICATION ?= "${INITIAL_PATH}/smarthome"
diff --git a/recipes-graphics/x-window-simple-app/x-window-simple-app.inc b/recipes-graphics/x-window-simple-app/x-window-simple-app.inc
index 2c5ecc1..941aae3 100644
--- a/recipes-graphics/x-window-simple-app/x-window-simple-app.inc
+++ b/recipes-graphics/x-window-simple-app/x-window-simple-app.inc
@@ -11,6 +11,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
inherit allarch
+RDEPENDS_${PN} += "${INITIAL_APP_PKGS}"
+
S = "${WORKDIR}"
SRC_URI = " \
diff --git a/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb
index eef8e1c..302a0c7 100644
--- a/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb
+++ b/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb
@@ -1,7 +1,7 @@
# set the following variable to your one and only application which should
# be started
-RDEPENDS ?= "xterm"
+INITIAL_APP_PKGS ?= "xterm"
INITIAL_PATH ?= ""
X_APPLICATION ?= "/usr/bin/xterm"