summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend b/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
index 2d5a610..bfeb99e 100644
--- a/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
+++ b/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
@@ -6,11 +6,13 @@ inherit systemd
SRC_URI += "file://xinput-calibrator.service"
-SYSTEMD_PACKAGES = "${PN}-systemd"
SYSTEMD_SERVICE = "${PN}.service"
# menu entry should make the calibration permanent instead of printing cal data into a terminal
do_install_append() {
install -m 0755 ${D}/usr/share/applications/xinput_calibrator.desktop ${D}/usr/share/applications/xinput_calibrator.desktop.old
sed -i -e 's/xinput_calibrator; cat/rm -f \/etc\/pointercal.xinput; xinput_calibrator_once.sh/' ${D}/usr/share/applications/xinput_calibrator.desktop
-} \ No newline at end of file
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system
+}