summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb9
-rw-r--r--recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb9
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb9
3 files changed, 27 insertions, 0 deletions
diff --git a/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb
new file mode 100644
index 0000000..d11611e
--- /dev/null
+++ b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be launched right after weston started
+
+INITIAL_APP_PKGS ?= "qtbase-examples qtwayland"
+INITIAL_PATH ?= ""
+APPLICATION_ENVIRONMENT ?= '\"QT_QPA_PLATFORM=wayland-egl\"'
+WAYLAND_APPLICATION ?= "/usr/share/examples/gui/analogclock/analogclock"
+
+require wayland-app-launch.inc
diff --git a/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb
new file mode 100644
index 0000000..b85fdf0
--- /dev/null
+++ b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be launched right after weston started
+
+INITIAL_APP_PKGS ?= "qtsmarthome qtwayland"
+INITIAL_PATH ?= "/usr/share/qtsmarthome-1.0/"
+APPLICATION_ENVIRONMENT ?= '\"QT_QPA_PLATFORM=wayland-egl\"'
+WAYLAND_APPLICATION ?= "${INITIAL_PATH}/smarthome"
+
+require wayland-app-launch.inc
diff --git a/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb
new file mode 100644
index 0000000..c9bfd7a
--- /dev/null
+++ b/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be started
+
+INITIAL_APP_PKGS ?= "qtbase-examples"
+INITIAL_PATH ?= ""
+X_APPLICATION ?= "/usr/share/examples/gui/analogclock/analogclock"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/x-window-simple-app:"
+require recipes-graphics/x-window-simple-app/x-window-simple-app.inc