summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/cogl/cogl-1.0_%.bbappend2
-rw-r--r--recipes-graphics/gpicview/gpicview_0.2.5.bb4
-rw-r--r--recipes-graphics/graphviz/graphviz_2.38.0.bb2
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend6
-rw-r--r--recipes-graphics/packagegroups/packagegroup-core-x11.bbappend2
-rw-r--r--recipes-graphics/scrot/giblib_1.2.4.bb8
-rw-r--r--recipes-graphics/scrot/imlib2_git.bb26
-rw-r--r--recipes-graphics/scrot/scrot_0.8.bb6
-rw-r--r--recipes-graphics/vnc/tightvnc_1.3.10.bb8
-rw-r--r--recipes-graphics/wayland-app-launch/wayland-app-launch.inc6
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb2
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-qtcinematicexperience_1.0.bb2
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb2
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-simple-app.inc4
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb2
-rw-r--r--recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend4
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend2
17 files changed, 44 insertions, 44 deletions
diff --git a/recipes-graphics/cogl/cogl-1.0_%.bbappend b/recipes-graphics/cogl/cogl-1.0_%.bbappend
index 85e6645..8dde652 100644
--- a/recipes-graphics/cogl/cogl-1.0_%.bbappend
+++ b/recipes-graphics/cogl/cogl-1.0_%.bbappend
@@ -1,3 +1,3 @@
# Workaround populate_sdk issue which depends on cogl-1.0 which can not be
# found.
-RDEPENDS_${PN}-dev = ""
+RDEPENDS:${PN}-dev = ""
diff --git a/recipes-graphics/gpicview/gpicview_0.2.5.bb b/recipes-graphics/gpicview/gpicview_0.2.5.bb
index cee82b7..53d996f 100644
--- a/recipes-graphics/gpicview/gpicview_0.2.5.bb
+++ b/recipes-graphics/gpicview/gpicview_0.2.5.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
DEPENDS = "glib-2.0-native intltool-native jpeg"
-RDEPENDS_${PN} = "adwaita-icon-theme"
+RDEPENDS:${PN} = "adwaita-icon-theme"
SRC_URI = " \
${SOURCEFORGE_MIRROR}/lxde/${P}.tar.xz \
@@ -21,4 +21,4 @@ PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"
inherit autotools gettext mime-xdg pkgconfig
-FILES_${PN} += "${datadir}/icons/*"
+FILES:${PN} += "${datadir}/icons/*"
diff --git a/recipes-graphics/graphviz/graphviz_2.38.0.bb b/recipes-graphics/graphviz/graphviz_2.38.0.bb
index 2001d79..fa547ed 100644
--- a/recipes-graphics/graphviz/graphviz_2.38.0.bb
+++ b/recipes-graphics/graphviz/graphviz_2.38.0.bb
@@ -14,7 +14,7 @@ SRC_URI[sha256sum] = "81aa238d9d4a010afa73a9d2a704fc3221c731e1e06577c2ab3496bdef
PR = "r1"
-FILES_${PN}-dev += " \
+FILES:${PN}-dev += " \
/usr/lib/graphviz/*.so \
"
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index c82b27f..ef4e7c3 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI_append_imxgpu = " file://0001-xeglgears-drop-usage-of-fooEXT-functions.patch"
-PACKAGE_ARCH_imxgpu = "${MACHINE_SOCARCH}"
+SRC_URI:append:imxgpu = " file://0001-xeglgears-drop-usage-of-fooEXT-functions.patch"
+PACKAGE_ARCH:imxgpu = "${MACHINE_SOCARCH}"
diff --git a/recipes-graphics/packagegroups/packagegroup-core-x11.bbappend b/recipes-graphics/packagegroups/packagegroup-core-x11.bbappend
index b3b082a..8647b87 100644
--- a/recipes-graphics/packagegroups/packagegroup-core-x11.bbappend
+++ b/recipes-graphics/packagegroups/packagegroup-core-x11.bbappend
@@ -1 +1 @@
-RDEPENDS_${PN}-utils_remove = "${VIRTUAL-RUNTIME_graphical_init_manager}" \ No newline at end of file
+RDEPENDS:${PN}-utils:remove = "${VIRTUAL-RUNTIME_graphical_init_manager}" \ No newline at end of file
diff --git a/recipes-graphics/scrot/giblib_1.2.4.bb b/recipes-graphics/scrot/giblib_1.2.4.bb
index 587c7fb..8cc6835 100644
--- a/recipes-graphics/scrot/giblib_1.2.4.bb
+++ b/recipes-graphics/scrot/giblib_1.2.4.bb
@@ -5,7 +5,7 @@ LICENSE = "BSD"
DEPENDS = "imlib2"
-MIRRORS_prepend () {
+MIRRORS:prepend () {
}
SRC_URI = " \
@@ -18,14 +18,14 @@ SRC_URI[sha256sum] = "176611c4d88d742ea4013991ad54c2f9d2feefbc97a28434c0f48922eb
PR = "r0"
-do_compile_prepend () {
+do_compile:prepend () {
#remove linkerpath to host libraries
sed -i -e 's:-L/usr/lib\s::' Makefile
sed -i -e 's:-L/usr/lib\s::' giblib/Makefile
export DESTDIR=${D}
}
-do_compile_append () {
+do_compile:append () {
for i in $(find ${B} -name "*?.pc") ; do
sed -i -e s:${STAGING_DIR_TARGET}::g \
-e s:/${TARGET_SYS}::g \
@@ -33,7 +33,7 @@ do_compile_append () {
done
}
-FILES_${PN}-doc = "/usr/doc"
+FILES:${PN}-doc = "/usr/doc"
inherit autotools-brokensep binconfig pkgconfig
diff --git a/recipes-graphics/scrot/imlib2_git.bb b/recipes-graphics/scrot/imlib2_git.bb
index ee7f2e2..df3109b 100644
--- a/recipes-graphics/scrot/imlib2_git.bb
+++ b/recipes-graphics/scrot/imlib2_git.bb
@@ -30,26 +30,26 @@ OE_LT_RPATH_ALLOW = "any"
OE_LT_RPATH_ALLOW[export]="1"
PACKAGES =+ "imlib2-loaders-dbg imlib2-filters-dbg imlib2-loaders imlib2-filters ${PN}-bin imlib2-themes "
-FILES_${PN} = "${libdir}/lib*.so.* ${libdir}/imlib2/*/*.so"
-FILES_${PN}-dbg = "${libdir}/.debug/ ${bindir}/.debug/ ${prefix}/src/debug/"
-FILES_${PN}-dev += "${bindir}/imlib2-config ${libdir}/*.so ${includedir}"
-FILES_${PN}-bin = "${bindir}"
-FILES_imlib2-themes = "${datadir}/imlib2/data"
-FILES_imlib2-loaders = "${libdir}/imlib2/loaders/*.so"
-FILES_imlib2-filters = "${libdir}/imlib2/filters/*.so"
-FILES_imlib2-loaders-dbg += "${libdir}/imlib2/loaders/.debug"
-FILES_imlib2-filters-dbg += "${libdir}/imlib2/filters/.debug"
+FILES:${PN} = "${libdir}/lib*.so.* ${libdir}/imlib2/*/*.so"
+FILES:${PN}-dbg = "${libdir}/.debug/ ${bindir}/.debug/ ${prefix}/src/debug/"
+FILES:${PN}-dev += "${bindir}/imlib2-config ${libdir}/*.so ${includedir}"
+FILES:${PN}-bin = "${bindir}"
+FILES:imlib2-themes = "${datadir}/imlib2/data"
+FILES:imlib2-loaders = "${libdir}/imlib2/loaders/*.so"
+FILES:imlib2-filters = "${libdir}/imlib2/filters/*.so"
+FILES:imlib2-loaders-dbg += "${libdir}/imlib2/loaders/.debug"
+FILES:imlib2-filters-dbg += "${libdir}/imlib2/filters/.debug"
# png.so jpeg.so id3.so are also provided by lightmediascanner
-PRIVATE_LIBS_imlib2-loaders = "pnm.so lbm.so argb.so tiff.so zlib.so bmp.so tga.so gif.so xpm.so bz2.so"
+PRIVATE_LIBS:imlib2-loaders = "pnm.so lbm.so argb.so tiff.so zlib.so bmp.so tga.so gif.so xpm.so bz2.so"
-PRIVATE_LIBS_imlib2-filters = "bumpmap.so colormod.so testfilter.so"
+PRIVATE_LIBS:imlib2-filters = "bumpmap.so colormod.so testfilter.so"
-do_configure_prepend() {
+do_configure:prepend() {
autopoint || touch config.rpath
}
-do_install_prepend () {
+do_install:prepend () {
for i in `find ${B}/ -name "*.pc" -type f` ; do \
sed -i -e 's:-L${STAGING_LIBDIR}:-L\$\{libdir\}:g' -e 's:-I${STAGING_LIBDIR}:-I\$\{libdir\}:g' -e 's:-I${STAGING_INCDIR}:-I\$\{includedir\}:g' $i
done
diff --git a/recipes-graphics/scrot/scrot_0.8.bb b/recipes-graphics/scrot/scrot_0.8.bb
index 6a0b6dc..91b5638 100644
--- a/recipes-graphics/scrot/scrot_0.8.bb
+++ b/recipes-graphics/scrot/scrot_0.8.bb
@@ -4,10 +4,10 @@ DESCRIPTION = "scrot (SCReen shOT) is a simple commandline screen capture utilit
HOMEPAGE = "http://linuxbrit.co.uk/software/"
LICENSE = "BSD"
-RDEPENDS_${PN} = "imlib2-loaders"
+RDEPENDS:${PN} = "imlib2-loaders"
DEPENDS = "imlib2 giblib"
-MIRRORS_prepend () {
+MIRRORS:prepend () {
}
SRC_URI = " \
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "613d1cf524c2b62ce3c65f1232ea4f05c7daf248d5e82ff2a6892c9809
PR = "r0"
-FILES_${PN}-doc += "/usr/doc"
+FILES:${PN}-doc += "/usr/doc"
inherit autotools
diff --git a/recipes-graphics/vnc/tightvnc_1.3.10.bb b/recipes-graphics/vnc/tightvnc_1.3.10.bb
index 5bec3ce..4a707b7 100644
--- a/recipes-graphics/vnc/tightvnc_1.3.10.bb
+++ b/recipes-graphics/vnc/tightvnc_1.3.10.bb
@@ -17,8 +17,8 @@ SRC_URI = " \
S = "${WORKDIR}/vnc_unixsrc/vncviewer"
PACKAGES = "${PN}-viewer-dbg ${PN}-viewer"
-FILES_${PN}-viewer-dbg = "${bindir}/.debug"
-FILES_${PN}-viewer = "${bindir}/${PN}viewer ${sysconfdir}"
+FILES:${PN}-viewer-dbg = "${bindir}/.debug"
+FILES:${PN}-viewer = "${bindir}/${PN}viewer ${sysconfdir}"
do_compile () {
install ${WORKDIR}/Makefile ${S}
@@ -32,12 +32,12 @@ do_install () {
install -m 644 ${WORKDIR}/Vncviewer ${D}${sysconfdir}/X11/app-defaults/Vncviewer
}
-pkg_postinst_${PN}-viewer () {
+pkg_postinst:${PN}-viewer () {
update-alternatives --install ${bindir}/vncviewer vncviewer tightvncviewer 100
}
-pkg_prerm_${PN}-viewer () {
+pkg_prerm:${PN}-viewer () {
update-alternatives --remove ${bindir}/vncviewer vncviewer tightvncviewer 100
}
diff --git a/recipes-graphics/wayland-app-launch/wayland-app-launch.inc b/recipes-graphics/wayland-app-launch/wayland-app-launch.inc
index 18b6b29..946b4cc 100644
--- a/recipes-graphics/wayland-app-launch/wayland-app-launch.inc
+++ b/recipes-graphics/wayland-app-launch/wayland-app-launch.inc
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
inherit allarch systemd
-RDEPENDS_${PN} += "weston-init ${INITIAL_APP_PKGS}"
+RDEPENDS:${PN} += "weston-init ${INITIAL_APP_PKGS}"
S = "${WORKDIR}"
@@ -13,7 +13,7 @@ SRC_URI = " \
file://wayland-app-launch.service.in \
file://wayland-app-launch.sh.in \
"
-FILESEXTRAPATHS_prepend := "${THISDIR}/wayland-app-launch:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/wayland-app-launch:"
APPLICATION_ENVIRONMENT ??= ""
@@ -29,4 +29,4 @@ do_install () {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "wayland-app-launch.service"
+SYSTEMD_SERVICE:${PN} = "wayland-app-launch.service"
diff --git a/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb
index c9bfd7a..9543156 100644
--- a/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb
+++ b/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb
@@ -5,5 +5,5 @@ INITIAL_APP_PKGS ?= "qtbase-examples"
INITIAL_PATH ?= ""
X_APPLICATION ?= "/usr/share/examples/gui/analogclock/analogclock"
-FILESEXTRAPATHS_prepend := "${THISDIR}/x-window-simple-app:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/x-window-simple-app:"
require recipes-graphics/x-window-simple-app/x-window-simple-app.inc
diff --git a/recipes-graphics/x-window-simple-app/x-window-qtcinematicexperience_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-qtcinematicexperience_1.0.bb
index f9a3f4d..4921351 100644
--- a/recipes-graphics/x-window-simple-app/x-window-qtcinematicexperience_1.0.bb
+++ b/recipes-graphics/x-window-simple-app/x-window-qtcinematicexperience_1.0.bb
@@ -5,5 +5,5 @@ INITIAL_APP_PKGS ?= "cinematicexperience"
INITIAL_PATH ?= "/usr/share/cinematicexperience-1.0"
X_APPLICATION ?= "${INITIAL_PATH}/Qt5_CinematicExperience"
-FILESEXTRAPATHS_prepend := "${THISDIR}/x-window-simple-app:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/x-window-simple-app:"
require recipes-graphics/x-window-simple-app/x-window-simple-app.inc
diff --git a/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb
index 968c98e..098dec6 100644
--- a/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb
+++ b/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb
@@ -5,5 +5,5 @@ INITIAL_APP_PKGS ?= "qtsmarthome"
INITIAL_PATH ?= "/usr/share/qtsmarthome-1.0"
X_APPLICATION ?= "${INITIAL_PATH}/smarthome"
-FILESEXTRAPATHS_prepend := "${THISDIR}/x-window-simple-app:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/x-window-simple-app:"
require recipes-graphics/x-window-simple-app/x-window-simple-app.inc
diff --git a/recipes-graphics/x-window-simple-app/x-window-simple-app.inc b/recipes-graphics/x-window-simple-app/x-window-simple-app.inc
index c9578ad..a96a0d5 100644
--- a/recipes-graphics/x-window-simple-app/x-window-simple-app.inc
+++ b/recipes-graphics/x-window-simple-app/x-window-simple-app.inc
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
inherit allarch
-RDEPENDS_${PN} += "${INITIAL_APP_PKGS} xserver-nodm-init"
+RDEPENDS:${PN} += "${INITIAL_APP_PKGS} xserver-nodm-init"
S = "${WORKDIR}"
@@ -31,6 +31,6 @@ do_install () {
}
# make sure xinput_calibrator is only started once
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
rm -f /etc/xdg/autostart/xinput_calibrator.desktop
}
diff --git a/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb
index 302a0c7..da711c7 100644
--- a/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb
+++ b/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb
@@ -5,5 +5,5 @@ INITIAL_APP_PKGS ?= "xterm"
INITIAL_PATH ?= ""
X_APPLICATION ?= "/usr/bin/xterm"
-FILESEXTRAPATHS_prepend := "${THISDIR}/x-window-simple-app:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/x-window-simple-app:"
require recipes-graphics/x-window-simple-app/x-window-simple-app.inc
diff --git a/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend b/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
index 2b42880..72933f1 100644
--- a/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
+++ b/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
@@ -1,7 +1,7 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/xinput-calibrator:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/xinput-calibrator:"
# menu entry should make the calibration permanent instead of printing cal data into a terminal
-do_install_append() {
+do_install:append() {
install -m 0755 ${D}/${datadir}/applications/xinput_calibrator.desktop ${D}/${datadir}/applications/xinput_calibrator.desktop.old
sed -i -e 's/xinput_calibrator; cat/rm -f \/etc\/pointercal.xinput; xinput_calibrator_once.sh/' ${D}/${datadir}/applications/xinput_calibrator.desktop
sed -i -e 's/Terminal\=true/Terminal=false/' ${D}/${datadir}/applications/xinput_calibrator.desktop
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
index 01a7948..8bfdd5c 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
@@ -1,3 +1,3 @@
# xinput-calibrator-once expects an evdev interface, so don't install
# xf86-input-libinput which takes precedence over xf86-input-evdev
-XSERVER_RRECOMMENDS_remove = "xf86-input-libinput"
+XSERVER_RRECOMMENDS:remove = "xf86-input-libinput"