summaryrefslogtreecommitdiff
path: root/recipes-images/images/qt5-x11-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-images/images/qt5-x11-image.bb')
-rw-r--r--recipes-images/images/qt5-x11-image.bb191
1 files changed, 0 insertions, 191 deletions
diff --git a/recipes-images/images/qt5-x11-image.bb b/recipes-images/images/qt5-x11-image.bb
deleted file mode 100644
index d79946a..0000000
--- a/recipes-images/images/qt5-x11-image.bb
+++ /dev/null
@@ -1,191 +0,0 @@
-SUMMARY = "Toradex Embedded Linux Qt5 Demo"
-SUMMARY_append_apalis-tk1-mainline = " (Mainline)"
-DESCRIPTION = "Image with the Qt5 Framework"
-
-# With X11:
-# after the boot systemd starts X and then a qt5 application, check
-# recipes-graphics/x-window-simple-app/x-window-qtsmarthome and
-# https://developer.toradex.com/knowledge-base/how-to-autorun-application-at-the-start-up-in-linux#X11_with_One_User_Application
-# for how this is done.
-
-LICENSE = "MIT"
-
-inherit core-image
-
-#start of the resulting deployable tarball name
-export IMAGE_BASENAME = "Qt5-X11-Image"
-MACHINE_NAME ?= "${MACHINE}"
-IMAGE_NAME = "${MACHINE_NAME}_${IMAGE_BASENAME}"
-
-SYSTEMD_DEFAULT_TARGET = "graphical.target"
-
-inherit populate_sdk_qt5
-
-IMAGE_FEATURES += " \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
- bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
- '', d), d)} \
-"
-
-IMAGE_LINGUAS = "en-us"
-#IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
-#ROOTFS_POSTPROCESS_COMMAND += 'install_linguas; '
-
-ROOTFS_PKGMANAGE_PKGS ?= '${@oe.utils.conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${ROOTFS_PKGMANAGE}", d)}'
-
-CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-client"
-
-# this would pull in a large amount of gst-plugins, we only add a selected few
-# gstreamer1.0-plugins-base-meta
-# gstreamer1.0-plugins-good-meta
-# gstreamer1.0-plugins-bad-meta
-# gst-ffmpeg
-GSTREAMER = " \
- gstreamer1.0 \
- gstreamer1.0-plugins-base \
- gstreamer1.0-plugins-base-alsa \
- gstreamer1.0-plugins-base-audioconvert \
- gstreamer1.0-plugins-base-audioresample \
- gstreamer1.0-plugins-base-audiotestsrc \
- gstreamer1.0-plugins-base-typefindfunctions \
- gstreamer1.0-plugins-base-ogg \
- gstreamer1.0-plugins-base-theora \
- gstreamer1.0-plugins-base-videotestsrc \
- gstreamer1.0-plugins-base-vorbis \
- gstreamer1.0-plugins-good-audioparsers \
- gstreamer1.0-plugins-good-autodetect \
- gstreamer1.0-plugins-good-avi \
- gstreamer1.0-plugins-good-deinterlace \
- gstreamer1.0-plugins-good-id3demux \
- gstreamer1.0-plugins-good-isomp4 \
- gstreamer1.0-plugins-good-matroska \
- gstreamer1.0-plugins-good-multifile \
- gstreamer1.0-plugins-good-rtp \
- gstreamer1.0-plugins-good-rtpmanager \
- gstreamer1.0-plugins-good-udp \
- gstreamer1.0-plugins-good-video4linux2 \
- gstreamer1.0-plugins-good-wavenc \
- gstreamer1.0-plugins-good-wavparse \
-"
-
-GSTREAMER_MX6QDL = " \
- gstreamer1.0-plugins-base-ximagesink \
- gstreamer1.0-plugins-imx \
-"
-GSTREAMER_append_mx6q = "${GSTREAMER_MX6QDL}"
-GSTREAMER_append_mx6dl = "${GSTREAMER_MX6QDL}"
-
-GSTREAMER_colibri-imx6ull = ""
-
-GSTREAMER_append_mx7 = " \
- gstreamer1.0-plugins-base-ximagesink \
- imx-gst1.0-plugin \
-"
-
-GSTREAMER_append_mx8 = " \
- imx-gst1.0-plugin \
- imx-gst1.0-plugin-gplay \
- imx-gst1.0-plugin-grecorder \
- packagegroup-fsl-gstreamer1.0-full \
- gst-examples \
- tinycompress \
- libvdk-imx \
- libopenvx-imx \
- libopencl-imx \
- imx-gpu-viv \
- vulkan-tools \
-"
-
-GSTREAMER_append_tegra124 = " \
- ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \
- gstreamer1.0-plugins-bad-videoparsersbad \
- libgstnvegl \
- libgstomx-1.0 \
-"
-
-IMAGE_INSTALL_QT5 = " \
- packagegroup-qt5 \
- liberation-fonts \
- x-window-qtsmarthome \
-"
-
-IMAGE_INSTALL_append_tegra124 = " \
- libglu \
- mesa-demos \
- freeglut \
- tiff \
- xvinfo \
-"
-IMAGE_INSTALL_append_tegra124m = " \
- libglu \
- mesa-demos \
- freeglut \
- tiff \
- xvinfo \
-"
-IMAGE_INSTALL_MX6QDL = " \
- packagegroup-fsl-gpu-libs \
- libopencl-imx \
-"
-IMAGE_INSTALL_append_mx6q = "${IMAGE_INSTALL_MX6QDL}"
-IMAGE_INSTALL_append_mx6dl = "${IMAGE_INSTALL_MX6QDL}"
-
-# Packages which might no longer exist
-RRECOMMENDS_${PN} += "xserver-xorg-multimedia-modules"
-
-IMAGE_INSTALL += " \
- ${IMAGE_INSTALL_QT5} \
- \
- xdg-utils \
- \
- libgsf \
- libxres \
- makedevs \
- mime-support \
- xcursor-transparent-theme \
- zeroconf \
- packagegroup-boot \
- packagegroup-basic \
- udev-extra-rules \
- ${CONMANPKGS} \
- ${ROOTFS_PKGMANAGE_PKGS} \
- timestamp-service \
- xserver-common \
- xserver-xorg-extension-dbe \
- xserver-xorg-extension-extmod \
- xauth \
- xhost \
- xset \
- setxkbmap \
- \
- xrdb \
- xorg-minimal-fonts xserver-xorg-utils \
- scrot \
- unclutter \
- \
- libxdamage libxvmc libxinerama \
- libxcursor \
- \
- bash \
- \
- ${GSTREAMER} \
- v4l-utils \
- libpcre \
- libpcreposix \
- libxcomposite \
- alsa-states \
- \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
- 'weston weston-init weston-examples libdrm-tests', \
- bb.utils.contains('DISTRO_FEATURES', 'x11', \
- 'xserver-nodm-init', '', d), d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
- 'weston-xwayland xterm', '', d)} \
-"
-
-require recipes-images/images/tdx-extra.inc
-
-IMAGE_DEV_MANAGER = "udev"
-IMAGE_INIT_MANAGER = "systemd"
-IMAGE_INITSCRIPTS = " "
-IMAGE_LOGIN_MANAGER = "busybox shadow"