summaryrefslogtreecommitdiff
path: root/recipes-images/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-images/images')
-rw-r--r--recipes-images/images/packagegroup-tdx-cli.bb9
-rw-r--r--recipes-images/images/packagegroup-tdx-graphical.bb2
-rw-r--r--recipes-images/images/packagegroup-tdx-qt5.bb4
-rw-r--r--recipes-images/images/tdx-reference-minimal-image.bb5
-rw-r--r--recipes-images/images/tdx-reference-multimedia-image.bb8
5 files changed, 18 insertions, 10 deletions
diff --git a/recipes-images/images/packagegroup-tdx-cli.bb b/recipes-images/images/packagegroup-tdx-cli.bb
index f329401..21709c2 100644
--- a/recipes-images/images/packagegroup-tdx-cli.bb
+++ b/recipes-images/images/packagegroup-tdx-cli.bb
@@ -65,6 +65,7 @@ RRECOMMENDS_packagegroup-devel-tdx-cli = "\
bonnie++ \
devmem2 \
evtest \
+ fio \
gdbserver \
i2c-tools \
ldd \
@@ -94,9 +95,16 @@ RRECOMMENDS_packagegroup-machine-tdx-cli_colibri-imx6ull = "\
mtd-utils-ubifs \
mwifiexap \
"
+RRECOMMENDS_packagegroup-machine-tdx-cli_colibri-imx6ull-emmc = "\
+ bmode-usb \
+"
RRECOMMENDS_packagegroup-machine-tdx-cli_colibri-imx7 = "\
mtd-utils-ubifs \
"
+RRECOMMENDS_packagegroup-machine-tdx-cli_verdin-imx8mp = "\
+ btuart \
+ mwifiexap \
+"
RRECOMMENDS_packagegroup-machine-tdx-cli_mx8 = "\
mwifiexap \
"
@@ -179,6 +187,7 @@ RRECOMMENDS_packagegroup-wifi-tdx-cli = "\
SUMMARY_packagegroup-wifi-fw-tdx-cli = "Wi-Fi firmware"
RRECOMMENDS_packagegroup-wifi-fw-tdx-cli = "\
linux-firmware-ath10k \
+ linux-firmware-nxp89xx \
linux-firmware-sd8686 \
linux-firmware-sd8688 \
linux-firmware-sd8787 \
diff --git a/recipes-images/images/packagegroup-tdx-graphical.bb b/recipes-images/images/packagegroup-tdx-graphical.bb
index 4088c44..de9e381 100644
--- a/recipes-images/images/packagegroup-tdx-graphical.bb
+++ b/recipes-images/images/packagegroup-tdx-graphical.bb
@@ -51,6 +51,7 @@ GSTREAMER_MX6QDL = " \
RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_append_mx6dl = " ${GSTREAMER_MX6QDL}"
RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_append_mx6q = " ${GSTREAMER_MX6QDL}"
RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_colibri-imx6ull = ""
+RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_colibri-imx6ull-emmc = ""
RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_append_mx7 = " imx-gst1.0-plugin"
RRECOMMENDS_packagegroup-gstreamer-tdx-graphical_append_mx8 = " \
imx-gst1.0-plugin \
@@ -79,6 +80,7 @@ RRECOMMENDS_packagegroup-gpu-tdx-graphical_append_mx6q = " \
${IMAGE_INSTALL_OPENCL_IMX} \
"
RRECOMMENDS_packagegroup-gpu-tdx-graphical_colibri-imx6ull = ""
+RRECOMMENDS_packagegroup-gpu-tdx-graphical_colibri-imx6ull-emmc = ""
RRECOMMENDS_packagegroup-gpu-tdx-graphical_append_mx8 = " \
tinycompress \
libvdk-imx \
diff --git a/recipes-images/images/packagegroup-tdx-qt5.bb b/recipes-images/images/packagegroup-tdx-qt5.bb
index ea14bc9..f3828ba 100644
--- a/recipes-images/images/packagegroup-tdx-qt5.bb
+++ b/recipes-images/images/packagegroup-tdx-qt5.bb
@@ -22,6 +22,10 @@ RRECOMMENDS_${PN}_colibri-imx6ull = " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland', '', d)} \
qtbase-examples \
"
+RRECOMMENDS_${PN}_colibri-imx6ull-emmc = " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland', '', d)} \
+ qtbase-examples \
+"
RRECOMMENDS_${PN}_colibri-imx7 = " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland', '', d)} \
qtbase-examples \
diff --git a/recipes-images/images/tdx-reference-minimal-image.bb b/recipes-images/images/tdx-reference-minimal-image.bb
index ae2e0dc..1be5909 100644
--- a/recipes-images/images/tdx-reference-minimal-image.bb
+++ b/recipes-images/images/tdx-reference-minimal-image.bb
@@ -14,11 +14,6 @@ IMAGE_NAME = "${MACHINE_NAME}_${IMAGE_BASENAME}"
COPY_LIC_MANIFEST ?= "1"
COPY_LIC_DIRS ?= "1"
-# Show Tezi EULA license
-TEZI_SHOW_EULA_LICENSE ?= "1"
-TEZI_SHOW_EULA_LICENSE_apalis-tk1 ?= "0"
-TEZI_SHOW_EULA_LICENSE_use-mainline-bsp ?= "0"
-
add_rootfs_version () {
printf "${DISTRO_NAME} ${DISTRO_VERSION} (${DISTRO_CODENAME}) \\\n \\\l\n" > ${IMAGE_ROOTFS}/etc/issue
printf "${DISTRO_NAME} ${DISTRO_VERSION} (${DISTRO_CODENAME}) %%h\n" > ${IMAGE_ROOTFS}/etc/issue.net
diff --git a/recipes-images/images/tdx-reference-multimedia-image.bb b/recipes-images/images/tdx-reference-multimedia-image.bb
index 8365909..252f7fc 100644
--- a/recipes-images/images/tdx-reference-multimedia-image.bb
+++ b/recipes-images/images/tdx-reference-multimedia-image.bb
@@ -8,11 +8,6 @@ inherit populate_sdk_qt5
#Prefix to the resulting deployable tarball name
export IMAGE_BASENAME = "Reference-Multimedia-Image"
-# Show Tezi EULA license
-TEZI_SHOW_EULA_LICENSE ?= "1"
-TEZI_SHOW_EULA_LICENSE_apalis-tk1 ?= "0"
-TEZI_SHOW_EULA_LICENSE_use-mainline-bsp ?= "0"
-
SYSTEMD_DEFAULT_TARGET = "graphical.target"
IMAGE_FEATURES += " \
@@ -23,12 +18,14 @@ IMAGE_FEATURES += " \
APP_LAUNCH_WAYLAND ?= "wayland-qtdemo-launch-cinematicexperience"
APP_LAUNCH_WAYLAND_colibri-imx6ull ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND_colibri-imx6ull-emmc ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_WAYLAND_colibri-imx7 ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_WAYLAND_colibri-imx7-emmc ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_WAYLAND_apalis-tk1 ?= "wayland-qtdemo-launch-qtsmarthome"
APP_LAUNCH_X11 ?= "x-window-qtcinematicexperience"
APP_LAUNCH_X11_colibri-imx6ull ?= "x-window-analogclock"
+APP_LAUNCH_X11_colibri-imx6ull-emmc ?= "x-window-analogclock"
APP_LAUNCH_X11_colibri-imx7 ?= "x-window-analogclock"
APP_LAUNCH_X11_colibri-imx7-emmc ?= "x-window-analogclock"
APP_LAUNCH_X11_apalis-tk1 ?= "x-window-qtsmarthome"
@@ -50,6 +47,7 @@ IMAGE_INSTALL += " \
less \
makedevs \
mime-support \
+ net-tools \
util-linux \
v4l-utils \
\