summaryrefslogtreecommitdiff
path: root/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-lxde/lxdm/lxdm_0.4.1.bbappend')
-rw-r--r--recipes-lxde/lxdm/lxdm_0.4.1.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-lxde/lxdm/lxdm_0.4.1.bbappend b/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
new file mode 100644
index 0000000..ce46a81
--- /dev/null
+++ b/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
@@ -0,0 +1,20 @@
+PRINC = "1"
+
+THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
+FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
+
+SRC_URI += " \
+ file://missingAM_GLIB_GNU_GETTEXT.patch \
+ file://configfiles.patch \
+"
+pkg_postinst_${PN}() {
+ # Register up as default dm
+ mkdir -p ${sysconfdir}/X11/
+ echo "${sbindir}/lxdm" > ${sysconfdir}/X11/default-display-manager
+ # the lxdm script in init.d includes the script functions, make an empty one if this does not yet exist
+ touch /etc/init.d/functions
+}
+
+pkg_postrm_${PN} () {
+ sed -i /lxdm/d ${sysconfdir}/X11/default-display-manager || true
+}