summaryrefslogtreecommitdiff
path: root/recipes-lxde/lxdm
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-lxde/lxdm')
-rw-r--r--recipes-lxde/lxdm/lxdm/lxdm.service10
-rw-r--r--recipes-lxde/lxdm/lxdm_0.4.1.bbappend15
2 files changed, 19 insertions, 6 deletions
diff --git a/recipes-lxde/lxdm/lxdm/lxdm.service b/recipes-lxde/lxdm/lxdm/lxdm.service
new file mode 100644
index 0000000..b01c27d
--- /dev/null
+++ b/recipes-lxde/lxdm/lxdm/lxdm.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=LXDM Display Manager
+After=systemd-user-sessions.service
+
+[Service]
+ExecStart=/usr/sbin/lxdm
+StandardOutput=syslog
+
+[Install]
+Alias=display-manager.service
diff --git a/recipes-lxde/lxdm/lxdm_0.4.1.bbappend b/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
index 028de4c..3186065 100644
--- a/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
+++ b/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
@@ -1,15 +1,12 @@
-PRINC = "3"
+PRINC = "4"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += " \
- file://configfiles.patch \
+ file://configfiles.patch \
+ file://lxdm.service \
"
-#issues during V2.0alpha development, might be removed later
-INITSCRIPT_PARAMS_colibri-t20 = "start 98 5 2 . stop 20 0 1 6 ."
-
-
pkg_postinst_${PN}() {
# Register up as default dm
mkdir -p ${sysconfdir}/X11/
@@ -21,3 +18,9 @@ pkg_postinst_${PN}() {
pkg_postrm_${PN} () {
sed -i /lxdm/d ${sysconfdir}/X11/default-display-manager || true
}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/systemd/system
+ install -m 0644 ${WORKDIR}/lxdm.service ${D}/${sysconfdir}/systemd/system
+ ln -s lxdm.service ${D}/${sysconfdir}/systemd/system/display-manager.service
+}