summaryrefslogtreecommitdiff
path: root/recipes-qt/qt5/qtbase_5.2.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtbase_5.2.1.bbappend')
-rw-r--r--recipes-qt/qt5/qtbase_5.2.1.bbappend17
1 files changed, 13 insertions, 4 deletions
diff --git a/recipes-qt/qt5/qtbase_5.2.1.bbappend b/recipes-qt/qt5/qtbase_5.2.1.bbappend
index 0682198..d06ff2d 100644
--- a/recipes-qt/qt5/qtbase_5.2.1.bbappend
+++ b/recipes-qt/qt5/qtbase_5.2.1.bbappend
@@ -1,9 +1,18 @@
-
-PACKAGECONFIG_GLES2 ?= "gles2"
+PACKAGECONFIG_GL_tegra = "gles2"
PACKAGECONFIG_EXAMPLES ?= "examples"
-PACKAGECONFIG += " \
- ${PACKAGECONFIG_GLES2} \
+PACKAGECONFIG_append_tegra += " \
${PACKAGECONFIG_EXAMPLES} \
"
+PACKAGECONFIG_append_vf += " \
+ ${PACKAGECONFIG_EXAMPLES} \
+"
+# Workaround from the Fedora ARM port preventing the following compiler error
+# happening with the Linaro 4.8. 2014.04 toolchain
+# qtbase-opensource-src-5.2.1/src/tools/qdoc/quoter.cpp:139:1: internal compiler error: in add_stores, at var-tracking.c:5918
+#
+# https://bugs.linaro.org/show_bug.cgi?id=534
+# http://pkgs.fedoraproject.org/cgit/mingw-qt5-qtbase.git/tree/qt5-workaround-gcc48-arm-build-failure.patch?h=f20
+FILESEXTRAPATHS_prepend := "${THISDIR}/files/:"
+SRC_URI += "file://0017-qt5-workaround-gcc48-arm-build-failure.patch"