summaryrefslogtreecommitdiff
path: root/recipes-qt
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/files/0017-qt5-workaround-gcc48-arm-build-failure.patch11
-rw-r--r--recipes-qt/qt5/qtbase_%.bbappend13
-rw-r--r--recipes-qt/qt5/qtbase_5.2.1.bbappend18
-rw-r--r--recipes-qt/qt5/qtmultimedia_%.bbappend7
-rw-r--r--recipes-qt/qt5/qtwebkit_%.bbappend7
5 files changed, 27 insertions, 29 deletions
diff --git a/recipes-qt/qt5/files/0017-qt5-workaround-gcc48-arm-build-failure.patch b/recipes-qt/qt5/files/0017-qt5-workaround-gcc48-arm-build-failure.patch
deleted file mode 100644
index 33882a3..0000000
--- a/recipes-qt/qt5/files/0017-qt5-workaround-gcc48-arm-build-failure.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/tools/qdoc/qdoc.pro.orig 2014-07-06 21:10:09.054048842 +0200
-+++ b/src/tools/qdoc/qdoc.pro 2014-07-06 21:11:00.960577053 +0200
-@@ -74,6 +74,8 @@
- tree.cpp \
- yyindent.cpp
-
-+QMAKE_CXXFLAGS_CXX11 =
-+
- ### QML/JS Parser ###
-
- include(qmlparser/parser.pri)
diff --git a/recipes-qt/qt5/qtbase_%.bbappend b/recipes-qt/qt5/qtbase_%.bbappend
new file mode 100644
index 0000000..00cdb2f
--- /dev/null
+++ b/recipes-qt/qt5/qtbase_%.bbappend
@@ -0,0 +1,13 @@
+PACKAGECONFIG_GL_tegra = "gles2"
+PACKAGECONFIG_EXAMPLES ?= "examples"
+
+#qtbase must be configured with icu for qtwebkit
+PACKAGECONFIG_append_tegra = " \
+ icu \
+ ${PACKAGECONFIG_EXAMPLES} \
+"
+
+PACKAGECONFIG_append_vf = " \
+ icu \
+ ${PACKAGECONFIG_EXAMPLES} \
+"
diff --git a/recipes-qt/qt5/qtbase_5.2.1.bbappend b/recipes-qt/qt5/qtbase_5.2.1.bbappend
deleted file mode 100644
index d06ff2d..0000000
--- a/recipes-qt/qt5/qtbase_5.2.1.bbappend
+++ /dev/null
@@ -1,18 +0,0 @@
-PACKAGECONFIG_GL_tegra = "gles2"
-PACKAGECONFIG_EXAMPLES ?= "examples"
-
-PACKAGECONFIG_append_tegra += " \
- ${PACKAGECONFIG_EXAMPLES} \
-"
-
-PACKAGECONFIG_append_vf += " \
- ${PACKAGECONFIG_EXAMPLES} \
-"
-# Workaround from the Fedora ARM port preventing the following compiler error
-# happening with the Linaro 4.8. 2014.04 toolchain
-# qtbase-opensource-src-5.2.1/src/tools/qdoc/quoter.cpp:139:1: internal compiler error: in add_stores, at var-tracking.c:5918
-#
-# https://bugs.linaro.org/show_bug.cgi?id=534
-# http://pkgs.fedoraproject.org/cgit/mingw-qt5-qtbase.git/tree/qt5-workaround-gcc48-arm-build-failure.patch?h=f20
-FILESEXTRAPATHS_prepend := "${THISDIR}/files/:"
-SRC_URI += "file://0017-qt5-workaround-gcc48-arm-build-failure.patch"
diff --git a/recipes-qt/qt5/qtmultimedia_%.bbappend b/recipes-qt/qt5/qtmultimedia_%.bbappend
new file mode 100644
index 0000000..d398475
--- /dev/null
+++ b/recipes-qt/qt5/qtmultimedia_%.bbappend
@@ -0,0 +1,7 @@
+PACKAGECONFIG_append_tegra = " \
+ gstreamer010 \
+"
+PACKAGECONFIG_remove_tegra = " \
+ gstreamer \
+"
+PACKAGE_ARCH_tegra = "${MACHINE_ARCH}"
diff --git a/recipes-qt/qt5/qtwebkit_%.bbappend b/recipes-qt/qt5/qtwebkit_%.bbappend
new file mode 100644
index 0000000..d398475
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit_%.bbappend
@@ -0,0 +1,7 @@
+PACKAGECONFIG_append_tegra = " \
+ gstreamer010 \
+"
+PACKAGECONFIG_remove_tegra = " \
+ gstreamer \
+"
+PACKAGE_ARCH_tegra = "${MACHINE_ARCH}"