summaryrefslogtreecommitdiff
path: root/recipes/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/console-trdx-image.bb~44
-rw-r--r--recipes/images/lx.inc~39
-rw-r--r--recipes/images/trdx-extra.inc~55
3 files changed, 0 insertions, 138 deletions
diff --git a/recipes/images/console-trdx-image.bb~ b/recipes/images/console-trdx-image.bb~
deleted file mode 100644
index 8d56094..0000000
--- a/recipes/images/console-trdx-image.bb~
+++ /dev/null
@@ -1,44 +0,0 @@
-#Angstrom image
-DESCRIPTION = "Image booting to a console"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-
-#create the file /etc/timestamp
-IMAGE_PREPROCESS_COMMAND = "rootfs_update_timestamp"
-
-#IMAGE_LINGUAS = ""
-#IMAGE_LINGUAS = "en-us"
-#IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
-#ROOTFS_POSTPROCESS_COMMAND += 'install_linguas; '
-
-ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
-
-DISTRO_UPDATE_ALTERNATIVES ??= ""
-ROOTFS_PKGMANAGE_PKGS ?= '${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${ROOTFS_PKGMANAGE} ${DISTRO_UPDATE_ALTERNATIVES}", d)}'
-
-CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-systemd"
-CONMANPKGS_libc-uclibc = ""
-
-
-IMAGE_INSTALL += " \
- angstrom-task-boot \
- task-basic \
- ${CONMANPKGS} \
- ${ROOTFS_PKGMANAGE_PKGS} \
- task-base-extended \
- ${ANGSTROM_EXTRA_INSTALL} \
- ${SPLASH} \
- ${ZZAPSPLASH} \
-"
-
-include trdx-extra.inc
-
-IMAGE_DEV_MANAGER = "udev"
-IMAGE_INIT_MANAGER = "sysvinit sysvinit-pidof"
-IMAGE_INITSCRIPTS = "initscripts"
-IMAGE_LOGIN_MANAGER = "tinylogin shadow"
-
-export IMAGE_BASENAME = "console-trdx-image"
-
-inherit image
diff --git a/recipes/images/lx.inc~ b/recipes/images/lx.inc~
deleted file mode 100644
index 1d9cfad..0000000
--- a/recipes/images/lx.inc~
+++ /dev/null
@@ -1,39 +0,0 @@
-IMAGE_INSTALL += " \
- task-lxde-extended \
- \
- xinput-calibrator \
- \
- lxde-common \
- openbox \
- openbox-theme-clearlooks \
- openbox-theme-onyx \
- lxde-icon-theme \
- hicolor-icon-theme \
- lxdm \
- lxsession \
- lxmenu-data \
- menu-cache \
- lxappearance \
- obconf \
- lxpanel \
- \
- lxtask \
- lxpolkit \
- lxsession-edit \
- \
- lxshortcut \
- lxlauncher \
- pcmanfm \
- leafpad \
- gpicview \
- lxterminal \
- lxinput \
-"
-# angstrom-task-lxde \
-# task-lxde-xserver \
-# task-lxde-xserver-base \
-# xkbd \
-# xcursor-themes \
-# lxappearance-obconf \
-# lxrandr \
-# policykit-gnome \
diff --git a/recipes/images/trdx-extra.inc~ b/recipes/images/trdx-extra.inc~
deleted file mode 100644
index df14875..0000000
--- a/recipes/images/trdx-extra.inc~
+++ /dev/null
@@ -1,55 +0,0 @@
-#additional packages to include in our Toradex images
-
-#the following builds cross gdb
-DEPENDS += "gdb-cross"
-
-#the gdb recipe provides gdbserver
-DEPENDS += "gdb"
-
-IMAGE_INSTALL_MACHINE_colibri-t20 += " \
- trdx-odm \
-"
-IMAGE_INSTALL_MACHINE += " \
-"
-
-IMAGE-INSTALL += " \
- alsa-utils \
- alsa-utils-aplay \
- alsa-utils-amixer \
- \
- \
- aspell \
- consolekit \
- sqlite3 \
- \
- curl \
- nfs-utils-client \
- openssh-scp \
- openssh-sftp \
- pam-plugin-ck-connector \
- \
- bzip2 \
- gdbserver \
- grep \
-# joe \
- ldd \
- mtd-utils \
- update-modules \
- \
- hdparm \
- iperf \
- memtester \
- stress \
- lmbench \
- nbench-byte \
- \
- trdx-nv-binaries \
- ${IMAGE_INSTALL_MACHINE} \
- trdx-config \
- \
- trdx-oak-sensors \
-"
-# tegrastats \
-# gpioconfig \
-# openssl-conf \
-# ntpclient \