summaryrefslogtreecommitdiff
path: root/recipes/tegrastats-gtk/tegrastats-gtk.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tegrastats-gtk/tegrastats-gtk.bb')
-rw-r--r--recipes/tegrastats-gtk/tegrastats-gtk.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/tegrastats-gtk/tegrastats-gtk.bb b/recipes/tegrastats-gtk/tegrastats-gtk.bb
new file mode 100644
index 0000000..9f6f8d5
--- /dev/null
+++ b/recipes/tegrastats-gtk/tegrastats-gtk.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "NVIDIAS tegrastats output in a gtk title bar"
+LICENSE = "NVIDIA Propriatry"
+
+DEPENDS = "gtk+"
+PR = "r1"
+
+S = "${WORKDIR}"
+
+SRC_URI="file://stats.c file://main.c file://Makefile"
+LIC_FILES_CHKSUM = "file://main.c;endline=9;md5=2fa47532d931bff0348b6d6835bf86ed"
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 ${S}/tegrastats-gtk ${D}${bindir}/
+}
+
+FILES_${PN} = "${bindir}/tegrastats-gtk" \ No newline at end of file