summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierluigi Passaro <pierluigi.p@variscite.com>2019-05-25 13:02:40 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-06-11 19:08:46 +0200
commit45ad445243f9d77673554313e19c07993050b479 (patch)
treec8584bf97f9f9d5a3d000a842d7a1584f1b16484
parentb21d29250847e4998ee64ca173891cb7828454be (diff)
xserver-xorg: fix crash with latest 1.20.1
This NXP patch was actually already available in poky layer, but has been removed with commit 9d2cbf041403f5012b251de6c2dc0683755398ed. However, it seems to be mandatory to allow Vivante driver working correctly. Taken from: https://github.com/varigit/meta-variscite-fslc/commit/d51c571a44feca398cebb218cfe9c187976cb5be Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/0003-Remove-check-for-useSIGIO-option.patch47
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.20.1.bbappend3
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/0003-Remove-check-for-useSIGIO-option.patch b/recipes-graphics/xorg-xserver/xserver-xorg/0003-Remove-check-for-useSIGIO-option.patch
new file mode 100644
index 0000000..beed6cb
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/0003-Remove-check-for-useSIGIO-option.patch
@@ -0,0 +1,47 @@
+From cf407b16cd65ad6e26a9c8e5984e163409a5c0f7 Mon Sep 17 00:00:00 2001
+From: Prabhu Sundararaj <prabhu.sundararaj@nxp.com>
+Date: Mon, 30 Jan 2017 16:32:06 -0600
+Subject: [PATCH] Remove check for useSIGIO option
+
+Commit 6a5a4e60373c1386b311b2a8bb666c32d68a9d99 removes the configure of useSIGIO
+option.
+
+As the xfree86 SIGIO support is reworked to use internal versions of OsBlockSIGIO
+and OsReleaseSIGIO.
+
+No longer the check for useSIGIO is needed
+
+Upstream-Status: Pending
+
+Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@nxp.com>
+---
+ hw/xfree86/os-support/shared/sigio.c | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/hw/xfree86/os-support/shared/sigio.c b/hw/xfree86/os-support/shared/sigio.c
+index 884a71c..be76498 100644
+--- a/hw/xfree86/os-support/shared/sigio.c
++++ b/hw/xfree86/os-support/shared/sigio.c
+@@ -185,9 +185,6 @@ xf86InstallSIGIOHandler(int fd, void (*f) (int, void *), void *closure)
+ int i;
+ int installed = FALSE;
+
+- if (!xf86Info.useSIGIO)
+- return 0;
+-
+ for (i = 0; i < MAX_FUNCS; i++) {
+ if (!xf86SigIOFuncs[i].f) {
+ if (xf86IsPipe(fd))
+@@ -256,9 +253,6 @@ xf86RemoveSIGIOHandler(int fd)
+ int max;
+ int ret;
+
+- if (!xf86Info.useSIGIO)
+- return 0;
+-
+ max = 0;
+ ret = 0;
+ for (i = 0; i < MAX_FUNCS; i++) {
+--
+2.7.4
+
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.20.1.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_1.20.1.bbappend
new file mode 100644
index 0000000..fd0d723
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.20.1.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append_mx6 = " file://0003-Remove-check-for-useSIGIO-option.patch"