summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-02-19 15:43:35 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-07 11:23:12 +0200
commitf94d31a7d64b539cc75bd1c21378dbb98587f6af (patch)
tree5826e6e6bef9073c94b3cb0803118d9a86c1e9b2
parent26bfaea3812a11aad46f9e8abfe59aa6658fa146 (diff)
layer.conf: add layer dependencies
While at it clean-up and unify with other Toradex layers. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--conf/layer.conf14
1 files changed, 10 insertions, 4 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 3b1666b..eec2324 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -1,9 +1,8 @@
-# We have a conf and classes directory, add to BBPATH
+# We have a conf and classes directory, append to BBPATH
BBPATH .= ":${LAYERDIR}"
-# We have a recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "toradex-nxp-layer"
BBFILE_PATTERN_toradex-nxp-layer = "^${LAYERDIR}/"
@@ -16,3 +15,10 @@ BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
# Add layer-specific bb files too
BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
for layer in BBFILE_COLLECTIONS.split())}"
+
+LAYERDEPENDS_toradex-nxp-layer = " \
+ core \
+ freescale-layer \
+ fsl-arm-extra \
+ toradex-bsp-common-layer \
+"