summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-06-24 20:05:04 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-06-24 20:05:41 +0200
commit704f2dd5a0b11f8cd6fef28ecb540c2ca5c11e8b (patch)
tree66f3d0c14ea06a00f8a2bb78e4a901794e59da25
parent9b04fbd8e18341b1a2a9f7ad9918355741b5644c (diff)
imx-atf: deploy binary additionally with the name used for atf 2.0
This helps that the user of the file (imx-boot) need not be aware of the atf version. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/imx-atf/imx-atf_%.bbappend9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_%.bbappend b/recipes-bsp/imx-atf/imx-atf_%.bbappend
index 5e8fd11..535bb98 100644
--- a/recipes-bsp/imx-atf/imx-atf_%.bbappend
+++ b/recipes-bsp/imx-atf/imx-atf_%.bbappend
@@ -1,3 +1,10 @@
PV = "1.5.0+git${SRCPV}"
SRCBRANCH = "imx_4.14.78_1.0.0_ga"
-SRCREV = "d6451cc1e162eff89b03dd63e86d55b9baa8885b" \ No newline at end of file
+SRCREV = "d6451cc1e162eff89b03dd63e86d55b9baa8885b"
+
+# imx-atf 1.5 uses bl31-imx8qxp.bin, 2.0 will use bl31-imx8qx.bin for a
+# platform specific filename. Provide both for now, so that the user of
+# the file need not care.
+do_deploy_append_mx8qxp () {
+ install -Dm 0644 ${S}/build/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-imx8qx.bin
+} \ No newline at end of file