summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-02-18 19:02:34 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2020-03-12 19:06:46 +0100
commit4be26a02083ee3329ba037ea7ec60f153c2a3067 (patch)
tree9e5607de138a087eddbb9f93bdf39bcde460eea0
parent78802e3ecd139a5031c06821526f249e060894c1 (diff)
imx-atf: update to 4.14.98 2.3.1
Related-to: ELB-2351 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/imx-atf/imx-atf_%.bbappend14
1 files changed, 10 insertions, 4 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_%.bbappend b/recipes-bsp/imx-atf/imx-atf_%.bbappend
index c48fb6b..f7e3bd9 100644
--- a/recipes-bsp/imx-atf/imx-atf_%.bbappend
+++ b/recipes-bsp/imx-atf/imx-atf_%.bbappend
@@ -1,12 +1,18 @@
-PV = "1.5.0+git${SRCPV}"
-SRCBRANCH = "imx_4.14.78_1.0.0_ga"
-SRCREV = "d6451cc1e162eff89b03dd63e86d55b9baa8885b"
+#PV = "1.5.0+git${SRCPV}"
+#SRCBRANCH = "imx_4.14.78_1.0.0_ga"
+#SRCREV = "d6451cc1e162eff89b03dd63e86d55b9baa8885b"
+#PLATFORM_mx8qxp = "imx8qxp"
-PLATFORM_mx8qxp = "imx8qxp"
+PV = "2.0+git${SRCPV}"
+SRCBRANCH = "imx_4.14.98_2.3.0"
+SRCREV = "bb209a0b4ccca2aa4a3a887f9606dc4a3d294adf"
+PLATFORM_mx8qxp = "imx8qx"
+PLATFORM_mx8mn = "imx8mn"
# imx-atf 1.5 uses bl31-imx8qxp.bin, 2.0 will use bl31-imx8qx.bin for a
# platform specific filename. Provide both for now, so that the user of
# the file need not care.
do_deploy_append_mx8qxp () {
install -Dm 0644 ${S}/build/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-imx8qx.bin
+ install -Dm 0644 ${S}/build/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-imx8qxp.bin
}