summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2017-12-19 22:39:52 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-23 22:15:42 +0100
commit04e23f29eddd5691abed947a2e0dd364259248dc (patch)
tree72e3604b4dcb3741535d6e831ffa0e42332c250e
parent6ea16f817f7bafd02458163efadb488192cfaab2 (diff)
mesa: Remove parts provided by imx-gpu-viv v6
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
new file mode 100644
index 0000000..74396ae
--- /dev/null
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -0,0 +1,43 @@
+PACKAGECONFIG_remove_imxgpu2d = "egl gles gbm"
+
+PROVIDES_remove_imxgpu2d = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl gbm"
+PROVIDES_remove_imxgpu3d = "virtual/libgl"
+
+# FIXME: mesa should support 'x11-no-tls' option
+python () {
+ overrides = d.getVar("OVERRIDES", True).split(":")
+ if "imxgpu2d" not in overrides:
+ return
+
+ x11flag = d.getVarFlag("PACKAGECONFIG", "x11", False)
+ d.setVarFlag("PACKAGECONFIG", "x11", x11flag.replace("--enable-glx-tls", "--enable-glx"))
+}
+
+# Enable Etnaviv support
+PACKAGECONFIG_append_use-mainline-bsp = " gallium"
+GALLIUMDRIVERS_append_use-mainline-bsp = ",etnaviv,imx"
+
+BACKEND = \
+ "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
+ 'fb', d), d)}"
+
+# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
+do_install_append_imxgpu3d () {
+ rm -f ${D}${libdir}/libGL.* \
+ ${D}${includedir}/GL/gl.h \
+ ${D}${includedir}/GL/glext.h \
+ ${D}${includedir}/GL/glx.h \
+ ${D}${includedir}/GL/glxext.h
+ if [ "${BACKEND}" = "x11" ]; then
+ rm -f ${D}${libdir}/pkgconfig/gl.pc
+ fi
+}
+
+do_install_append_imxgpu2d () {
+ rm -f ${D}${libdir}/pkgconfig/wayland-egl.pc
+}
+
+do_install_append_imxgpu2d () {
+ rm -f ${D}${libdir}/pkgconfig/wayland-egl.pc
+}