summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-02-06 18:22:20 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-02-06 18:22:20 +0100
commit5069b6c34557cb98c6cc3cb16b4cc8d3cd4afc21 (patch)
tree649860378bf518e63a8a2402312e20b13966ef3d
parentfacab872871fc6fc770b621c382ee99c60be86f7 (diff)
v4l-utils: fix for NULL not found erros
-rw-r--r--recipes-multimedia/v4l2apps/files/initalizer-not-const.patch12
-rw-r--r--recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bbappend6
2 files changed, 18 insertions, 0 deletions
diff --git a/recipes-multimedia/v4l2apps/files/initalizer-not-const.patch b/recipes-multimedia/v4l2apps/files/initalizer-not-const.patch
new file mode 100644
index 0000000..85ff161
--- /dev/null
+++ b/recipes-multimedia/v4l2apps/files/initalizer-not-const.patch
@@ -0,0 +1,12 @@
+NULL is no longer defined in what is included resulting in compile time errors.
+Include stddef.h to make it available
+--- git/utils/dvb/dvb_frontend.h~ 2013-02-05 18:13:39.000000000 +0100
++++ git/utils/dvb/dvb_frontend.h 2013-02-05 18:14:43.723139932 +0100
+@@ -26,6 +26,7 @@
+ #ifndef _DVBFRONTEND_H_
+ #define _DVBFRONTEND_H_
+
++#include <stddef.h>
+ #include <linux/types.h>
+
+ typedef enum fe_type {
diff --git a/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bbappend b/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bbappend
new file mode 100644
index 0000000..fbbe6b4
--- /dev/null
+++ b/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+PRINC = "1"
+
+SRC_URI += "file://initalizer-not-const.patch"
+