summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2016-09-28 11:00:23 -0700
committerMax Krummenacher <max.krummenacher@toradex.com>2016-09-29 21:09:58 +0200
commit9d897e89564ccbf9d659d74427fdcc2f1961ccf2 (patch)
treec50062e42d6718c4977a8a8d09dbaa2d6277732f
parent72953ce96e819afa84389a56c8f814969029bbc9 (diff)
xorg-server: add xorg.conf for Vybrid
Add default xorg.conf for Vybrid based modules. This makes sure that the DRM enabled modesetting DDX driver gets used. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/colibri-vf/xorg.conf39
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend1
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/colibri-vf/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/colibri-vf/xorg.conf
new file mode 100644
index 0000000..ee77e84
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/colibri-vf/xorg.conf
@@ -0,0 +1,39 @@
+# Default Xorg configuration for Toradex Colibri VF50/VF61 modules
+# (Freescale/NXP Vybrid based modules)
+#
+# This configuration uses the Xorg modesetting DDX driver, which requires
+# the DRM based DCU kernel driver (CONFIG_DRM_FSL_DCU)
+#
+
+Section "Device"
+ Identifier "FSL-DCU"
+ Driver "modesetting"
+ Option "kmsdev" "/dev/dri/card0"
+EndSection
+
+Section "Monitor"
+ Identifier "LCD"
+ Option "DPMS" "off"
+EndSection
+
+Section "Screen"
+ Identifier "Main"
+ Device "FSL-DCU"
+ Monitor "LCD"
+ DefaultDepth 16
+EndSection
+
+Section "ServerFlags"
+ Option "BlankTime" "0"
+ Option "StandbyTime" "0"
+ Option "SuspendTime" "0"
+ Option "OffTime" "0"
+EndSection
+
+Section "InputClass"
+ Identifier "Fusion 7/10"
+ Driver "evdev"
+ MatchProduct "fusion_F0710A"
+ MatchDevicePath "/dev/input/event*"
+EndSection
+
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 0000000..3feb3b1
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/xserver-xf86-config:"