summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2021-02-15 10:59:56 +0100
committerMing Liu <ming.liu@toradex.com>2021-03-03 11:08:36 +0100
commit1be428ed72974888790268eb7b95c1e354b1c72b (patch)
treebeee511c6c17ef6482da1aec15a1e3164d9c4a2c
parentddd76cf2bb716014a6a66604752803a306b1dc61 (diff)
device-tree-overlays: inherit toradex-devicetree
We have introduced toradex-devicetree.bbclass in BSP common layer, let's inherit it. Related-to: TOR-1700 Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--recipes-kernel/linux/device-tree-overlays_git.bb16
1 files changed, 3 insertions, 13 deletions
diff --git a/recipes-kernel/linux/device-tree-overlays_git.bb b/recipes-kernel/linux/device-tree-overlays_git.bb
index a06016f..9e8e514 100644
--- a/recipes-kernel/linux/device-tree-overlays_git.bb
+++ b/recipes-kernel/linux/device-tree-overlays_git.bb
@@ -1,21 +1,9 @@
-SUMMARY = "Toradex BSP device tree overlays"
-DESCRIPTION = "Toradex BSP device tree overlays from within layer."
-
-SRC_URI = "git://git.toradex.com/device-tree-overlays.git;branch=${SRCBRANCH};protocol=https"
+inherit toradex-devicetree
SRCBRANCH = "toradex_5.4-2.3.x-imx"
-
SRCREV = "84362081d1656a820a481155c218ffcd76483526"
SRCREV_use-head-next = "${AUTOREV}"
-PV = "${SRCBRANCH}+git${SRCPV}"
-
-inherit devicetree
-
-S = "${WORKDIR}/git/overlays"
-
-COMPATIBLE_MACHINE = ".*(mx[678]).*"
-
# we have dtbo's in arm and arm64 architecture, set the include paths
# to include both architectures.
KERNEL_INCLUDE = " \
@@ -25,3 +13,5 @@ KERNEL_INCLUDE = " \
${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/* \
${STAGING_KERNEL_DIR}/scripts/dtc/include-prefixes \
"
+
+COMPATIBLE_MACHINE = ".*(mx[678]).*"