summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-11-03 20:10:42 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-11-03 20:31:12 +0100
commit1f9b05bc296f5c16a0c2e1a8add56c4074facf61 (patch)
tree1bc88c1cd7871bcdf08c938222028581e954a2bd
parent84dc95f2e62ef9179c499d7d1c3eca72e3e8ae29 (diff)
weston: revert use systemd notify
Commit 4efdcc1090 ("weston: Use systemd notify,") in openembedded-core introduced systemd notify for weston. This seems, at least in our configuration, not to work, both with openembedded weston 8.0.0 and NXP's fork weston 9.0.0.imx. Weston starts but systemd does kill it after a timeout as it does not receive a notification from the spawned deamon. Comment the relevant lines in the service file, so that systemd does not expect any notification. Compare also with https://github.com/Freescale/meta-freescale/issues/901 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index d2eba90..d5f911a 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -47,3 +47,11 @@ do_install_append_upstream_colibri-imx7() {
do_install_append_upstream_colibri-imx7-emmc() {
configure_pixman
}
+
+# openembedded-core commit 4efdcc1090 ("weston: Use systemd notify,")
+# forces systemd-notify which in our setup does not work. Uncomment the
+# relevant lines for now.
+do_install_append() {
+ sed -i 's/\(Type=notify\)/# \1/' ${D}${systemd_system_unitdir}/weston@.service
+ sed -i 's/\(NotifyAccess=all\)/# \1/' ${D}${systemd_system_unitdir}/weston@.service
+}