summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-01-28 16:46:39 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-01-30 19:38:06 +0100
commit29d018f8ce6791eff56526c0fa57b90ab221dc63 (patch)
treea214916a6ba3e9be238e8fe0791d6af7fbe97324
parenta37e98833f48069228db85bfabb217bccb136c76 (diff)
imx-vpuwrap: update to 4.5.7
NXP release imx_5.4.70_2.3.0. Related-to: ELB-3327 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--backports/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.7.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/backports/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.7.bb b/backports/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.7.bb
new file mode 100644
index 0000000..2b02823
--- /dev/null
+++ b/backports/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.7.bb
@@ -0,0 +1,29 @@
+# Copyright (C) 2013-2016 Freescale Semiconductor
+# Copyright (C) 2017-2020 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Freescale Multimedia VPU wrapper"
+LICENSE = "Proprietary"
+SECTION = "multimedia"
+LIC_FILES_CHKSUM = "file://COPYING;md5=228c72f2a91452b8a03c4cab30f30ef9"
+
+DEPENDS = "virtual/imxvpu"
+DEPENDS_append_mx8mp = " imx-vpu-hantro-vc"
+
+SRC_URI = "git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH}"
+
+SRCBRANCH = "MM_04.05.07_2011_L5.4.70"
+SRCREV = "ccaf10a0dae7c0d7d204bd64282598bc0e3bd661"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ # FIXME: Drop examples for now
+ rm -r ${D}${datadir}
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+COMPATIBLE_MACHINE = "(imxvpu)"