summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-02-23 15:19:00 +0100
committerMing Liu <ming.liu@toradex.int>2022-02-26 13:44:50 +0000
commit4e347e7ea7e615cc4eedaa6e25ad700fa2ed2bcc (patch)
tree4fc643a48e5cdf3fbf5197dbd57b3c7e7e02a7c7
parent4cc37e369a36f31327461a361b4bdf1ca275e8ff (diff)
firmware-imx-8: drop a Toradex specific fix
We dont have to install HDMI firmwares to firmware-imx-8 main package any more, they are now already in firmware-imx-hdmi subpackage. Related-to: ELB-3046 Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--conf/machine/apalis-imx8.conf4
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8_8.%.bbappend14
2 files changed, 1 insertions, 17 deletions
diff --git a/conf/machine/apalis-imx8.conf b/conf/machine/apalis-imx8.conf
index 68263f8..53dd83d 100644
--- a/conf/machine/apalis-imx8.conf
+++ b/conf/machine/apalis-imx8.conf
@@ -62,9 +62,7 @@ PREFERRED_PROVIDER_u-boot = "u-boot-toradex"
# not yet available in 2020.07.
PREFERRED_VERSION_u-boot-toradex = "2020.04%"
-MACHINE_FIRMWARE_append = " linux-firmware-pcie8997"
-MACHINE_FIRMWARE_append = " firmware-imx-vpu-imx8"
-MACHINE_FIRMWARE_append = " firmware-imx-8"
+MACHINE_FIRMWARE_append = " linux-firmware-pcie8997 firmware-imx-hdmi firmware-imx-vpu-imx8"
IMXBOOT_TARGETS = "flash_b0"
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8_8.%.bbappend b/recipes-bsp/firmware-imx/firmware-imx-8_8.%.bbappend
deleted file mode 100644
index 1766a7a..0000000
--- a/recipes-bsp/firmware-imx/firmware-imx-8_8.%.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-FILES_${PN} += " \
- ${nonarch_base_libdir}/firmware/imx/hdmi/hdmitxfw.bin \
- ${nonarch_base_libdir}/firmware/imx/hdmi/hdmirxfw.bin \
- ${nonarch_base_libdir}/firmware/imx/hdmi/dpfw.bin \
-"
-
-unset do_install[noexec]
-
-do_install_append () {
- install -d ${D}${nonarch_base_libdir}/firmware/imx/hdmi
- install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi/
- install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi/
- install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi/
-}