summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-08-14 14:01:23 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2014-10-06 14:23:05 +0200
commit214a82b79e0ef67a58ef9951a109ed560c40f273 (patch)
treea60d8fac0c8440456f0adf19912df6c9090a2a00
parent5d4ccacff64c9c0440e2d27b6e5b5fa598b5dbe2 (diff)
colibri-imx6: refactor recipes for new module
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb7
-rw-r--r--recipes-kernel/linux/linux-toradex-fsl_git.bb10
2 files changed, 9 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
index 34b9a26..b833288 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
@@ -12,16 +12,17 @@ S = "${WORKDIR}/git"
SRCREV_colibri-vf = "36b44c6fc7ddde29aec7f39ebcb5cc959d24b469"
SRCBRANCH_colibri-vf = "2014.04-toradex"
-SRCREV_apalis-imx6 = "36b44c6fc7ddde29aec7f39ebcb5cc959d24b469"
-SRCBRANCH_apalis-imx6 = "2014.04-toradex"
+SRCREV_mx6 = "36b44c6fc7ddde29aec7f39ebcb5cc959d24b469"
+SRCBRANCH_mx6 = "2014.04-toradex"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
#FILESPATHPKG =. "git:"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(colibri-vf|apalis-imx6)"
+COMPATIBLE_MACHINE = "(colibri-vf|colibri-imx6|apalis-imx6)"
DEFAULT_PREFERENCE_colibri-vf = "1"
DEFAULT_PREFERENCE_apalis-imx6 = "1"
+DEFAULT_PREFERENCE_colibri-imx6 = "1"
# colibri_vf: copy additional U-Boot binary for NAND
UBOOT_BINARY_NAND_colibri-vf = "u-boot-nand.imx"
diff --git a/recipes-kernel/linux/linux-toradex-fsl_git.bb b/recipes-kernel/linux/linux-toradex-fsl_git.bb
index d653f26..fc88680 100644
--- a/recipes-kernel/linux/linux-toradex-fsl_git.bb
+++ b/recipes-kernel/linux/linux-toradex-fsl_git.bb
@@ -10,22 +10,22 @@ require recipes-kernel/linux/linux-dtb.inc
DEPENDS += "lzop-native "
LINUX_VERSION_colibri-vf = "3.0.15"
-LINUX_VERSION_apalis-imx6 = "3.10.17"
+LINUX_VERSION_mx6 = "3.10.17"
SRCREV_colibri-vf = "1d876acfd2cd445fe46e5bc4c531da2c6bef0c91"
PR_colibri-vf = "V2.3b1"
-SRCREV_apalis-imx6 = "485787d21c9ddefb9f992bf5190e9c4b8d9154b4"
-PR_apalis-imx6 = "V2.3b1"
+SRCREV_mx6 = "485787d21c9ddefb9f992bf5190e9c4b8d9154b4"
+PR_mx6 = "V2.3b1"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
S = "${WORKDIR}/git"
SRCBRANCH_colibri-vf = "colibri_vf"
-SRCBRANCH_apalis-imx6 = "toradex_imx_3.10.17_1.0.0_ga"
+SRCBRANCH_mx6 = "toradex_imx_3.10.17_1.0.0_ga"
SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=${SRCBRANCH}"
# a Patch
# SRC_URI_append_mx6 += "file://a.patch "
-COMPATIBLE_MACHINE = "(colibri-vf|apalis-imx6)"
+COMPATIBLE_MACHINE = "(colibri-vf|colibri-imx6|apalis-imx6)"
# Place changes to the defconfig here
config_script () {