summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-10-19 14:08:32 +0200
committerStefan Agner <stefan.agner@toradex.com>2017-11-27 11:30:46 +0100
commit0ab4eef6a6d1d0500a4128fee5cd49ff50000d4f (patch)
tree538ef57e262afa668cef98e9a68444459520f261
parent4a567ef806c5491e59f8e5590bfb064f3b3327d0 (diff)
u-boot recipes: automatically update to latest -next through override
This can be used e.g. for a CI setup to do nightly builds of latest and greatest. To use HEAD of xxx-next instead of the pinned version one would add in local.conf: MACHINEOVERRIDES =. "use-head-next:" Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2016.11.bb1
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend3
3 files changed, 6 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
index 7f73228..3c3239c 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
@@ -18,6 +18,8 @@ FILESPATHPKG =. "git:"
SRCREV = "1b121c6ab548a9af0a27876e9eaa0c654c1dc3e1"
SRCBRANCH = "2016.11-toradex"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "2016.11-toradex-next"
SRC_URI = " \
git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
file://fw_env.config \
@@ -25,7 +27,7 @@ SRC_URI = " \
"
PV = "2016.11"
-PR = "${TDX_VER_INT}+gitr${@d.getVar("SRCREV", False)[0:7]}"
+PR = "${TDX_VER_INT}+gitr${SRCPV}"
LOCALVERSION ?= "-${TDX_VER_INT}"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
index 68bb050..8b4c666 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
@@ -2,6 +2,7 @@ require recipes-bsp/u-boot/u-boot-toradex.inc
DESCRIPTION = "U-Boot for NXP based Toradex Computer on Modules"
PV = "2016.11"
+PR = "${TDX_VER_INT}+gitr${SRCPV}"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
index f9c6ab4..a195d01 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
+++ b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
@@ -1,9 +1,10 @@
include conf/tdx_version.conf
-PR = "${TDX_VER_INT}+gitr${@d.getVar("SRCREV", False)[0:7]}"
LOCALVERSION ?= "-${TDX_VER_INT}"
#LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
SRCREV = "1b121c6ab548a9af0a27876e9eaa0c654c1dc3e1"
SRCBRANCH = "2016.11-toradex"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "2016.11-toradex-next"