summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-01-17 19:20:36 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-03-23 16:51:12 +0100
commit56ae59dc5f34dc8fa07884a0d2cb0c3e795287cc (patch)
treee338ae695eb1229493b0bcd41a8ca3c2bde5c628
parent960369345d92b189b4d1af0701da75c9b8d3767a (diff)
u-boot-toradex: drop building a recovery u-boot
We move to use SPL/u-boot.img also in the recovery case. Drop building the u-boot-recover.imx and no longer rename the u-boot-spl.img file to the misleading name u-boot-spl.imx. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--conf/machine/include/apalis-imx6.inc9
-rw-r--r--conf/machine/include/colibri-imx6.inc5
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend53
3 files changed, 2 insertions, 65 deletions
diff --git a/conf/machine/include/apalis-imx6.inc b/conf/machine/include/apalis-imx6.inc
index 8d2ad67..6d6cbfa 100644
--- a/conf/machine/include/apalis-imx6.inc
+++ b/conf/machine/include/apalis-imx6.inc
@@ -7,14 +7,7 @@ OFFSET_SPL_PAYLOAD = "138"
KERNEL_DEVICETREE_remove = "imx6q-apalis_v1_0-eval.dtb imx6q-apalis_v1_0-ixora.dtb"
-# The SPL configures the DDR RAM depending on the module it runs on. Thus there
-# is no need to distingush between the different module types.
-# For recovery mode we build a U-Boot with IVT which runs without SPL. It uses
-# save timings for all known Apalis iMX6.
-# Note: The last config will be symlinked to UBOOT_BINARY which is crucial for
-# certain image formats.
-UBOOT_CONFIG ?= "recover spl"
-UBOOT_CONFIG[recover] = "apalis_imx6_nospl_it_defconfig,,u-boot.imx"
+UBOOT_SUFFIX = "img"
PREFERRED_PROVIDER_virtual/libg2d_mx6 ?= "imx-gpu-g2d"
diff --git a/conf/machine/include/colibri-imx6.inc b/conf/machine/include/colibri-imx6.inc
index 6538ab0..a20afe7 100644
--- a/conf/machine/include/colibri-imx6.inc
+++ b/conf/machine/include/colibri-imx6.inc
@@ -5,10 +5,7 @@ TORADEX_PRODUCT_IDS = "0014 0015 0016 0017"
OFFSET_BOOTROM_PAYLOAD = "2"
OFFSET_SPL_PAYLOAD = "138"
-# Note: The last config will be symlinked to UBOOT_BINARY which is crucial for
-# certain image formats.
-UBOOT_CONFIG ?= "recover spl"
-UBOOT_CONFIG[recover] = "colibri_imx6_nospl_defconfig,,u-boot.imx"
+UBOOT_SUFFIX = "img"
PREFERRED_PROVIDER_virtual/libg2d_mx6 ?= "imx-gpu-g2d"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
index 095e4c7..22e9d2f 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
+++ b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
@@ -6,56 +6,3 @@ SRCREV = "30a1208727729dae22cb42f9ba9ba17efe5e6f77"
SRCBRANCH = "2016.11-toradex"
SRCREV_use-head-next = "${AUTOREV}"
SRCBRANCH_use-head-next = "2016.11-toradex-next"
-
-# Hack around building two U-Boot configurations, one with, one without SPL
-# if using UBOOT_CONFIG to build more than one configuration, the current code in
-# u-boot.inc assumes all are either with or without SPL.
-compile_add() {
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- touch ${B}/${config}/${SPL_BINARY}
- done
- fi
-}
-deploy_add() {
- # if SPL is zero sized file, remove all deployed artefacts
- if [ -n "${SPL_BINARY}" ]
- then
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- i=$(expr $i + 1);
- for type in ${UBOOT_CONFIG}; do
- j=$(expr $j + 1);
- if [ $j -eq $i ]
- then
- if [ ! -s ${DEPLOYDIR}/${SPL_IMAGE}-${type}-${PV}-${PR} ]
- then
- rm -f ${DEPLOYDIR}/${SPL_IMAGE}-${type}-${PV}-${PR}
- rm -f ${DEPLOYDIR}/${SPL_BINARYNAME}-${type}
- rm -f ${DEPLOYDIR}/${SPL_SYMLINK}-${type}
- rm -f ${DEPLOYDIR}/${SPL_SYMLINK}
- else
- ln -sf ${SPL_IMAGE}-${type}-${PV}-${PR} ${SPL_BINARYNAME}
- fi
- fi
- done
- unset j
- done
- unset i
- fi
- fi
-}
-do_compile_append_mx6() {
- compile_add
-}
-do_compile_append_use-mainline-bsp() {
- compile_add
-}
-do_deploy_append_mx6() {
- deploy_add
-}
-do_deploy_append_use-mainline-bsp() {
- deploy_add
-}