summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 13:58:48 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 16:15:45 +0100
commit0680d4fbd8f543861549c66cf9602edd29447b66 (patch)
treee85d78701c6a0fe521d6aa2a4bf442d1d74ca9d3
parent526955065f90934ec829cfe3dc18de938497b062 (diff)
linux-toradex: drop include tdx_version.conf
Variables from tdx_version.conf are now provided by the distro. Add defaults in case someone doesn't use our distro. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-toradex-rt_4.4.bb4
-rw-r--r--recipes-kernel/linux/linux-toradex_4.4.bbappend5
-rw-r--r--recipes-kernel/linux/linux-toradex_4.9-2.3.x.bb4
3 files changed, 9 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-toradex-rt_4.4.bb b/recipes-kernel/linux/linux-toradex-rt_4.4.bb
index 25e56e9..7a95186 100644
--- a/recipes-kernel/linux/linux-toradex-rt_4.4.bb
+++ b/recipes-kernel/linux/linux-toradex-rt_4.4.bb
@@ -1,5 +1,4 @@
require recipes-kernel/linux/linux-imx.inc
-include conf/tdx_version.conf
SUMMARY = "Linux kernel with real-time patch for Toradex Colibri VFxx Computer on Modules"
@@ -23,3 +22,6 @@ SRCREV_use-head-next = "${AUTOREV}"
SRCBRANCH_use-head-next = "toradex_vf_4.4-next"
DEPENDS += "lzop-native bc-native"
COMPATIBLE_MACHINE = "(vf)"
+
+# defaults
+TDX_VER_ITEM ??= "0"
diff --git a/recipes-kernel/linux/linux-toradex_4.4.bbappend b/recipes-kernel/linux/linux-toradex_4.4.bbappend
index 1d37124..99daf79 100644
--- a/recipes-kernel/linux/linux-toradex_4.4.bbappend
+++ b/recipes-kernel/linux/linux-toradex_4.4.bbappend
@@ -1,5 +1,3 @@
-include conf/tdx_version.conf
-
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-toradex-4.4:"
LOCALVERSION = "-${TDX_VER_ITEM}"
@@ -8,3 +6,6 @@ SRCREV = "09733c33a1e232097653c96bd788848129c95c7e"
SRCBRANCH = "toradex_vf_4.4"
SRCREV_use-head-next = "${AUTOREV}"
SRCBRANCH_use-head-next = "toradex_vf_4.4-next"
+
+# defaults
+TDX_VER_ITEM ??= "0"
diff --git a/recipes-kernel/linux/linux-toradex_4.9-2.3.x.bb b/recipes-kernel/linux/linux-toradex_4.9-2.3.x.bb
index 8e46c9d..7c27727 100644
--- a/recipes-kernel/linux/linux-toradex_4.9-2.3.x.bb
+++ b/recipes-kernel/linux/linux-toradex_4.9-2.3.x.bb
@@ -1,6 +1,5 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
require recipes-kernel/linux/linux-imx.inc
-include conf/tdx_version.conf
SUMMARY = "Linux kernel for Toradex Freescale i.MX based modules"
@@ -20,3 +19,6 @@ SRCBRANCH_use-head-next = "toradex_4.9-2.3.x-imx-next"
DEPENDS += "lzop-native bc-native"
COMPATIBLE_MACHINE = "(mx6|mx7)"
+
+# defaults
+TDX_VER_ITEM ??= "0"