summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-04-18 12:27:48 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-04-23 09:55:04 +0200
commit1724af6c8db837f645fe4c18a85b435c5f5d55ff (patch)
treef5113c1a06463023a503ef8650b9c2d5f717b338
parentce5a4e1eeb6a3bd712f55e6460e7133a5dd84df5 (diff)
linux-toradex: add inital 4.14.78 for i.MX8 recipe
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-imx/0001-uapi-Add-ion.h-to-userspace.patch22
-rw-r--r--recipes-kernel/linux/linux-toradex_4.14.%.bbappend5
-rw-r--r--recipes-kernel/linux/linux-toradex_4.14.78.bb45
-rw-r--r--recipes-kernel/linux/linux-toradex_4.14.78.inc13
4 files changed, 85 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx/0001-uapi-Add-ion.h-to-userspace.patch b/recipes-kernel/linux/linux-imx/0001-uapi-Add-ion.h-to-userspace.patch
new file mode 100644
index 0000000..f2c3a6d
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx/0001-uapi-Add-ion.h-to-userspace.patch
@@ -0,0 +1,22 @@
+From dd5b2075480bcb6787f7342f341559ca13fdfbef Mon Sep 17 00:00:00 2001
+From: Tom Hochstein <tom.hochstein@nxp.com>
+Date: Fri, 24 Aug 2018 17:40:29 -0500
+Subject: [PATCH] uapi: Add ion.h to userspace
+
+Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
+---
+ include/uapi/linux/ion.h | 1 +
+ 1 file changed, 1 insertion(+)
+ create mode 120000 include/uapi/linux/ion.h
+
+diff --git a/include/uapi/linux/ion.h b/include/uapi/linux/ion.h
+new file mode 120000
+index 0000000..17e8dbb
+--- /dev/null
++++ b/include/uapi/linux/ion.h
+@@ -0,0 +1 @@
++../../../drivers/staging/android/uapi/ion.h
+\ No newline at end of file
+--
+2.7.4
+
diff --git a/recipes-kernel/linux/linux-toradex_4.14.%.bbappend b/recipes-kernel/linux/linux-toradex_4.14.%.bbappend
new file mode 100644
index 0000000..cf4daa9
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex_4.14.%.bbappend
@@ -0,0 +1,5 @@
+# Copyright (C) 2013-2016 Freescale Semiconductor
+# Copyright 2017 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+inherit fsl-vivante-kernel-driver-handler
diff --git a/recipes-kernel/linux/linux-toradex_4.14.78.bb b/recipes-kernel/linux/linux-toradex_4.14.78.bb
new file mode 100644
index 0000000..7a0a6f7
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex_4.14.78.bb
@@ -0,0 +1,45 @@
+# Copyright (C) 2013-2016 Freescale Semiconductor
+# Copyright 2017-2018 NXP
+# Copyright 2018 Toradex AG
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Linux Kernel provided and supported by Toradex"
+DESCRIPTION = "Linux Kernel provided and supported by Toradex based on NXP"
+
+require recipes-kernel/linux/linux-imx.inc
+require recipes-kernel/linux/linux-toradex_${PV}.inc
+
+DEPENDS += "lzop-native bc-native"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-imx:"
+SRC_URI += "file://0001-uapi-Add-ion.h-to-userspace.patch"
+
+DEFAULT_PREFERENCE = "1"
+
+DO_CONFIG_V7_COPY = "no"
+DO_CONFIG_V7_COPY_mx6 = "yes"
+DO_CONFIG_V7_COPY_mx7 = "yes"
+DO_CONFIG_V7_COPY_mx8 = "no"
+
+addtask copy_defconfig after do_unpack before do_preconfigure
+do_copy_defconfig () {
+ install -d ${B}
+ if [ ${DO_CONFIG_V7_COPY} = "yes" ]; then
+ # copy latest imx_v7_defconfig to use for mx6, mx6ul and mx7
+ mkdir -p ${B}
+ cp ${S}/arch/arm/configs/imx_v7_defconfig ${B}/.config
+ cp ${S}/arch/arm/configs/imx_v7_defconfig ${B}/../defconfig
+ else
+ # copy latest defconfig to use for mx8
+ mkdir -p ${B}
+ cp ${S}/arch/arm64/configs/defconfig ${B}/.config
+ cp ${S}/arch/arm64/configs/defconfig ${B}/../defconfig
+ fi
+}
+
+# Currently only ported for i.MX8 based SoMs
+#COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"
+COMPATIBLE_MACHINE = "(mx8)"
+EXTRA_OEMAKE_append_mx6 = " ARCH=arm"
+EXTRA_OEMAKE_append_mx7 = " ARCH=arm"
+EXTRA_OEMAKE_append_mx8 = " ARCH=arm64"
diff --git a/recipes-kernel/linux/linux-toradex_4.14.78.inc b/recipes-kernel/linux/linux-toradex_4.14.78.inc
new file mode 100644
index 0000000..c3a04b0
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex_4.14.78.inc
@@ -0,0 +1,13 @@
+# Copyright 2017-2018 NXP
+# Copyright 2018 Toradex AG
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+LOCALVERSION = "-${TDX_VER_ITEM}"
+
+KERNEL_SRC ?= "git://git.toradex.com/linux-toradex.git;protocol=https"
+SRC_URI = "${KERNEL_SRC};branch=${SRCBRANCH}"
+
+SRCREV = "fc45c31ab82747d1f766610b443c427ba693cdf6"
+SRCBRANCH = "toradex_imx_4.14.78_1.0.0_ga-bring_up"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "toradex_imx_4.14.78_1.0.0_ga-bring_up"