summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-11-20 12:51:10 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 16:15:32 +0100
commit2951149d43f771768f0b2823665b4887b7e20b4b (patch)
treee527d0daef0cae3913902a1aee5c1e46cc15f799
parentf11b9f99d48bd6db2283e376131861f4dff3ddc1 (diff)
u-boot-toradex-fw-utils: rework after move to 3rdparty
The recipe got moved to meta-freescale-3rdparty. Rework additional settings into a bbappend. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/u-boot/files/colibri-imx6ull/fw_env.config11
-rw-r--r--recipes-bsp/u-boot/files/colibri-imx7/fw_env.config11
-rw-r--r--recipes-bsp/u-boot/files/default-gcc.patch39
-rw-r--r--recipes-bsp/u-boot/files/fw_env.config22
-rw-r--r--recipes-bsp/u-boot/files/mx6/fw_env.config15
-rw-r--r--recipes-bsp/u-boot/files/vf/fw_env.config11
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb79
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend31
8 files changed, 31 insertions, 188 deletions
diff --git a/recipes-bsp/u-boot/files/colibri-imx6ull/fw_env.config b/recipes-bsp/u-boot/files/colibri-imx6ull/fw_env.config
deleted file mode 100644
index 30b8b90..0000000
--- a/recipes-bsp/u-boot/files/colibri-imx6ull/fw_env.config
+++ /dev/null
@@ -1,11 +0,0 @@
-# Configuration file for fw_(printenv/setenv) utility.
-# Up to two entries are valid, in this case the redundant
-# environment sector is assumed present.
-# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
-# Futhermore, if the Flash sector size is ommitted, this value is assumed to
-# be the same as the Environment size, which is valid for NOR and SPI-dataflash
-
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-# Colibri iMX7
-/dev/mtd3 0x00000000 0x00020000 0x20000 4
-
diff --git a/recipes-bsp/u-boot/files/colibri-imx7/fw_env.config b/recipes-bsp/u-boot/files/colibri-imx7/fw_env.config
deleted file mode 100644
index 30b8b90..0000000
--- a/recipes-bsp/u-boot/files/colibri-imx7/fw_env.config
+++ /dev/null
@@ -1,11 +0,0 @@
-# Configuration file for fw_(printenv/setenv) utility.
-# Up to two entries are valid, in this case the redundant
-# environment sector is assumed present.
-# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
-# Futhermore, if the Flash sector size is ommitted, this value is assumed to
-# be the same as the Environment size, which is valid for NOR and SPI-dataflash
-
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-# Colibri iMX7
-/dev/mtd3 0x00000000 0x00020000 0x20000 4
-
diff --git a/recipes-bsp/u-boot/files/default-gcc.patch b/recipes-bsp/u-boot/files/default-gcc.patch
deleted file mode 100644
index 04184df..0000000
--- a/recipes-bsp/u-boot/files/default-gcc.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-OE needs to be able to change the default compiler. If we pass in HOSTCC
-through the make command, it overwrites not only this setting but also the
-setting in tools/Makefile wrapped in ifneq ($(CROSS_BUILD_TOOLS),) which
-breaks the build.
-
-We therefore use override to ensure the value of HOSTCC is overwritten when
-needed.
-
-RP: Updated the patch to the version being submitted to upstream u-boot
-
-Upstream-Status: Submitted [emailed to Masahiro Yamada for discussion]
-RP 2017/3/11
-
-Index: git/tools/Makefile
-===================================================================
---- git.orig/tools/Makefile
-+++ git/tools/Makefile
-@@ -262,7 +262,7 @@ $(LICENSE_H): $(obj)/bin2header $(srctre
- subdir- += env
-
- ifneq ($(CROSS_BUILD_TOOLS),)
--HOSTCC = $(CC)
-+override HOSTCC = $(CC)
-
- quiet_cmd_crosstools_strip = STRIP $^
- cmd_crosstools_strip = $(STRIP) $^; touch $@
-Index: git/tools/env/Makefile
-===================================================================
---- git.orig/tools/env/Makefile
-+++ git/tools/env/Makefile
-@@ -8,7 +8,7 @@
- # fw_printenv is supposed to run on the target system, which means it should be
- # built with cross tools. Although it may look weird, we only replace "HOSTCC"
- # with "CC" here for the maximum code reuse of scripts/Makefile.host.
--HOSTCC = $(CC)
-+override HOSTCC = $(CC)
-
- # Compile for a hosted environment on the target
- HOST_EXTRACFLAGS = $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
diff --git a/recipes-bsp/u-boot/files/fw_env.config b/recipes-bsp/u-boot/files/fw_env.config
deleted file mode 100644
index e054ccb..0000000
--- a/recipes-bsp/u-boot/files/fw_env.config
+++ /dev/null
@@ -1,22 +0,0 @@
-# Configuration file for fw_(printenv/setenv) utility.
-# Up to two entries are valid, in this case the redundant
-# environment sector is assumed present.
-# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
-# Futhermore, if the Flash sector size is ommitted, this value is assumed to
-# be the same as the Environment size, which is valid for NOR and SPI-dataflash
-
-# NOR example
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-#/dev/mtd1 0x0000 0x4000 0x4000
-#/dev/mtd2 0x0000 0x4000 0x4000
-
-# MTD SPI-dataflash example
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-#/dev/mtd5 0x4200 0x4200
-#/dev/mtd6 0x4200 0x4200
-
-# NAND example
-#/dev/mtd0 0x4000 0x4000 0x20000 2
-
-# Block device example
-#/dev/mmcblk0 0xc0000 0x20000
diff --git a/recipes-bsp/u-boot/files/mx6/fw_env.config b/recipes-bsp/u-boot/files/mx6/fw_env.config
deleted file mode 100644
index 731d874..0000000
--- a/recipes-bsp/u-boot/files/mx6/fw_env.config
+++ /dev/null
@@ -1,15 +0,0 @@
-# Configuration file for fw_(printenv/setenv) utility.
-# Up to two entries are valid, in this case the redundant
-# environment sector is assumed present.
-# Device offset must be prefixed with 0x to be parsed as a hexadecimal value.
-# On a block device a negative offset is treated as a backwards offset from the
-# end of the device/partition, rather than a forwards offset from the start.
-
-# Colibri iMX6/Apalis iMX6
-# U-Boot environment is stored at the end of the first eMMC boot partition
-# hence use a negative value. The environment is just in front of the config
-# block which occupies the last sector (hence -0x200)
-
-# Block device name Device offset Env. size
-/dev/mmcblk0boot0 -0x2200 0x2000
-
diff --git a/recipes-bsp/u-boot/files/vf/fw_env.config b/recipes-bsp/u-boot/files/vf/fw_env.config
deleted file mode 100644
index c1581ea..0000000
--- a/recipes-bsp/u-boot/files/vf/fw_env.config
+++ /dev/null
@@ -1,11 +0,0 @@
-# Configuration file for fw_(printenv/setenv) utility.
-# Up to two entries are valid, in this case the redundant
-# environment sector is assumed present.
-# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
-# Futhermore, if the Flash sector size is ommitted, this value is assumed to
-# be the same as the Environment size, which is valid for NOR and SPI-dataflash
-
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-# Colibri VF61
-/dev/mtd2 0x00000000 0x00020000 0x20000 4
-
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
deleted file mode 100644
index 09775c3..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
+++ /dev/null
@@ -1,79 +0,0 @@
-SUMMARY = "U-boot bootloader fw_printenv/setenv utils"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
-SECTION = "bootloader"
-PROVIDES = "u-boot-fw-utils"
-RPROVIDES_${PN} = "u-boot-fw-utils"
-DEPENDS = "mtd-utils"
-
-include conf/tdx_version.conf
-
-COMPATIBLE_MACHINE = "(apalis-imx*|colibri-imx*|colibri-vf*)"
-DEFAULT_PREFERENCE_apalis-imx6 = "1"
-DEFAULT_PREFERENCE_colibri-imx6 = "1"
-DEFAULT_PREFERENCE_colibri-imx7 = "1"
-DEFAULT_PREFERENCE_colibri-vf = "1"
-
-FILESPATHPKG =. "git:"
-
-# This revision is based on upstream "v2016.11"
-SRCREV = "02735f400478c6e9afc432fda1149abef630657c"
-SRCBRANCH = "2016.11-toradex"
-SRCREV_use-head-next = "${AUTOREV}"
-SRCBRANCH_use-head-next = "2016.11-toradex-next"
-SRC_URI = " \
- git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
- file://default-gcc.patch \
- file://fw_env.config \
- file://fw_unlock_mmc.sh \
-"
-
-PV = "2016.11+git${SRCPV}"
-LOCALVERSION ?= "-${TDX_VER_ITEM}"
-
-S = "${WORKDIR}/git"
-
-INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
-
-inherit pkgconfig uboot-config
-
-do_compile () {
- oe_runmake ${UBOOT_MACHINE}
- oe_runmake env
-}
-
-do_install () {
- install -d ${D}${base_sbindir} ${D}${sysconfdir}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
- ln -s fw_printenv ${D}${base_sbindir}/fw_setenv
- install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
-}
-
-install_unlock_emmc() {
- install -d ${D}${sysconfdir}/profile.d/
- install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
-}
-
-do_install_append_apalis-imx6() {
- install_unlock_emmc
-}
-
-do_install_append_colibri-imx6() {
- install_unlock_emmc
-}
-
-do_install_append_colibri-imx7-emmc() {
- install_unlock_emmc
-}
-
-do_install_class-cross () {
- install -d ${D}${bindir_cross}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
-}
-
-SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
new file mode 100644
index 0000000..00bc9de
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
@@ -0,0 +1,31 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+include conf/tdx_version.conf
+
+SRCREV = "02735f400478c6e9afc432fda1149abef630657c"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "2016.11-toradex-next"
+SRC_URI += "file://fw_unlock_mmc.sh"
+
+PV = "2016.11+git${SRCPV}"
+LOCALVERSION ?= "-${TDX_VER_ITEM}"
+
+S = "${WORKDIR}/git"
+
+install_unlock_emmc() {
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
+}
+
+do_install_append_apalis-imx6() {
+ install_unlock_emmc
+}
+
+do_install_append_colibri-imx6() {
+ install_unlock_emmc
+}
+
+do_install_append_colibri-imx7-emmc() {
+ install_unlock_emmc
+}
+