summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-07-10 18:29:12 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-07-10 19:47:15 +0200
commit6648fb0dba5a74f03c8ce2a542da4b2509918129 (patch)
treec25c67a6635d9c1b8e6c0aadcc18f65b72458400
parentddcdce6443b4926840265ad39139d8e485ab579e (diff)
u-boot-fw-utils: choose flavour though prefered provider
This allows to use u-boot-fw-utils in image recipes. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--conf/machine/apalis-imx8.conf1
-rw-r--r--conf/machine/colibri-imx6ull.conf1
-rw-r--r--conf/machine/colibri-imx7-emmc.conf1
-rw-r--r--conf/machine/colibri-imx8x.conf1
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb3
5 files changed, 7 insertions, 0 deletions
diff --git a/conf/machine/apalis-imx8.conf b/conf/machine/apalis-imx8.conf
index 1431cef..de28488 100644
--- a/conf/machine/apalis-imx8.conf
+++ b/conf/machine/apalis-imx8.conf
@@ -42,6 +42,7 @@ MACHINE_BOOT_FILES = "hdmitxfw.bin dpfw.bin"
PREFERRED_PROVIDER_virtual/kernel = "linux-toradex"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex"
+PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-toradex-fw-utils"
# Currently we use the nxp 2018.03 downstream for mx8 as some features are
# not yet available in 2019.03.
PREFERRED_VERSION_u-boot-toradex = "2018.03"
diff --git a/conf/machine/colibri-imx6ull.conf b/conf/machine/colibri-imx6ull.conf
index b339093..4aaedd6 100644
--- a/conf/machine/colibri-imx6ull.conf
+++ b/conf/machine/colibri-imx6ull.conf
@@ -20,6 +20,7 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
PREFERRED_PROVIDER_u-boot ?= "u-boot-toradex"
PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-toradex"
+PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-toradex-fw-utils"
UBOOT_BINARY = "u-boot-nand.imx"
UBOOT_MAKE_TARGET = "u-boot.imx"
UBOOT_MACHINE ?= "colibri-imx6ull_defconfig"
diff --git a/conf/machine/colibri-imx7-emmc.conf b/conf/machine/colibri-imx7-emmc.conf
index 5ec8dea..ddcf24b 100644
--- a/conf/machine/colibri-imx7-emmc.conf
+++ b/conf/machine/colibri-imx7-emmc.conf
@@ -18,6 +18,7 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
PREFERRED_PROVIDER_u-boot ?= "u-boot-toradex"
PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-toradex"
+PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-toradex-fw-utils"
UBOOT_MACHINE ?= "colibri_imx7_emmc_defconfig"
IMAGE_FSTYPES += "wic.gz tar.xz"
diff --git a/conf/machine/colibri-imx8x.conf b/conf/machine/colibri-imx8x.conf
index 4f445f6..70532bc 100644
--- a/conf/machine/colibri-imx8x.conf
+++ b/conf/machine/colibri-imx8x.conf
@@ -37,6 +37,7 @@ IMX_BOOT_SEEK = "32"
PREFERRED_PROVIDER_virtual/kernel = "linux-toradex"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex"
+PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-toradex-fw-utils"
# Currently we use the nxp 2018.03 downstream for mx8 as some features are
# not yet available in 2019.03.
PREFERRED_VERSION_u-boot-toradex = "2018.03"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb
index 45eaaa4..2c46a73 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb
@@ -44,6 +44,9 @@ do_install_class-cross () {
SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+PROVIDES += "u-boot-fw-utils"
+RPROVIDES_${PN} += "u-boot-fw-utils"
+
COMPATIBLE_MACHINE = "(mx8)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
BBCLASSEXTEND = "cross"